locked
Set permissions on Root of Public Folders in Exchange 2010? RRS feed

  • Question

  • I've been Googling for a while, and haven't found the answer...so I'll try here:

    We have created an AD group to deny access to all public folders in Exchange 2010. I used the following command to apply this group with a permission level of None to all public folders, and that worked well: 

    AddUserstoPFRecursive.ps1 -TopPublicFolder "\" -User "<group>" -Permission None

    This doesn't, however, do anything with new public folders created after this command was executed. My question here is: Is it possible to apply permissions to the Root (the "\", not the Top-Level Folders) Public Folder, so that any new Top-Level Public Folders would inherit those new permissions automatically? I've tried:

    Add-PublicFolderClientPermission -Identity "\" -User "<group>" -AccessRights None

    It results in:

    Failed to commit the change on object "\" because access is denied. + CategoryInfo : NotSpecified: (0:Int32) [Add-PublicFolderClientPermission], MapiAccessDeniedException + FullyQualifiedErrorId : 846560AB,Microsoft.Exchange.Management.MapiTasks.AddPublicFolderClientPermission

    Tuesday, August 4, 2015 2:36 AM

Answers

  • Hi,

    Q: Is it possible to apply permissions to the Root (the "\", not the Top-Level Folders) Public Folder, so that any new Top-Level Public Folders would inherit those new permissions automatically?

    By default, it’s not possible. We need to re-run AddUserstoPFRecursive.ps1 script to assign new permissions to new Top-Level Public Folders. Workaround: Add this command to Task Scheduler.

    About that error, the Identity parameter specifies the GUID or public folder name that represents a specific public folder. You can also include the path using the format TopLevelPublicFolder\PublicFolder.

    Best Regards.

    Wednesday, August 5, 2015 2:30 AM
    Moderator