locked
Routing Role for Remote Access Role, failure RRS feed

  • Question

  • Hey I'm having  areally strange issue with Server 2016 TP 5.

    I realized after I had initially installed the WAP Role under the Remote Services Role, I decided I needed the routing role as well. I attempted to check it off and sure enough it failed.. the error 0xc004000d

    I then rebooted the server, and to my dismay the initial WAP role I installed showed as unchecked, as if it wasn't even installed... so weird.

    so i decided to add all the check boxes and again and the role installation failed with the same error??? what's going on here?!??!

    Friday, June 3, 2016 10:07 PM

Answers

  • Alright, instead of wasting any more time on this. I simply re-installed my Server 2015 TP 5 from scratch.

    Installed VMware Tools, configured my Vmxnet3 nic, added to my domain (I decided to change to a different OU to prevent getting unwanted local right assignments)

    Installed just the Routing Role (Again not sure why Direct Access and IIS have to be requirements) however the installation of said feature worked without issue, didn't even need a reboot. I then was able to configure LAN routing under the Routing and remote access snap-in.

    If anyone else can confirm this wizard breaks when you select and install the WAP Role before the Routing role, that be great, but I just don't have time to re-test this.


    • Edited by Zewwy Monday, June 6, 2016 3:52 PM
    • Marked as answer by Zewwy Monday, June 6, 2016 3:52 PM
    Monday, June 6, 2016 3:52 PM

All replies

  • OK well this issue has gotten a little deeper than I wanted.. might might be on to something?

    What I noticed was even though the Role Failed with the above error code 0xc004000d stating the specific parent role is disabled, blah blah blah. The Roles wizards would still appear under the action centre after reboot, however would fail stating File C:\Windows\system32\RAMgmtUI.exe is not available, blah blah blah, to cut it short "a bug in MS Role deployment"

    Since the Roles themselves were checked off, I ran the removal wizard for the roles that didn't get installed properlly anyway.. :S, good news is, at least the removal of the roles goes without failure.

    So I googled the Error code in it's self and came across this.

    I noticed IIS was installed on this server (I'm presuming a dependency for one of the roles I deployed earlier)

    I removed the Remote Access Role, Rebooted, I removed the IIS Role, Rebooted. (Lucky all this succeeded without failure.)

    Installed ASP.NET 4.6 and .NET 3.5 (specified Server 2016 install media for source) (No reboot required apparently)

    Install Routing and WAP roles, select Routing (requires Direct Access and VPN Role (Why? who the heck knows why a router would possibly require these services as a dependency?!?!?) and IIS (Again why the heck would simple routing require IIS?!?!)) moving on. (check off include mgmt tools, and click add features)

    Check off WAP, Next

    Web (IIS) Leave all default Roles Services

    Check off restart server automatically, install (fingers crossed....)

    Nope same error... mmm

    Monday, June 6, 2016 2:32 PM
  • Alright, instead of wasting any more time on this. I simply re-installed my Server 2015 TP 5 from scratch.

    Installed VMware Tools, configured my Vmxnet3 nic, added to my domain (I decided to change to a different OU to prevent getting unwanted local right assignments)

    Installed just the Routing Role (Again not sure why Direct Access and IIS have to be requirements) however the installation of said feature worked without issue, didn't even need a reboot. I then was able to configure LAN routing under the Routing and remote access snap-in.

    If anyone else can confirm this wizard breaks when you select and install the WAP Role before the Routing role, that be great, but I just don't have time to re-test this.


    • Edited by Zewwy Monday, June 6, 2016 3:52 PM
    • Marked as answer by Zewwy Monday, June 6, 2016 3:52 PM
    Monday, June 6, 2016 3:52 PM