none
MDT 2013 & Windows 8.1 RRS feed

  • Question

  • I am having some issues with trying to deploy windows 8.1 with MDT 2013.

    It is a fresh server install I have recently setup and it works perfectly as expected on my windows 7 deployment.

    So I decided to try it with windows 8.1.

    I deployed a standard copy of windows 8.1 with WDS to my reference computer.

    Set the computer up as desired (Same as Windows 7)

    Did a dism backup (Just to protect the work I did)

    Then I came to run the Sysprep and capture task sequence. (recently done this on server 2012 and again it worked perfectly.)

    It runs through the motions as expected but the sysprep part was over fairly quickly not like on Windows 7 where you can see the visual changes happen in the back ground. It then restarts and sends the image up to the server.

    I import the image and assign it to my task sequence to push back down.

    PXE boot to MDT and start the deployment (So far so good.)

    The image gets pushed down and restarts and this is where is gets interesting, Fairly quickly i'm at a login screen and itsnot moving anywhere. I login with the administrator account and no continuation, no errors. So im a little puzzled now.

    It looks like the unattended.xml didnt process? and do the auto login. All the MDT folders are also still present on the Cdrive.

    I was expected to see windows installing hardware etc etc like windows 7, restart a few times and auto login to windows to finish installing the applications.

    Where do I start with this one?!

    Tried doing the process again in case it didn't capture correctly but same thing happens every time.

    Rob

    Wednesday, May 21, 2014 1:11 PM

All replies

  • The logs:

    2014-05-22 15:21:06, Error                 SYSPRP Package Microsoft.WinJS.2.0_1.0.9600.17018_neutral__8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.
    
    2014-05-22 15:21:06, Error                 SYSPRP Failed to remove apps for the current user: 0x80073cf2.
    
    2014-05-22 15:21:06, Error                 SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.
    
    2014-05-22 15:21:06, Error      [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'SysprepGeneralize' from C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
    2014-05-22 15:21:06, Error                 SYSPRP ActionPlatform::ExecuteAction: Error in executing action; dwRet = 0x3cf2
    2014-05-22 15:21:06, Error                 SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
    2014-05-22 15:21:06, Error                 SYSPRP SysprepSession::Execute: Error in executing actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
    2014-05-22 15:21:06, Error                 SYSPRP RunPlatformActions:Failed while executing SysprepSession actions; dwRet = 0x3cf2
    2014-05-22 15:21:06, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2
    2014-05-22 15:21:06, Error      [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2
    2014-05-22 15:23:13, Info       [0x0f004c] SYSPRP WaitThread:Exiting spawned waiting thread
    2014-05-22 15:23:13, Info       [0x0f0052] SYSPRP Shutting down SysPrep log
    2014-05-22 15:23:13, Info       [0x0f004d] SYSPRP The time is now 2014-05-22 15:23:13

    Looks to be that WinJS thing causing the issue.

    dism /Online /remove-provisionedappxpackage /packagename:Microsoft.WinJS.2.0_1.0.9600.17018_neutral__8wekyb3d8bbwe

    Just returns could not find app.. How do I remove this app for the current user?

    Rob

    Thursday, May 22, 2014 3:41 PM
  • Only thing I can think of here is a possible problem with your boot images. WinJS is required by a lot of the Modern applications as a dependency. Even if you could remove it, I doubt that you will find all of your Modern apps working when the build completes.

    I haven't had the issue you describe running in the same environment.

    .bill


    Regards, Bill Moore @BMooreAtDell

    Monday, May 26, 2014 4:44 AM