locked
SIPTAPI (IP phone driver) after upgrading windows 10 1511 to Anniversary (1607) RRS feed

  • Question

  • After upgrading Windows 10 1511 to Anniversary (1607) our IP phone driver SIPTAPI has lost its configuration. Attempting to reconfigure it seems to accept the data but get lost again. After opening the configuration page in "Modem and phone" again all of the fields are empty. Does anybody have this problem? How to solve it?
    Wednesday, September 28, 2016 2:25 PM

All replies

  • Hi, 

    Have you tried to reinstall the driver in compatibility mode to check the results? 

    Try steps here:

    https://support.microsoft.com/en-us/help/15078/windows-make-older-programs-compatible

    If still not work, considering to contact the manufacturer's support to see if there is any update driver package to fix this issue. 


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, October 1, 2016 9:01 AM
  • Same problem here :(

    seems like the update have f*cked up more settings.

    my SIPTAPI configuration doesn't save the settings anymore.

    The compatiblity check doesnt work with TSP files.

    Thanks microsoft for this briliant update! NOT

    Thursday, October 20, 2016 10:13 AM
  • Found the solution :)

    here it is:

    go to phone en modems,

    tab Advanced,

    select the provider "SIPTAPI"

    click Remove

    click Add

    Select SIPTAPI

    fill in your settings

    Now it seems to save your settings.

    Seems the update has broken things you can repair by installing the 'provider' again.

    Thursday, October 20, 2016 10:19 AM
  • Great,

    thanks for your good sharing on this issue, please help to mark your post as answered, so that other communities who may encounter the similar issue as yours will find the solution more efficiently.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, October 21, 2016 1:11 AM
  • Great, Is working now!

    More efficent than Microsoft....(try to reinstall the driver in compatibility mode....)

    :-)

    Monday, May 15, 2017 11:52 AM
  • I had the same issue after upgrading to Windows 10, but could not remove it from the phone/modem panel. I had to delete <g class="gr_ gr_254 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="254" id="254">siptapi</g>.<g class="gr_ gr_255 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="255" id="255">tps</g> file from c:/windows/system32. After deleting the file, I added back a new version of the file from the <g class="gr_ gr_157 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling" data-gr-id="157" id="157">siptapi</g> website, and all is back to working
    Tuesday, January 7, 2020 12:52 AM