locked
New-InformationBarrierPolicy does not work RRS feed

  • Question

  • I am setting up barrier policy. I was able to create segments and run the 'Get-RetentionCompliancePolicy' command without any error.

    However New-InformationBarrierPolicy command returns the error: '

     The term 'New-InformationBarrierPolicy' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling
    of the name, or if a path was included, verify that the path is correct and try again.

    '

    I am working at the same PowerShell session when I created segments, so the command should be included/imported.

    I have enabled as well 'Scope directory search using an Exchange address book policy' on Teams.

    Full command that I ran is

    New-InformationBarrierPolicy -Name "Internal-Company A" -AssignedSegment "Company A Restricted" -SegmentsAllowed "Internal","Company A Restricted" -State Inactive                     

    Could you help me work out with running the New-InformationBarrierPolicy command 

    Wednesday, June 10, 2020 7:28 AM

All replies

  • Please take time to learn how to use teh documentation for commands.  YOU would find the following:

    This cmdlet is available only in Security & Compliance Center PowerShell. For more information, see Security & Compliance Center PowerShell (https://docs.microsoft.com/powershell/exchange/scc-powershell).


    \_(ツ)_/

    Wednesday, June 10, 2020 7:42 AM
  • Thank you for your quick response. I have already connected to Security & Compliance Center PowerShell using the article however 'New-InformationBarrierPolicy' does not work. Perhaps it is wrong something else?

    Thanks for advance.

    Wednesday, June 10, 2020 8:31 AM
  • Then you will need t contact MS support to find out why your portal is not set up for this.


    \_(ツ)_/

    Wednesday, June 10, 2020 9:06 AM
  • Hi,
    Was your issue resolved? 
    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.
    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.
    If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,
    Yang Yang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 3, 2020 3:34 AM