none
GPO will not stay enforced on Windows 10

    Question

  • I have set a GPO to set the display to never sleep.  When I run gpupdate /force manually, I see the power setting immediately change to "Never."  However, later the monitor still goes to sleep.  I go back to the setting and see it has changed to 15 minutes.

    I run gpupdate /force again and the settings changes back to "Never" again, so I know the policy is being applied.

    How can I find out why the setting doesn't stick?


    • Edited by MyGposts Wednesday, December 7, 2016 3:44 PM
    Wednesday, December 7, 2016 3:40 PM

Answers

  • gpresult /h is not a valid command.  Only gpresult /r works for us.

    There is not a another GPO with "higher priority."  The policy we have to stop display sleep has the highest priority (applied directly to the OU the user and workstation are in), but there was another policy that should have had lower priority that was still interfering.  

    After adding deny permissions to the other GPO, the settings now seem to work.

    Don't know why this needs to be done, but it is the only thing that's working for us.

    Monday, December 12, 2016 4:22 PM

All replies

  • > How can I find out why the setting doesn't stick?
     
    Is this a laptop and has some vendor specific tools installed?
     
    Wednesday, December 7, 2016 4:40 PM
  • > How can I find out why the setting doesn't stick?
     
    Is this a laptop and has some vendor specific tools installed?
     
    No. 
    Wednesday, December 7, 2016 5:06 PM
  • Hi MyGposts,

    Please check if there are other GPOs that have higher priority to cover the GPO. You may run gpresult /h to check the GPO apply result.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 8, 2016 5:37 AM
    Moderator
  • The settings take effect when I run gpupdate force.  The problem is that the settings don't stay.

    If another GPO had higher priority, gpupdate would not make it work even temporarily.


    Thursday, December 8, 2016 6:04 AM
  • Then I suggest determining the corresponding registry value and run process monitor with a filter on that value. So you will identify the processes that write to this value.
     
    Thursday, December 8, 2016 9:25 AM
  • Hi MyGposts,

    Process monitor link:

    https://technet.microsoft.com/en-us/sysinternals/bb896645

    Besides, if the issue actually locates on Windows 10 OS, then you'd turn to win10 forum for better help.

    https://social.technet.microsoft.com/Forums/en-US/home?forum=win10itprogeneral

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, December 12, 2016 9:35 AM
    Moderator
  • gpresult /h is not a valid command.  Only gpresult /r works for us.

    There is not a another GPO with "higher priority."  The policy we have to stop display sleep has the highest priority (applied directly to the OU the user and workstation are in), but there was another policy that should have had lower priority that was still interfering.  

    After adding deny permissions to the other GPO, the settings now seem to work.

    Don't know why this needs to be done, but it is the only thing that's working for us.

    Monday, December 12, 2016 4:22 PM
  • Hi MyGposts,

    >gpresult /h is not a valid command.

    gpresult /h C:\report.html will work. The report will locates in C drive;

    >After adding deny permissions to the other GPO, the settings now seem to work.

    Glad to see you have made it work.

    You may mark your reply as answer.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 13, 2016 5:44 AM
    Moderator