locked
I am installing server 2016 on server 2012 r2 and getting the error message RRS feed

  • General discussion

  • Hi Support,

    When i am installation I am installing server 2016 on server 2012 r2 but getting the error message ?

    I have assign full role to user and after that installation exchange.

    [07/20/2018 10:54:12.0604] [0] **********************************************
    [07/20/2018 10:54:12.0620] [0] Starting Microsoft Exchange Server 2016 Setup
    [07/20/2018 10:54:12.0620] [0] **********************************************
    [07/20/2018 10:54:12.0620] [0] Local time zone: (UTC+05:30) Chennai, Kolkata, Mumbai, New Delhi.
    [07/20/2018 10:54:12.0620] [0] Operating system version: Microsoft Windows NT 6.2.9200.0.
    [07/20/2018 10:54:12.0620] [0] Setup version: 15.1.1466.3.
    [07/20/2018 10:54:12.0620] [0] Logged on user: RFLNEW\administrator.
    [07/20/2018 10:54:12.0886] [0] Command Line Parameter Name='mode', Value='Install'.
    [07/20/2018 10:54:12.0886] [0] Command Line Parameter Name='roles', Value='Microsoft.Exchange.Management.Deployment.RoleCollection'.
    [07/20/2018 10:54:12.0886] [0] Command Line Parameter Name='targetdir', Value='C:\Exchange Server'.
    [07/20/2018 10:54:12.0886] [0] Command Line Parameter Name='iacceptexchangeserverlicenseterms', Value=''.
    [07/20/2018 10:54:12.0886] [0] Command Line Parameter Name='sourcedir', Value='D:\'.
    [07/20/2018 10:54:12.0886] [0] RuntimeAssembly was started with the following command: '/mode:Install /role:Mailbox /TargetDir:C:\Exchange Server /IAcceptExchangeServerLicenseTerms /sourcedir:D:"'.
    [07/20/2018 10:54:12.0886] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0, wasn't found.
    [07/20/2018 10:54:12.0886] [0] The registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14, wasn't found.
    [07/20/2018 10:54:12.0886] [0] Copying Files...
    [07/20/2018 10:54:12.0901] [0] Starting copy from D:\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
    [07/20/2018 10:54:15.0167] [0] Finished copy from D:\Setup\ServerRoles\Common to C:\Windows\Temp\ExchangeSetup.
    [07/20/2018 10:54:15.0167] [0] File copy complete.  Setup will now collect additional information needed for installation.

    [07/20/2018 10:54:15.0182] [0] Assembly dll file location is C:\Windows\Temp\ExchangeSetup\Microsoft.Exchange.Setup.Console.dll
    [07/20/2018 10:54:19.0604] [0] Setup is choosing the domain controller to use
    [07/20/2018 10:54:25.0823] [0] Setup is choosing a local domain controller...
    [07/20/2018 10:54:27.0307] [0] Setup has chosen the local domain controller cloudconsultantdc.rflnew.xyz for initial queries
    [07/20/2018 10:54:27.0588] [0] PrepareAD has been run, and has replicated to this domain controller; so setup will use cloudconsultantdc.rflnew.xyz
    [07/20/2018 10:54:27.0588] [0] Setup is choosing a global catalog...
    [07/20/2018 10:54:27.0588] [0] Setup has chosen the global catalog server cloudconsultantdc.rflnew.xyz.
    [07/20/2018 10:54:27.0604] [0] Setup will use the domain controller 'cloudconsultantdc.rflnew.xyz'.
    [07/20/2018 10:54:27.0604] [0] Setup will use the global catalog 'cloudconsultantdc.rflnew.xyz'.
    [07/20/2018 10:54:27.0604] [0] Exchange configuration container for the organization is 'CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=rflnew,DC=xyz'.
    [07/20/2018 10:54:27.0604] [0] Exchange organization container for the organization is 'CN=RFLNEW,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=rflnew,DC=xyz'.
    [07/20/2018 10:54:27.0620] [0] Setup will search for an Exchange Server object for the local machine with name 'CLOUDEXCH-2016'.
    [07/20/2018 10:54:27.0698] [0] Exchange Server object found : 'CN=CLOUDEXCH-2016,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=RFLNEW,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=rflnew,DC=xyz'.
    [07/20/2018 10:54:27.0760] [0] The following roles have been unpacked: BridgeheadRole ClientAccessRole MailboxRole UnifiedMessagingRole FrontendTransportRole AdminToolsRole CafeRole 
    [07/20/2018 10:54:27.0760] [0] The following datacenter roles are unpacked: 
    [07/20/2018 10:54:27.0776] [0] The following roles are installed: AdminToolsRole 
    [07/20/2018 10:54:27.0776] [0] The local server has some Exchange files installed.
    [07/20/2018 10:54:27.0792] [0] Server Name=CLOUDEXCH-2016
    [07/20/2018 10:54:27.0792] [0] Setup will use the path 'D:\' for installing Exchange.
    [07/20/2018 10:54:27.0792] [0] Setup will discover the installed roles from server object 'CN=CLOUDEXCH-2016,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=RFLNEW,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=rflnew,DC=xyz'.
    [07/20/2018 10:54:27.0792] [0] Setup has detected a provisioned server scenario.
    [07/20/2018 10:54:27.0807] [0] The installation mode is set to: 'Install'.
    [07/20/2018 10:54:28.0807] [0] An Exchange organization with name 'RFLNEW' was found in this forest.
    [07/20/2018 10:54:28.0807] [0] Active Directory Initialization status : 'True'.
    [07/20/2018 10:54:28.0807] [0] Schema Update Required Status : 'False'.
    [07/20/2018 10:54:28.0807] [0] Organization Configuration Update Required Status : 'False'.
    [07/20/2018 10:54:28.0807] [0] Domain Configuration Update Required Status : 'False'.
    [07/20/2018 10:54:28.0823] [0] The locally installed version is 15.1.1466.3.
    [07/20/2018 10:54:28.0823] [0] Exchange Installation Directory : 'C:\Program Files\Microsoft\Exchange Server\V15'.
    [07/20/2018 10:54:28.0854] [0] Applying default role selection state
    [07/20/2018 10:54:28.0885] [0] Setup is determining what organization-level operations to perform.
    [07/20/2018 10:54:28.0885] [0] Because the value was specified, setup is setting the argument OrganizationName to the value RFLNEW.
    [07/20/2018 10:54:28.0885] [0] Setup will run from path 'C:\Program Files\Microsoft\Exchange Server\V15\'.
    [07/20/2018 10:54:28.0901] [0] InstallModeDataHandler has 13 DataHandlers
    [07/20/2018 10:54:28.0901] [0] RootDataHandler has 1 DataHandlers
    [07/20/2018 10:54:28.0901] [0]      Languages
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Transport service
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Client Access service
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Unified Messaging service
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Mailbox service
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Front End Transport service
    [07/20/2018 10:54:28.0901] [0]      Mailbox role: Client Access Front End service
    [07/20/2018 10:54:28.0917] [0] Validating options for the 6 requested roles
    [07/20/2018 10:54:28.0932] [0] [ERROR] The target directory was specified but cannot be changed.
    [07/20/2018 10:54:28.0932] [0] CurrentResult console.ProcessRunInternal:90: 1
    [07/20/2018 10:54:28.0948] [0] CurrentResult launcherbase.maincore:90: 1
    [07/20/2018 10:54:28.0948] [0] CurrentResult console.startmain:52: 1
    [07/20/2018 10:54:28.0948] [0] CurrentResult SetupLauncherHelper.loadassembly:452: 1
    [07/20/2018 10:54:28.0948] [0] The Exchange Server setup operation didn't complete.  More details can be found in ExchangeSetup.log located in the <SystemDrive>:\ExchangeSetupLogs folder.
    [07/20/2018 10:54:28.0948] [0] CurrentResult main.run:235: 1
    [07/20/2018 10:54:28.0948] [0] CurrentResult setupbase.maincore:396: 1
    [07/20/2018 10:54:28.0948] [0] End of Setup
    [07/20/2018 10:54:28.0948] [0] **********************************************

    Friday, July 20, 2018 11:10 AM

All replies

  • Hi

    Did you do the prerequisite installs for Exchange required before you do the actual install?

    Can you run setup from an elevated prompt?

    Is the user account part of the domain, schema and enterprise admins group and did you wait for replication to complete?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 20, 2018 11:36 AM
  • Hi Edward,

    Yes, I have installed prerequisite installs for Exchange required before you do the actual install.

    Can you run setup from an elevated prompt:  Yes

    I have add user on domain, schema and enterprise admins group but still getting the error message.

    Saturday, July 21, 2018 6:26 AM
  • Hi,

    Have you re-run the setup? 

    From the error message, we could see that the target directory has been changed D:\ to C:\, so please make sure the target directory being given matches the one configured last time. If you're running install a second time don't put the target directory, and setup will use what was specified the first time the command was run.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, July 23, 2018 10:04 AM