locked
(0x80131904): Cannot open database "SUSDB" requested by the login. RRS feed

  • Question

  • Hi everybody,

    Currently i have the following error in the WCM.log file and WSUS synchronization failes as well:

    System.Data.SqlClient.SqlException (0x80131904): Cannot open database "SUSDB" requested by the login. 
    The login failed.~~Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.~~   at Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow(SoapException soapException)~~   at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.ExecuteSPGetComponentsWithErrors()~~   at Microsoft.SystemsManagementServer.WSUS.WSUSServer.get_ComponentsWithErrors()

    Current environment:

    - SCCM 2012 SP1 and WSUS 3 SP2 on the same server.

    - WSUS is using the windows internal database.

    any advise??

    thanks

    Sunday, February 1, 2015 9:13 PM

Answers

  • What worked for me to solve this issue:

    - Install the SQL Server Management Studio

    - Connect to the internal database:

    \\.\pipe\MSSQL$MICROSOFT##SSEE\SQL\query

    - Stop Services "Updates Services" & "IIS Admin Service"

    - Detach the SUSDB and then attach it again and give the account in the error SYSAdmin role

    - Try Sync again :)

    Also some other useful links:

    - How to migrate the WSUS internal DB to SQL DB:

    https://technet.microsoft.com/en-us/library/dd939918(v=ws.10).aspx

    http://wp.secretnest.info/archives/804

    http://havardkristiansen.com/?p=173

    http://blog.augustoalvarez.com.ar/2009/01/25/wsus-30-connecting-managing-and-moving-susdb-as-internal-database/

    - Re-index the SUSDB

    https://technet.microsoft.com/en-us/library/dd939795(v=ws.10)

    thanks 

    M.Zakaria


    • Edited by M_Zakaria Monday, February 2, 2015 11:51 AM
    • Marked as answer by M_Zakaria Monday, February 2, 2015 12:16 PM
    Monday, February 2, 2015 11:49 AM

All replies

  • Check these steps.

    1. go to Sql Server Configuration management->SQL Server network config->protocols for 'servername' and check TCP/IP is enabled.
    2. Open SSMS in run, and check you are able to login to server using specfied username/password and/or using windows authentication.
    3. repeat step 1 for SQL native client config also

    Monday, February 2, 2015 3:54 AM
  • What worked for me to solve this issue:

    - Install the SQL Server Management Studio

    - Connect to the internal database:

    \\.\pipe\MSSQL$MICROSOFT##SSEE\SQL\query

    - Stop Services "Updates Services" & "IIS Admin Service"

    - Detach the SUSDB and then attach it again and give the account in the error SYSAdmin role

    - Try Sync again :)

    Also some other useful links:

    - How to migrate the WSUS internal DB to SQL DB:

    https://technet.microsoft.com/en-us/library/dd939918(v=ws.10).aspx

    http://wp.secretnest.info/archives/804

    http://havardkristiansen.com/?p=173

    http://blog.augustoalvarez.com.ar/2009/01/25/wsus-30-connecting-managing-and-moving-susdb-as-internal-database/

    - Re-index the SUSDB

    https://technet.microsoft.com/en-us/library/dd939795(v=ws.10)

    thanks 

    M.Zakaria


    • Edited by M_Zakaria Monday, February 2, 2015 11:51 AM
    • Marked as answer by M_Zakaria Monday, February 2, 2015 12:16 PM
    Monday, February 2, 2015 11:49 AM
  • Thanks M_Zakaria for your update.
    Monday, February 2, 2015 12:08 PM