none
SBS 2011 RWA Problem RRS feed

  • Question

  • Hi, Having problems with a recently installed SBS 2011 Standard RWA. When connecting to a desktop from Boxes running IE 9 we get an error. IE 8 and chrome work fine.  Screen shot follows.   Thanks in advance.

    Dexter

    Thursday, January 10, 2013 5:16 PM

Answers

  • Few suggestions and few questions

    Suggestions
    C:\Program Files\Microsoft SDKs\Windows\v7.1>err -2147221163
    # for decimal -2147221163 / hex 0x80040155
      REGDB_E_IIDNOTREG                                              winerror.h
    # Interface not registered
    # 1 matches found for "-2147221163"

    Interface not registered points to issues with the remote desktop client add in's on the computers you are attempting this with (Since this works with other version's of IE I will assume (I may be wrong on this) issue is probably from client side).

    "When connecting to a desktop from Boxes running IE 9 we get an error" -- Does that means you are trying this from external machines where IE9 was installed recently ? Does that means this has been attempted from multiple Client machines (external) with IE9 installed regardless of the user permission's example admin or standard users and all results in same error?

    Crakdkorn  is suggesting a great feature of IE9 which will require a familiarity with IE9 deubgging features . If you wish to take a deep dive into it here are the links

    http://blogs.msdn.com/b/cbowen/archive/2011/05/25/internet-explorer-9-developer-tools-deep-dive-part-1-introduction.aspx

    http://blogs.msdn.com/b/cbowen/archive/2011/07/08/internet-explorer-9-developer-tools-deep-dive-part-5-network-performance-and-debugging.aspx

    Questions :

    1. Since you mentioned this  is a recently installed SBS2011 it's hard to believe this issue should come up ( OS was released 4 years ago and google , bing search results almost nothing). Any change was made from IIS perspective?

    2. Client machines on which this error occurs are they of same make and model or you have tested this on other machines ( which works flawlessly with RWA of another SBS2011 , if that's a possibility? )

    Sunday, January 13, 2013 11:38 AM

All replies

  • Try running in Quirks mode (tap the F12 key - Document Mode: Standards)

    R, J

    Saturday, January 12, 2013 11:40 PM
  • Few suggestions and few questions

    Suggestions
    C:\Program Files\Microsoft SDKs\Windows\v7.1>err -2147221163
    # for decimal -2147221163 / hex 0x80040155
      REGDB_E_IIDNOTREG                                              winerror.h
    # Interface not registered
    # 1 matches found for "-2147221163"

    Interface not registered points to issues with the remote desktop client add in's on the computers you are attempting this with (Since this works with other version's of IE I will assume (I may be wrong on this) issue is probably from client side).

    "When connecting to a desktop from Boxes running IE 9 we get an error" -- Does that means you are trying this from external machines where IE9 was installed recently ? Does that means this has been attempted from multiple Client machines (external) with IE9 installed regardless of the user permission's example admin or standard users and all results in same error?

    Crakdkorn  is suggesting a great feature of IE9 which will require a familiarity with IE9 deubgging features . If you wish to take a deep dive into it here are the links

    http://blogs.msdn.com/b/cbowen/archive/2011/05/25/internet-explorer-9-developer-tools-deep-dive-part-1-introduction.aspx

    http://blogs.msdn.com/b/cbowen/archive/2011/07/08/internet-explorer-9-developer-tools-deep-dive-part-5-network-performance-and-debugging.aspx

    Questions :

    1. Since you mentioned this  is a recently installed SBS2011 it's hard to believe this issue should come up ( OS was released 4 years ago and google , bing search results almost nothing). Any change was made from IIS perspective?

    2. Client machines on which this error occurs are they of same make and model or you have tested this on other machines ( which works flawlessly with RWA of another SBS2011 , if that's a possibility? )

    Sunday, January 13, 2013 11:38 AM