locked
Adding Driver Package to Boot Image in Windows Server 2008 R2 - A required privilege is not held by the client RRS feed

  • Question

  • I'm trying to add a NIC driver package to my WDS boot image. I've tried using imagex in the command prompt with elevated priveleges, as well as right clicking on the boot image and selecting add drive package.

    Each time I get the, "A required privilege is not held by the client" error.

    I've changed local security policies, changed UAC settings, and verified my own administrative privileges.

    Any help would be appreciated.

    Monday, April 12, 2010 3:01 PM

Answers

  • Logon a domain admin account to test the issue.

    Wednesday, April 14, 2010 2:12 AM
    Moderator

All replies

  • Check your NTFS permissions on the WDS directories as you will need write permissions at a minimum.  UAC should have absolutely zero impact.  Leave it on.
    Monday, April 12, 2010 3:40 PM
  • I forgot to mention I checked that as well. All relevant directories have full control permissions for Administrators, which my account is a member of.

    Thank you for your response, though. Any other ideas?

    Monday, April 12, 2010 4:11 PM
  • With R2, you can add drivers on the WDS console instead of using ImageX.  Have you tried this?  I always boot from the server for captures, etc.  ImageX just isn't something I've had to use at all with Windows 2008 R2's WDS.
    Monday, April 12, 2010 4:46 PM
  • I tried from the WDS console after I found out you could do that in R2. Previously I was trying to use ImageX. However, I got the same error regardless of how I tried. I actually got that error when I was simply trying to mount the boot image.

    Monday, April 12, 2010 4:51 PM
  • Try recreating the boot image.  Something just sounds off.  You should be able to use the boot.wim off of any Windows 7 disk for this.
    Monday, April 12, 2010 6:12 PM
  • I believe my colleague recreated it already, but I will try that this afternoon just to be sure. Thank you again for the help. I'll let you know how it goes.
    Monday, April 12, 2010 6:30 PM
  • Logon a domain admin account to test the issue.

    Wednesday, April 14, 2010 2:12 AM
    Moderator
  • Hi,

     

    How are things going? We have not heard back from you in a few days and wanted to check on the status of the issue. Please let us know how things turned out.

     

    Tim Quan - MSFT

    Friday, April 16, 2010 7:13 AM
    Moderator
  • I am having the same problem and am a domain admin. Is there a list of services that are needed by the mmc to mount images? I suspect that the issue is due to security requirements we have for servers in our environment.
    Saturday, June 26, 2010 1:50 AM