none
I can't use Comodo digital certificate in e-mail

    Question

  • Dear all...

    I have installed a free Comodo secure e-mail digital certificate in my computer but Outlook 2016 doesn't display certificate in Trust Center settings...Here is a screen shot...I am using genuine Windows 10 Pro x86 and genuine Microsoft Office 2016 Professional Plus...Can anyone help me?...

    Friday, March 24, 2017 9:17 AM

All replies

  • Hello,

    Have you double checked that the certificate has been successfully installed and added to your personnel store in system?

    Have you verified that the certificate can be used to encrypt email messages in Outlook?

    In addition, it looks that the most common reason for this is that the email address on the mail client is not the same as the one in the certificate. See the following article for more details:

    https://support.comodo.com/index.php?/Knowledgebase/Article/View/73/18/i-have-installed-my-certificate-but-cannot-assign-it-to-my-email-address-why

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 27, 2017 6:20 AM
    Moderator
  • Dear Steve Fan...

    Thanks for your reply...I have now reinstalled the certificate in the "Personal Store" location...Outlook 2016 says " No Certificate Available...No Certificates meet the application criteria" when I try to select choose  Certificates and Algorithms...When I checked the certificate issue my e-mail address is correct...

    I have attached screen shots...

    Please help me...

    Thanks 


    • Edited by naheez Tuesday, March 28, 2017 3:54 PM
    Tuesday, March 28, 2017 3:54 PM
  • I have the same problem and none has any clue what is happening. I searched the whole technet, nothing on it.

    Saturday, August 12, 2017 5:53 PM
  • This is because the machine you are trying to send emails from doesn't have the PRIVATE KEY associated with your certificate. Probably you issued this cert from another machine.

    This solution probably applies to you:

    https://www.comodo.com/support/products/authentication_certs/setup/outlook.php

    edit: After doing the above procedure, don't forget to enable > the "Request S/MIME receipt for all S/MIME signed messages" option enabled in Trust Center > Email Security

    (thanks to:)

     https://social.technet.microsoft.com/Forums/en-US/d5cd0d6d-5245-4beb-8365-d1dfa74d8309/outlook-2016-x64-cannot-send-digitally-signed-message-smime?forum=outlook


    • Edited by Rhodin Saturday, October 21, 2017 7:47 PM
    Saturday, October 21, 2017 7:31 PM
  • I have the same problems as all mentioned above and have been working on the local outlook 2016 client on the same machine throughout. I really am stumped it would be great if anyone could fix this as it looks like a lot of people are experiencing the same issue with the free comodo cert. If anyone can tell me where on the machine it will have downloaded the key then maybe that's a start. I can remember doing it years ago and it was fine so I really can't figure what I'm doing wrong...
    Friday, March 2, 2018 3:46 PM
  • The real problem is that outlook does´nt recognize the certificate becouse Windows 10 is not installing it. You have to open the certificate in Firefox and then backup it from firefox to your pc. You can se more here https://www.youtube.com/watch?v=MeGwLLFzT34 (see 1:27 - 2:26) . After you have exported the certificate in firefox, you can import it in outlook and follow the normal steps. First Create de Digital ID in outlook and then set up as default settings the certificate.
    • Proposed as answer by Leeto20 Monday, March 12, 2018 9:35 PM
    Thursday, March 8, 2018 5:32 PM
  • Import the comodo cert using Firefox. Then export the same cert as a .p12  Then import the cert into Outlook.  

    It's silly, but it works. 

    • Proposed as answer by Freddy Lao Thursday, August 23, 2018 6:20 AM
    Monday, March 12, 2018 9:36 PM
  • It worked also for me but I don't understand why.

    Before, the certificate - with private key line clearly visible when querying to view the certificate - was in the certificates container under "Other persons" folder for my "hotmail" address. But I could see only one line. I did not pay enough attention (no print screen etc).

    I had nothing to loose.

    I had a .pfx export. 

    I deleted this certificate.

    I used Firefox to import from user.crt downloaded on same machine, which no longer worked (no private key,  destroyed with my hasty delete?). I then imported from the .pfx backup, which worked 1st time. 

    This moved it "by force" to Personnel folder (instead of other persons as before). Is that the decisive changing element? 

    Now I could finally "see" the certificate in Outlook (Trust Center/E-mail security/Settings). Hallelujah. 

    I could then use it in an email signed from my "hotmail" address to my test "gmail" address as recipient.

    This recipient was in the contacts with its certificates (sign & encrypt) in Other Persons folder. I know these certificates work for signing (never used for encryption requiring exchanges of keys). 

    Only the "signing" worked in my test but not the requested encryption (Outlook sending error alluded to "recipient having missing certificates or conflicting encryption capabilities"). I am used to use signing as sender but I never used mail encryption. 

    I will make further readings, enquiries and tests to try to use this damned encryption.

    Anyway, this tip was useful to me.  Thanks.


    • Edited by acontrario Friday, November 30, 2018 10:23 PM
    Friday, November 30, 2018 10:14 PM