none
Windows Script Host startup error - Windows 8 RRS feed

  • Question

  • Hello all,

    I got  new Windows 8 Lenovo laptop recently, and I wanted to install all my games from my previous computer to my new one. So I did, but ended up with some errors (Which have nothing to due with Windows or Lenovo, but rather the games themselves), and as a result, I had to re-install java (I mention java just to ensure I cover all the possibilities, I doubt it has anything to due with java). After some un-installations and scans/clean-ups, I got my computer back to normal except for one notable error: every time I boot my laptop, I get an error message that is titled "Windows Script Host" and has the message "Can not find file "C:\ProgramData\Lenovo-1423.vbs"". When I safe boot I do not get this message, but when I go to troubleshoot it in clean boot, I always get the error message, regardless of what services/startup items I have disabled. My virus softwares (Webroot and McAfee) detect no threats when I scan my drives.

    I'm sure I'm overlooking something simple. And, knowing me, I probably posted this in the wrong category, so apologies in advanced. Can someone please offer me help?

    Tuesday, June 18, 2013 9:29 PM

All replies

  • Probably in the wrong place, but whatever.  :)

    When you are looking for startup items to disable, you may be overlooking something.  Here are all of the places I know of that can cause something to launch on startup (excluding services, which probably wouldn't produce a pop-up that you can actually see):

    • The Start -> Programs -> Startup folder for Public / All Users.
    • Start -> Programs -> Startup folder for your user account.
    • HKLM\Software\Microsoft\Windows\CurrentVersion\Run key
    • HKCU\Software\Microsoft\Windows\CurrentVersion\Run key
    • HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce key (unlikely since you're seeing this on every logon, but technically things can be launched from here).
    • HKCU\Software\Microsoft\Windows\CurrentVersion\RunOnce key (same thing).

    Assuming that Windows 8 hasn't added some new location that I don't know about yet, that should be a complete list.  Have you checked all of them? 

    Wednesday, June 19, 2013 1:33 AM
  • Thank you for the reply! Yeah, I figured I was in the wrong place... Sorry. I haven't tried any of those, but I'm quite new to Windows 8 and don't understand most of it, so you'll have to elaborate a bit more if you wouldn't mind.

    Wednesday, June 19, 2013 1:54 AM
  • The first two items are folders on your hard drive.  The simplest way to open them is to run shell:startup and shell:common startup .  If there are any shortcuts (or any files at all, really) in those folders, they will also run at startup.

    The items starting with HKLM and HKCU are Registry keys.  You can view them by running regedit and browsing to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run, etc.  There may be string values (REG_SZ or REG_EXPAND_SZ) in those locations;  each item is a program that will launch when you log on.

    I don't have Windows 8 myself to confirm this, but I think you can get to a simpler startup menu inside Task Manager as well.  Most likely, it's just reading those same folders and registry keys and displaying all the information for you, but I'm not certain of that.

    Wednesday, June 19, 2013 2:17 AM
  • Yes, I used the startup tab under task manager to clean boot. I will try the methods you suggested.
    Wednesday, June 19, 2013 2:46 AM
  • This just isn't making any scenes. I can safe boot and I won't get that error, but when I clean boot and prevent literally every single item and service from starting that the system will allow me I still get the error.
    Wednesday, June 19, 2013 3:47 AM
  • "Open up regedit and check the following registry key:

    HKCR\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32

    Within it, there is a registry value called (Default) which should carry a Data value of:

    C:\Windows\system32\vbscript.dll

    If it says something else, you’ll need to change it to match the above.  This should fix your problem!

    So what’s the reason for the bad value?  Nearly always, it’s thanks to a broken or partially uninstalled antivirus (the most common culprits are McAfee and avast!, both of which I’ve seen leave behind values in this key after an attempted uninstall).  AV programs use this value to redirect script processing through a driver of their own for filtering purposes so that they can check for suspect behavior."

    Thursday, August 29, 2013 7:54 PM
  • Not sure if the OP is still reading this, but looking over my original response, I realize I left out the Wow6432Node keys as potential places for startup entries to hide (if the OS is 64-bit).  Everywhere I listed "\Software\Microsoft" as part of a registry key path, you could also check "\Software\Wow6432Node\Microsoft".

    Thursday, August 29, 2013 9:56 PM
  • Hi there. I had a similar problem and was able to resolve it. Every time I started up my PC, I would get an annoying message titled "windows script host" saying it couldn't find a file relating to a 3rd party application. You can check whether it is a 3rd party app causing this by starting your PC in safe mode and see if it still gives you the message titled "windows script host". If it doesn't, then it is a 3rd party app causing it and the problem is relatively easy to resolve.

    I was able to resolve this as follows:

    1. Start in safe mode

    (If the message titled "windows script host" doesn't appear, proceed and follow the remaining steps. If it does still appear then don't proceed and I'm not sure how you should resolve the issue in that case)

    2. Run registry editor
    3. Search for Lenovo-1423.vbs
    4. When found, delete it.

    5. Restart PC in normal mode. Problem solved!

    Below are detailed instructions below for performing the steps above:
    First startup your PC in safemode.
    A sure way to enable safe mode (for Windows 7 and Windows 8) is as follows. Run "msconfig", when msconfig is open, go to the boot tab and tick the checkbox that says "safe boot", apply changes then restart PC. It will start in safemode.
    Note: to find "msconfig" just hit the windows key and type "msconfig" (without quotes). Then click on it to run it.

    Now once in safe mode, run "regedit". To find regedit, press windows key, type "regedit" without quotes, then click on it to run it. The Registry Editor will open.

    When it is open, press ctrl+F to open the find window. Type "Lenovo-1423.vbs" then click on "find next" or just hit "Enter" key. It will begin searching the registry. When the search is complete it should come up with a list, one of them should be highlighted and will have the path,
    C:\ProgramData\Lenovo-1423.vbs

    Simply right click on it and click on delete. When you delete it, the problem should be resolved, now just run your PC normally again. I.e. not in "safe mode".

    To do this, run "msconfig" again by pressing windows key, typing "msconfig" then clicking on it. Go to the boot tab, uncheck the box saying "safe boot". Apply changes then restart your PC. It will start in regular mode and no more annoying message at start up.

    If the problem persists, you can start in safe mode again and run regedit to search for Lenovo-1423.vbs again in case it appears elsewhere in your registry. I doubt it would though.

    Good luck to anybody who had a similar problem

    Friday, December 6, 2013 5:51 PM
  • I got two script errors Lenovo-6209 and Lenovo-6160.vbs.  I found LENOVO COMPANION in my windows start, ran it, it updated the agent service, and I no longer get script errors.  Try running that and see if it fixes your errors.
    Wednesday, May 14, 2014 11:39 PM