locked
The directory name is invalid. RRS feed

  • Question

  • Hi,

     I am getting the below error when i launch the application shortcut.

    Application has two executables .

    About the application:

    I need to copy both exe's in one folder and register a dll and point the shortcut to a exe. When i launch the appv application got this error. The source works fine . Looked into the app through procmon but found nothing.

    We will get this error in the source when we keep both exe in different location and error will be "System can't find the file specified"

    I suspect that when the app launch the exe it will search for the another exe but not able to find even though it is there in the same location in the bubble.

    I have remove the path in WorkingDir section of OSD but that also did not help.

    

    Need help to resolve the issue.

    Friday, May 31, 2013 10:32 AM

All replies

  • Ensure the Path for the .exe is correct in the XML. If there's parameters make sure they are also correct.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Friday, May 31, 2013 1:32 PM
  • I am not able to find any path in XML .And there is not parameter for the shortcut.
    Friday, May 31, 2013 2:56 PM
  • It's on the main line near the top of the OSD. You will see the relative path for your sft and on the end of that line (you will have to scroll to the right, most likely) and you should see. It's under FILENAME.

    There's a good example: HERE

    It would be a good idea to create a Debug OSD or launch into the command line. The browse on the command line to the .exe and try and launch in there to ensure the application is actually working. To eliminate any issues with the app itself and identify it's just with how it's being launched.


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Friday, May 31, 2013 3:25 PM
  • I have checked the relative path and the file name are correct for the application in the OSD.

    As the shortcut exe calls the second exe which is there in the same location , it is not able to find it and though the error.

    Monday, June 3, 2013 8:13 AM
  • Hello,

    What happens if you change the working directory of the application to a folder that exists?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, June 3, 2013 8:36 AM
  • As i kept the exe's in Program files and captured it during Sequening.

    So i removed the WorkingDir from OSD which was pointing to %CSIDL_PROGRAM_FILES% .

    Also tried chagning the WorkingDir to Q:\<AssetDir>\CSIDL_PROGRAM_FILES

    Also sequenced the app once again by keeping the exe's in mount folder (Q:\<AssetDir>) but this also didnot help.

    Monday, June 3, 2013 9:58 AM
  • Also tried chagning the WorkingDir to Q:\<AssetDir>\CSIDL_PROGRAM_FILES

    This won't work,  %CSIDL_PROGRAM_FILES% points to your Program Files folder, which typicaly is C:\Program Files.
    So if you installed your applciation to "c:\Program Files\testapp" durining sequence, your workingdir should be "%CSIDL_PROGRAM_FILES%\testapp". You could also check inside your app-v bubble where the files are on your Q-drive and change the path to that location, like "Q:\Testapp\version123"

    Monday, June 3, 2013 10:34 AM