locked
Publishing autodiscover.xml for ActiveSync ? RRS feed

  • Question

  • I am trying to publish our autodiscover information through UAG so our mobile devices can configure themselves, but I seem to be running into a strange issue.  Our DNS record for autodiscover points to our application portal IP which as the Outlook web applications (including ActiveSync).  ActiveSync works on this portal if we hardwire the information, so I know that all works.

    If I modify the Outlook web application which has the Microsoft-ActiveSync, add a directory to publish /Autodiscover that exists on our CAS and attempt to setup a mobile device using autodiscover, I get the following error reported through the Web Monitor in UAG:

    A request from source IP address X.X.X.X on trunk defaultuserportal; Secure=1 for application Outlook Web Access of type ExchangePub2010 failed. The URL /autodiscover/autodiscover.xml contains an illegal path. The rule applied is Default rule. The method is GET.

    We are on Exchange 2010 if this makes any difference.

    Am I going about this all wrong?

    Thanks!

    Tuesday, May 4, 2010 12:20 AM

Answers

  • The message you are seeing indicates that no rule in the RuleSet exists for that URL and Application. To fix this, open the Advanced Trunk Configuration, and go to RuleSet. Add a rule and name it according to the application's type (you can observe how other rules are named, and understand how that works), and specify that path using RegEx. Then, Activate your configuration and try again.
    Ben Ari
    Microsoft CSS IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Wednesday, May 12, 2010 6:58 PM
    Wednesday, May 12, 2010 6:58 PM

All replies

  • The message you are seeing indicates that no rule in the RuleSet exists for that URL and Application. To fix this, open the Advanced Trunk Configuration, and go to RuleSet. Add a rule and name it according to the application's type (you can observe how other rules are named, and understand how that works), and specify that path using RegEx. Then, Activate your configuration and try again.
    Ben Ari
    Microsoft CSS IAG Support
    Sammamish, WA
    • Marked as answer by Erez Benari Wednesday, May 12, 2010 6:58 PM
    Wednesday, May 12, 2010 6:58 PM
  • I would run the Exchange 2010 wizard again and choose Outlook Anywhere option too, this should setup the Autodiscover elements you need...

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Wednesday, May 12, 2010 7:06 PM