locked
high definition audio device, after hibernation or sleep >> NO SOUND RRS feed

  • Question

  • After you resume a Windows Vista-based computer from sleep or from hibernation, a high definition audio (HDA) device may no longer work.


    I tried KB929685 x64

    but it gives me an error "the update does not apply to your system." my system is x64...


    what should ı do ?


    every time I reinstall the drivers the problem goes away until the sytem hibernates....


    any solution ? please...Also I got the latest service pack of vista.


    I have done that any my original realtek driver is fine which is dll no : 5423 (Realtek high definiton audio)

    my computer is hp dx7400 quad. with vista ultimate x64.

    when I uninstall and open in safe mode anr reinstall everything works.

    but the thing is I do not want to do this every time the system hibernates.....

    I got the latest drivers.......it is vistas fault and they made a gfix for this but ...when I use these fixes

    Windows6.0-KB937077-x64.msu

    Windows6.0-KB929685-x64.msu

    Windows6.0-KB929685-x86.msu

    the system sayf these fixes are not supported by your machine.

    I need a fix that works.......or a nother work around.
     
    Monday, March 31, 2008 4:58 PM

All replies

  • Hello,

     

    Windows Vista SP1 has been released and it is capable to solve some similar issues. You may try to upgrade and see if SP1 can mitigate this issue:

     

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3092361&SiteID=17

     

    Hope this helps!

     

    Cheers,

    Lionel

     

    Wednesday, April 2, 2008 6:04 AM
  • As I told u I got the latest drivers and the latest service pack....

    the thing I can not understand is where is this switch to say disable the sound.


    should I look into registry ?  
    Wednesday, April 2, 2008 8:21 PM
  • Hi

    I also have the same problem with Vista (Ulitmate 32bit with SP1) i.e. I am using Realtek HDA and although the sound works fine after a reboot, it stops working after the machine resumes from sleep. I loaded the most recent manufacturers driver (14th Feb 2008) but that didn't fix it.

    I tried the Microsoft Hotfix but that didn't install so I assume that is already included in SP1, which as I mentioned I am already using.

    From looking around on the internet this seems to be a fairly common problem and one that's been going on for a while with Vista.

     

    Any ideas ?

     

    Thanks,

     

    Simon

    Wednesday, April 9, 2008 8:35 AM