locked
Mail doesnt show in Sent Items RRS feed

  • Question

  • We are using Outlook 2010 and Exchnage 2013 and are struggling with a strange issue.

    We have Published outlook in online mode  through Citrix and user use it to access mails. Some uses have added additional shared  mailboxes in outlook.

    When a user tries to send a email or reply to the email that is sent to shared mailbox or when user sends a mail from shared mailbox , the mail is sent fine and the recipient receives it.

    However the mail doesn't show in the sent items list for the Shared Mailbox or the Users mailbox.

    Everything works on a normal PC where Outlook is running in Cached Mode.

    Tuesday, April 7, 2015 12:48 PM

Answers

  • Hi Kitaab,

    As mentioned earlier MS article says there is no option:

    For Outlook on Online mode:

    There is no resolution to this problem other than to either switch your profile to cached Exchange mode or set the DelegateSentItemsStyle registry value to zero (0).

    You might try setting the send\receive groups interval to 1min.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Kitaab Sunday, April 19, 2015 1:39 PM
    Friday, April 17, 2015 12:37 PM

All replies

  • No solution for this??
    Monday, April 13, 2015 9:42 AM
  • Hi Kitaab,

    Try these out. In earlier versions it was not possible to save shared mailbox sent items with user mailbox as primary, but now its possible.

    What is your CU level, is it CU5 and above.

    Check if below settings are correctly set. Client\GPO\Regedit etc.

    Change where sent e-mail messages are saved when using an Exchange account

    By default, a copy of each message that you send is saved in the Sent Items folder.

    When you reply to or forward an e-mail message that is saved in any folder other than the Inbox, you can configure Outlook to save a copy of the sent message in the same folder as the original message.

    1. On the Tools menu, click Options, and then on the Preferences tab, click E-mail Options.

    2. Under Message handling, the Save copies of messages in Sent Items folder check box must be selected.

      Message handling options

    3. Click Advanced E-mail Options.

    4. Select the In folders other than the Inbox, save replies with original message check box.

    https://support.office.com/en-in/article/Change-where-sent-e-mail-messages-are-saved-bd95ef3b-8c04-466a-8576-d1ce0eabeb2c#bm1

    Change the value of DelegateSentItemsStyle to 0 in the registry

    • Locate and then select the following registry key:
      HKEY_CURRENT_USER\Software\Microsoft\Office\<var>x</var>.0\Outlook\Preferences

      Note In this key path, the placeholder <var>x</var>.0represents 15.0 for Outlook 2013, 14.0 for Outlook 2010, 12.0 for Outlook 2007, and 11.0 for Outlook 2003.
    • Select the DelegateSentItemsStyle value.
    • On the Edit menu, click Modify.
    • Type 1, and then click OK.

    Email sent using Outlook are not saved to the Sent Items folder

    Messages sent from a shared mailbox

    Email messages that you send from a shared

    For Outlook on Online mode:

    There is no resolution to this problem other than to either switch your profile to cached Exchange mode or set the DelegateSentItemsStyle registry value to zero (0).


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Monday, April 13, 2015 10:11 AM
  • This setting for the registry already shows 1 

    However the sent item doesn't show up in either of the mailboxes. Not in the Primary Mailboxes Sent item or the Shared mailboxes sent item.

    This happens only when Outlook on the Terminal server  (Which uses Online Mode for Outllook)

    When we run Outlook in Cached Mode on Desktops they do not face this issue.

    Monday, April 13, 2015 3:04 PM
  • Hi Kitaab,

    What about Outbox(any emails stuck there), does it happen for all users profiles on all TS profile sessions.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Wednesday, April 15, 2015 5:42 AM
  • yes , the email are sent fine and received fine, however they seem to get stuck in the Outbox of the main mailbox.

    I had checked similar thing for office 365 (We have on premise Exchange 2013 )

    We already have the registry setting DelegateSentItemsStyle =1 

    Any other suggestion

    Wednesday, April 15, 2015 12:49 PM
  • Hi Kitaab,

    As mentioned earlier MS article says there is no option:

    For Outlook on Online mode:

    There is no resolution to this problem other than to either switch your profile to cached Exchange mode or set the DelegateSentItemsStyle registry value to zero (0).

    You might try setting the send\receive groups interval to 1min.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by Kitaab Sunday, April 19, 2015 1:39 PM
    Friday, April 17, 2015 12:37 PM
  • Thanks , it is a know issue as i see now and the only way to get this working is using a third part Outlook Plugin. Thanks for all the help guys.
    Sunday, April 19, 2015 1:39 PM
  • Hi All,

    Below is not directly related to the above issue, but worth mentioning for a heads-up on upcoming CU9 update.

    If enabled Shared mailboxes will retain a copy of emails sent from the mailbox. You will no longer have to figure out which mailbox member sent an email as the shared mailbox or on behalf of it.

    The feature is still coming to our on-premises customers in CU9, but will also be off by default. Admins can make a decision when to turn it on for which shared mailboxes.

    Want more control over Sent Items when using shared mailboxes?

    http://blogs.technet.com/b/exchange/archive/2015/03/03/want-more-control-over-sent-items-when-using-shared-mailboxes.aspx


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, April 23, 2015 7:21 AM
  • Thank you for this. Will share with our Exchange guys.
    Tuesday, April 28, 2015 8:54 AM
  • "There is no resolution to this problem other than to either switch your profile to cached Exchange mode or set the DelegateSentItemsStyle registry value to zero (0)."

    This is incorrect as i have just solved it. If you set to 0 , then the item goes to the users mailbox. Still better than completely disapearing, but not ideal. We want it to go to the sent items of the shared account (obviously microsoft! come ON!) So using exchange 2016 (and probably 2013 too) I have been able to configure exchange IN ONLINE MODE to save the item to the sent items in the shared mailbox.

    I used this method here:

    https://blogs.technet.microsoft.com/exchange/2015/03/03/want-more-control-over-sent-items-when-using-shared-mailboxes/

    TLDR basically, go onto the exchange server. and run the following command on the shared mailbox to enable this. You enable on the shared mailbox and it appears that the clients simply honour that and do not need to be reconfigured. My issue was if i did switch people to cache mode, i would have had to delete and recreate their profile which was not as seemless as i would have liked. The command is:

    set-mailbox <mailbox name> -MessageCopyForSentAsEnabled $True

    Once you do that, (and possibly restart outlook) then all sent mails from the shared mailbox (using the FROM field) will go to the sent items folder in the shared mailbox, even when not using cached and using ONLINE mode. Success!

    This is using outlook 2016 as well, but its on the server setting so all interfaces should honour that i would hope.

    EDIT: AH nevermind this didnt work. Well it worked, but if you have some people in online mode and some in cached mode, it will duplicate the sent items for those in cached mode. Some of our users are in cached and some are in online, so this solution will not work for us. I end up having two sent items for the users in cached mode.



    Thursday, October 20, 2016 5:02 PM