locked
Setup failed to connect to SQL database RRS feed

  • Question

  • Hello all,

    I'm getting this error while trying to install MS SharePoint Server 2010.

    Actually, i'm not very sure on what to put on SQL setup asked. Maybe you can help with some pictured errors as below:

    This is what I put on the setup config:

    and this is my SQL console:

    http://i.imgur.com/VQgTv.jpg

    I'm trying to install SharePoint on server SXC05

    While SQL server (MS SQL Server 2008 R2) is installed in server SXC02

    Both servers are using Windows Server 2008 R2.

    Appreciate your help and advice.

    Thanks!


    ---Packie

    Friday, June 29, 2012 4:55 AM

Answers

  • Apart from above recommendations, you may check if your firewall on SXC02 is enabled or not.
    Tuesday, July 3, 2012 9:31 AM
  • Hi Packie,

    You need make sure your user have full permission to create database. Please try to give it "dbcreator" permission or above. Here is a screenshot link about it:
    http://sdrv.ms/QZ2tW4

    Thanks,
    Lhan Han



    Tuesday, July 3, 2012 2:39 AM
    Moderator
  • Hi,

    Also while executing configuration wizard right click on the wizard and select run as administrator.


    Thanks, Rahul Rashu

    Tuesday, July 3, 2012 3:08 AM
  • Hi,

    Give "DBCrreator" and "SecurityAdmin" permissions to the account.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, July 4, 2012 7:22 AM
  • ^Thanks. I've disabled firewall and able to proceed to the next screen.

    Now i'm thinking to apply port exception on my server than to disable the firewall off forever.

    Thank you again :)


    ---Packie

    • Marked as answer by Patrick M Friday, July 6, 2012 2:59 PM
    Thursday, July 5, 2012 2:14 PM

All replies

  • Hi Packie,

    You need make sure your user have full permission to create database. Please try to give it "dbcreator" permission or above. Here is a screenshot link about it:
    http://sdrv.ms/QZ2tW4

    Thanks,
    Lhan Han



    Tuesday, July 3, 2012 2:39 AM
    Moderator
  • Hi,

    Also while executing configuration wizard right click on the wizard and select run as administrator.


    Thanks, Rahul Rashu

    Tuesday, July 3, 2012 3:08 AM
  • Apart from above recommendations, you may check if your firewall on SXC02 is enabled or not.
    Tuesday, July 3, 2012 9:31 AM
  • Hi,

    Give "DBCrreator" and "SecurityAdmin" permissions to the account.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, July 4, 2012 7:22 AM
  • ^Thanks. I've disabled firewall and able to proceed to the next screen.

    Now i'm thinking to apply port exception on my server than to disable the firewall off forever.

    Thank you again :)


    ---Packie

    • Marked as answer by Patrick M Friday, July 6, 2012 2:59 PM
    Thursday, July 5, 2012 2:14 PM