locked
Customizing the report viewer web part RRS feed

  • Question

  • When I try to configure ReportViewer.dwp

    I get this message "This web part has not been configured correctly. Please contact the document owner."

    The reports load without error though.

    Suggestions please?

    Monday, February 6, 2012 7:41 PM

All replies

  • Hi,

    Please make sure the web.config file of your web application contains

    <SafeControl Assembly="Microsoft.ReportingServices.SharePoint.UI.ServerPages, Version=10.50.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.ReportingServices.SharePoint.UI" TypeName="*" Safe="True" />
    <SafeControl Assembly="Microsoft.ReportingServices.SharePoint.UI.WebParts, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.ReportingServices.SharePoint.UI.WebParts" TypeName="*" Safe="True" />

    Regards,

    Seven

    Wednesday, February 8, 2012 7:16 AM
  • Is it the "web.config"  file under 14/CONFIG/..  on my server OR the one(s) for each webapplication under c:/inetpub/wwwroot/wss/virtualdirectories/..?

    Where exactly do I add these lines?

    It is already present in my web.config file of my web application (under c:/inetpub/wwwroot/wss/virtualdirectories/...)

    Please advise

    • Edited by GoingForward Wednesday, February 8, 2012 2:12 PM
    Wednesday, February 8, 2012 1:40 PM
  • Hi,

    1. Please make sure you have permissions to edit it.

    2. You can try to download it to change it and then upload it to web part gallery.

    Regards,

    Seven

    Thursday, February 9, 2012 8:01 AM
  • I am part of the administrative group and am also the domain administrator. Shouldnt these permissions be enough.

    Thursday, February 9, 2012 1:28 PM