locked
Mobile won't work on second pool RRS feed

  • Question

  • I have set up a second SfB pool, using the same Edge server as the primary pool, and everything works except for mobile. I originally had forgotten to set up reverse proxy, but that is now set up and working and I still can't sign in via mobile. I have 2 pools US.company.com and EU.company.com (US being the first). Everything works with the EU pool as far as signing in internally, signing in via the internet, etc. except for mobile. I have a single Edge server and a single reverse proxy server for both pools. The external web services for the US pool are set as RP.company.com and published on 80 and 443. The external web services for the EU pool are set up EU-RP.company.com and published on 81 and 444.

    I can get EU-RP.company.com from the internet without issue. I have loaded eu-rp.company.com:444/certprov/certprovisioningservice.svc/mex and it loads without problem. So I know I am getting through to the server. But when I try to sign in via mobile I get the error "We can't sign you in because you aren't set up to use Skype for Business. Please contact your support team." In looking through the logs from the mobile app I do see an error when it tries to access eu-rp.company.com:444/ucwa/v1/applications, but that is the only error I can find. I'm not sure why that page won't load but the others will. Is there something I am missing here?

    Monday, November 14, 2016 9:35 PM

Answers

  • I figured it out. In the reverse proxy, I had missed a single setting. I had the Authentication Delegation set to No delegation and client cannot authenticate directly.  Once I fixed that it started working.
    • Marked as answer by Steve Weide Wednesday, November 16, 2016 1:31 PM
    Tuesday, November 15, 2016 2:25 PM

All replies

  • Hi,

    Seems to be a problem of second pool. Validate all mobility configurations are done, make sure both pools at same CU level.

    I believe you have open required ports in both sites, and no port restriction between pools.

    can you share the log section where you see this error.  


    Malinda Perer | MCSM - Chatter Communication | MCM - Lync 2010 and OCS 2007 | http://malinblog.com/ | https://sg.linkedin.com/in/malindap

    Monday, November 14, 2016 11:28 PM
  • I figured it out. In the reverse proxy, I had missed a single setting. I had the Authentication Delegation set to No delegation and client cannot authenticate directly.  Once I fixed that it started working.
    • Marked as answer by Steve Weide Wednesday, November 16, 2016 1:31 PM
    Tuesday, November 15, 2016 2:25 PM
  • Hi,

    you have two pools in one site or two site with two pools? Can you elaborate your environment?

     Once a client connects to the Autodiscover service it will be returned the external web service FQDN for either pool, depending on which pool the user account belongs to.

    http://blog.schertz.name/2011/12/deploying-the-lync-2010-mobility-service/


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work


    • Edited by Off2work Tuesday, November 15, 2016 2:44 PM Edit
    Tuesday, November 15, 2016 2:42 PM
  • Hi Steve,

    Welcome to our forum.

    From your second post, we know this issue has been solved, right?

    When we configure second pool on RP, it will be have same setting with first pool except for port. Thanks for your sharing, would you mark your reply as answer so that someone who has similar issue could find this thread as soon as possible. And if possible, you could share more details about this solution (include snapshots) with us, then mark it as answer.

    If there are any questions or issues, please be free to let me know.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 16, 2016 8:29 AM