none
Mail still routing to a scoped send connector

    Question

  • Hello

    This is my first time asking a question on this forum. I would really appreciate some help with a mail flow issue we are having. Ive also made up a few domain names to explain whats going on. 

    Our UK company has purchased a company in the US. We have installed an Exchange server in the US office with all roles installed. We have added their domain (USA.com) as an accepted domain and made this the primary SMTP address for all US users. We have created a scoped send connector so that all mail sent from their exchange server goes out through to a smart host (spam filter) which is different to the smart host in the UK. 

    In the UK, we have a three node DAG and two CAS server which are load balanced by a Kemp load balancer. 

    In the UK, we have a scoped send connector which sends email to our current smart host (spam filter) and all mailboxes have unitedKindom.com as their primary SMTP Address. 

    The smart host (spam filter) in the US is configured to only allow email addresses from USA.com, so if someone from the UK sends and email, it CANNOT go out through the US Scoped Send connector, as it will get blocked by their spam filter. 

    But lo and behold, if someone in the UK sends an email to a recipient with a USA.com address and includes an external recipient in the email, the email is sent all the way down to the US and out through the US scoped send connector. Their smart host (spam filter) blocks the message and gives the following error in the NDR:

     - "Remote Server returned '553 sorry, relay of mail is not allowed. (#5.7.1)'"

    One thing I have checked it that my AD Sites and Services are setup correctly. They definitely are. 

    So why are these emails going down to the US send connector, which are scoped and also have the US exchange server as their "Source Server"?

    Many Thanks

    Wednesday, July 26, 2017 3:24 PM

All replies

  • track the email i suspect it is being decomposed by the usa side because it has a USA recipient in the email.

    what if the test email includes a UK recipient, a USA recipient and external recipient (3)?

    Wednesday, July 26, 2017 3:29 PM
  • I have run that test and as you suspected, the email has been delivered, which means its gone out of the correct UK send connector. 
    Wednesday, July 26, 2017 5:08 PM
  • So now all i need to know is if its possible to get this to work when I am sending to a US mailbox and an external recipient, without having to include a mailbox in the UK, 
    Wednesday, July 26, 2017 8:20 PM
  • Hi Judd,

    Is there only one send connector in UK site? 

    We can also check if the US server exists as a source server in UK scoped send connector, if yes, try delete US server from source server and check again.

    Best Regards,


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 27, 2017 6:37 AM
    Moderator
  • Hi Niko

    Thanks for you reply...

    I have three "UK" send connectors that have UK servers as their "Source Server".

    1. The first one connects internally to a notes server

    2. The second is used to journal email to Mimecast using a custom Address Space. 

    3. The third send connector has an address space of * which sends all of our email to the internet. 

    I have double checked the US send connectors. They only have US servers as their source server. I have also double check the UK send connectors and they only have UK server as the Source Server. 

    Thursday, July 27, 2017 10:16 AM
  • Did you check the box "Scoped Send Connector" ? 

    Even though you added Source servers in US and UK connectors , leaving Scoped Send Connector "unchecked" allows transport servers in other sites  relay through the send connector.

    Thursday, July 27, 2017 4:12 PM
  • Hi Judd,

    If we disable the current send connectors and create a new one in UK site with the same settings(enable scoped and leave UK server as the source server), check if there is the same issue.

    Best Regards, 


    Niko Cheng
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, August 2, 2017 7:54 AM
    Moderator