none
Images not displayed in IE8, but shown in Chrome & Firefox RRS feed

  • Question

  • I have added a image in SiteAssets library. I have referred to that image in my aspx page. While redering page, image is not rendered in IE. While same image is rendered correctly in Chrome / Firefox . Am I missing something here?

    Thanks for help in advance.

     

    Monday, October 11, 2010 10:13 AM

Answers

  • Just to confirm

    -> At the start, image was not displayed in both the machines (yours & your friends)

    -> After making the web application settings, it started working in your friends machine. But the same setting what you did in your CA did not work.

     

    If yes to the above questions then try the following

    -> Try hitting the image url directly in the browser. Verify if it displays the images or prompts you with open save dialogue box.

    -> Try to put the image directly in the images folder of 14 hive directly and and restart IIS and refer that image in the page. Verify if that works


    Satheesh
    • Marked as answer by Manoj Attal Tuesday, October 12, 2010 4:39 AM
    Monday, October 11, 2010 4:43 PM

All replies

  • Hi there.

    How are you referrning the URL to the image? Absolute or relative? Try change to the other to see if that changes anything. hat is the reason you don't see the image? A 404 (not found) or 401 (permission issue?). Fire up the Fiddler web debugging tool to find that out.

    Hope this helps.

    Regards,

    Magnus


    My blog: InsomniacGeek.com
    Monday, October 11, 2010 10:58 AM
  • Thanks Magnus.

    I fired fiddler & I found that image url returned 401 code in both IE & Chrome. But Chrome, Firefox showed the image, while IE did not show that. Is there any way by which I can show it in IE as well?

    Monday, October 11, 2010 11:47 AM
  • The image is outside sharepoint?
    If this is true, you problably need go to internet explorer Tools>Internet Options>Security tab and add the path for that image as trusted sites.
    André Lage Microsoft SharePoint, CRM and Sybase Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    Monday, October 11, 2010 12:18 PM
  • SharePoint 2010 is having special security through which contents of the sharepoint will not be delivered as content to another page (by making http headers it will push to download).

    Go to central administration, Select the Web application, From the ribbon select General Settings and in the section Browser File Handling set as 'Permissive' from 'Strict'.

     

    This should solve the issue.

    Following post is also explaining similar issue, but instead of image it is silverlight

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010general/thread/35474989-2f56-42ff-a7a1-3094fd654aee


    Satheesh
    Monday, October 11, 2010 12:28 PM
  • @Andre - Image is inside SharePoint only. Though I added the path in trusted sites, it didn't work out.

    @Satheesh - I have done the said setting in central administation site. Still issue remains the same.

    I tried the same thing on my colleague's machine. But it worked out on his end. Image was rendering correctly. Is there any clue what this issue could be?

    Monday, October 11, 2010 12:57 PM
  • So this works with antoher user account ?

    Could it be a permission issue on the resource/image? Do your account that you are testing with have permissions to access that image?

    If so, and this problem is on one client machine only, and works on all the others? If that is the case, try to reset the Internet Explorer Security settings, clear history and cookies for that client and see if that helps.

    Regards,

    Magnus


    My blog: InsomniacGeek.com
    Monday, October 11, 2010 1:09 PM
  • Agree,

    if work with other user account that will be permission problem...


    André Lage Microsoft SharePoint, CRM and Sybase Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    Monday, October 11, 2010 1:16 PM
  • It seems I was not clear in my response. What I meant to say is that I deployedthis application on other machine. Then when I accesed the web application in other machine, I could see the image in IE browser as well. I am admistriator on my machine. While I am a visitor in other machine where I have deployed the application.

    Is there any way to compare settings of applications in both machine and come to know whats issue with my machine?

    Monday, October 11, 2010 2:01 PM
  • Just to confirm

    -> At the start, image was not displayed in both the machines (yours & your friends)

    -> After making the web application settings, it started working in your friends machine. But the same setting what you did in your CA did not work.

     

    If yes to the above questions then try the following

    -> Try hitting the image url directly in the browser. Verify if it displays the images or prompts you with open save dialogue box.

    -> Try to put the image directly in the images folder of 14 hive directly and and restart IIS and refer that image in the page. Verify if that works


    Satheesh
    • Marked as answer by Manoj Attal Tuesday, October 12, 2010 4:39 AM
    Monday, October 11, 2010 4:43 PM
  • Thanks Satheesh. It worked !
    Tuesday, October 12, 2010 4:39 AM
  • In my case, there seems to be no images folder in "14 hive" and it prompts to download the image when I paste the address of the image in directly, but there isn't more info in your post as to the reason for that. Can you please elaborate?
    Monday, May 2, 2011 3:01 PM