locked
4.4.1 Connection timed out RRS feed

  • Question

  • This has been asked on different threads in the past but the solutions mentioned are not working. I'm running Exchange Server 2007 with SP3 + update rollup 3-v2 on Windows Server 2008 R2 64-bit with SP1 and the latest patches. This is the one and only Exchange box we have (we don't use Edge transport) so it receives incoming mail directly from the internet (through our firewall). Here's the problem:

    I see an incoming email which is about 1MB in size are timing out after 10 minutes connecting to our mail server. Here's the log for an incoming mail that times out:

    sequence-number,local-endpoint,remote-endpoint,event,data,context
    0,our IP address:25,sender's IP address:25099,+,,
    1,our IP address:25,sender's IP address:25099,*,SMTPSubmit SMTPAcceptAnySender SMTPAcceptAuthoritativeDomainSender AcceptRoutingHeaders,Set Session Permissions
    2,our IP address:25,sender's IP address:25099,>,"220 mail.ourdomain.com Microsoft ESMTP MAIL Service ready at Wed, 14 Sep 2011 11:12:27 -0700",
    3,our IP address:25,sender's IP address:25099,<,EHLO owa.senderdomain.com,
    4,our IP address:25,sender's IP address:25099,>,250-exchange2007.ourdomain.com Hello [sender's IP address],
    5,our IP address:25,sender's IP address:25099,>,250-SIZE,
    6,our IP address:25,sender's IP address:25099,>,250-PIPELINING,
    7,our IP address:25,sender's IP address:25099,>,250-DSN,
    8,our IP address:25,sender's IP address:25099,>,250-ENHANCEDSTATUSCODES,
    9,our IP address:25,sender's IP address:25099,>,250-STARTTLS,
    10,our IP address:25,sender's IP address:25099,>,250-X-ANONYMOUSTLS,
    11,our IP address:25,sender's IP address:25099,>,250-AUTH NTLM,
    12,our IP address:25,sender's IP address:25099,>,250-X-EXPS GSSAPI NTLM,
    13,our IP address:25,sender's IP address:25099,>,250-8BITMIME,
    14,our IP address:25,sender's IP address:25099,>,250-XEXCH50,
    15,our IP address:25,sender's IP address:25099,>,250 XRDST,
    16,our IP address:25,sender's IP address:25099,<,MAIL FROM:<john.abc@senderdomain.com> SIZE=1028353,
    17,our IP address:25,sender's IP address:25099,*,08CE3485F3DA8D7D;2011-09-14T18:12:28.605Z;1,receiving message
    18,our IP address:25,sender's IP address:25099,>,250 2.1.0 Sender OK,
    19,our IP address:25,sender's IP address:25099,<,RCPT TO:<John.Doe@ourdomain.com>,
    20,our IP address:25,sender's IP address:25099,>,250 2.1.5 Recipient OK,
    23,our IP address:25,sender's IP address:25099,<,DATA,
    24,our IP address:25,sender's IP address:25099,>,354 Start mail input; end with <CRLF>.<CRLF>,

    about 10 minutes later...

    25,our IP address:25,sender's IP address:25099,>,421 4.4.1 Connection timed out,
    26,our IP address:25,sender's IP address:25099,-,,Local

    I have tried the following:

    • Setting the default receive connector "connection timeout" from 10 to 20 minutes
    • Setting Chunking Enabled to False (Set-ReceiveConnector -identity "Default MAIL" -ChunkingEnabled $False)
    • Setting BinaryMIMEEnabled to False (Set-ReceiveConnector -identity "Default MAIL" -BinaryMIMEEnabled $False)

    This particular incoming mail is still not coming through. The log shows the same thing (4.4.1 Connection timed out) over and over again. Some larger incoming mail (as much as 20MB, SIZE=21970363) are getting through just fine. I set the global limit at 30MB.

    What else should I do? Thanks in advance.


    • Edited by morph2-7 Wednesday, September 14, 2011 10:31 PM
    Wednesday, September 14, 2011 10:24 PM

All replies

  • Did you try disabling autotuning, there are some known issues with 2008.

    netsh interface tcp set global autotuning=disabled
     



    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Wednesday, September 14, 2011 11:13 PM
  • I just issued the command to disable autotuning. Do I need a Win2k8 server restart? I think I do because incoming mail still failed (connection timedout). This incoming mail has been retried for 2 days, once in every 10 minutes. What a waste of bandwidth.
    Thursday, September 15, 2011 4:34 PM
  • According to KB yes.

    http://support.microsoft.com/kb/934430


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Thursday, September 15, 2011 4:40 PM
  • I've restarted Windows 2008. Mail still isn't coming through. It's the same problem: "4.4.1 connection timed out".
    Thursday, September 15, 2011 5:40 PM