none
DisbleKeyprotectors - Wmi method Call for disable Bitlocker Key RRS feed

  • Question

  • Hi,

    i need to remotely restart a machine with Bitlocker enabled ,using DisableKeyProtectors() wmi method of Win32_EncryptableVolume Class.

    i know there are other ways ,but need to use the wmi.

    i want to disable the key protectors for only one restart ,cannot understand the syntax ,can someone post an example of how to pass the parameters to the method?

    this is the syntax from microsoft site:

    uint32 DisableKeyProtectors(
      [in, optional] uint32 DisableCount
    );

    Parameters

    DisableCount [in, optional]
    Type: uint32
    Integer that specifies the number of reboots for which the key protectors will be disabled. This parameter is only available on OS volumes.





    • Edited by Shai Mor Tuesday, February 27, 2018 7:33 AM syntax
    Tuesday, February 27, 2018 7:31 AM

All replies

  • The method requires a single number of reboots required.


    \_(ツ)_/

    Tuesday, February 27, 2018 8:44 AM
  • Thank's i tried it but seems like it wont work... i get an error message

    This is what i tried : 

    $b = gwmi -Namespace root\CIMv2\Security\MicrosoftVolumeEncryption -Class Win32_EncryptableVolume
    
    $b.DisableKeyProtectors(1)

    The error: 

    Cannot find an overload for "DisableKeyProtectors" and the argument count: "1".
    At line:3 char:1
    + $b.DisableKeyProtectors(1)
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [], MethodException
        + FullyQualifiedErrorId : MethodCountCouldNotFindBest

    When i call the method without specifying the number it works ,but the key protector not enabled after restart. 

    Wednesday, February 28, 2018 7:17 AM
  • For non-OS volumes:

    $b.DisableKeyProtectors()


    \_(ツ)_/

    Wednesday, February 28, 2018 7:26 AM
  • $b = gwmi -ns ROOT\CIMV2\Security\MicrosoftVolumeEncryption -class Win32_EncryptableVolume -Filter 'DriveLetter="D:"'
    $b.DisableKeyProtectors()


    \_(ツ)_/

    Wednesday, February 28, 2018 7:34 AM
  • The bitlocker is enabled on the OS volume c: drive ,i forgot to mention the OS is Win7 ,still not working...
    Wednesday, February 28, 2018 8:52 AM