locked
Trouble with manual install of systems behind a firewall RRS feed

  • Question

  • First - There is a firewall between this client and my SCCM 2012 Server.  Communication is allowed however between the two over the following ports:  80, 445 and 8530.  The Management Point is configured to allow HTTP client connections.

    Second - Most systems are not separated from this one by a firewall, those systems ARE able to be managed.

    Third -  There is an IP subnet Boundary created for this subnet, but the other clients (not separated by a firewall) exist within an Active Directory site Boundary.

    Baring all of that in mind, I'm going to paste in the resulting logs that I get when I try to run the installation manually from the command line with the following command:  CCMSetup.exe SMSSITECODE=WKS SMSSLP=ServerName.domainxyz.CORP SMSMP=ServerName.domainxyz.CORP FSP=ServerName.domainxyz.CORP

    I'd appreciate any help you may have to offer, thanks in advance!

    <![LOG[==========[ ccmsetup started in process 1000 ]==========]LOG]!><time="14:58:00.898+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:9601">
    <![LOG[Launch from folder C:\]LOG]!><time="14:58:00.929+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:680">
    <![LOG[CcmSetup version: 5.0.8239.1001]LOG]!><time="14:58:00.929+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:686">
    <![LOG[Running on 'Microsoft Windows 7 Professional ' (6.1.7601). Service Pack (1.0). SuiteMask = 272. Product Type = 18]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="util.cpp:2000">
    <![LOG[Ccmsetup command line: CCMSetup.exe  SMSSITECODE=WKS SMSSLP=ServerName.domainxyz.CORP SMSMP=ServerName.domainxyz.CORP FSP=ServerName.domainxyz.CORP]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:3719">
    <![LOG[Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:3924">
    <![LOG[Command line: CCMSetup.exe  SMSSITECODE=WKS SMSSLP=ServerName.domainxyz.CORP SMSMP=ServerName.domainxyz.CORP FSP=ServerName.domainxyz.CORP]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:3925">
    <![LOG[SslState value: 224]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:4572">
    <![LOG[No version of the client is currently detected.]LOG]!><time="14:58:00.960+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:2875">
    <![LOG[Task 'Configuration Manager Client Retry Task' does not exist]LOG]!><time="14:58:00.992+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="wintask.cpp:652">
    <![LOG[Updated security on object C:\Windows\ccmsetup\.]LOG]!><time="14:58:00.992+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9445">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="14:58:01.023+420" date="04-25-2016" component="ccmsetup" context="" type="2" thread="644" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error: ']LOG]!><time="14:58:01.023+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="state.cpp:215">
    <![LOG[A Fallback Status Point has not been specified and no client was installed.  Message with STATEID='100' will not be sent.]LOG]!><time="14:58:01.023+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="state.cpp:229">
    <![LOG[Failed to send status 100. Error (87D00215)]LOG]!><time="14:58:01.023+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="644" file="state.cpp:242">
    <![LOG[Downloading file C:\ccmsetup.exe]LOG]!><time="14:58:02.037+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:5827">
    <![LOG[Downloading C:\ccmsetup.exe to C:\Windows\ccmsetup\ccmsetup.exe]LOG]!><time="14:58:02.037+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:5911">
    <![LOG[File download 15% complete (262144 of 1740472 bytes).]LOG]!><time="14:58:02.130+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 30% complete (524288 of 1740472 bytes).]LOG]!><time="14:58:02.146+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 45% complete (786432 of 1740472 bytes).]LOG]!><time="14:58:02.146+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 60% complete (1048576 of 1740472 bytes).]LOG]!><time="14:58:02.162+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 75% complete (1310720 of 1740472 bytes).]LOG]!><time="14:58:02.162+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 90% complete (1572864 of 1740472 bytes).]LOG]!><time="14:58:02.177+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[File download 100% complete (1740472 of 1740472 bytes).]LOG]!><time="14:58:02.193+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="ccmsetup.cpp:9349">
    <![LOG[Download complete.]LOG]!><time="14:58:02.193+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:6008">
    <![LOG[Current directory is a not valid source location and no source was specified. Ccmsetup will attempt to auto find an MP source location.]LOG]!><time="14:58:02.193+420" date="04-25-2016" component="ccmsetup" context="" type="2" thread="644" file="ccmsetup.cpp:3337">
    <![LOG[Successfully created the ccmsetup service]LOG]!><time="14:58:05.188+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:3385">
    <![LOG[==========[ ccmsetup started in process 3712 ]==========]LOG]!><time="14:58:05.406+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="3720" file="ccmsetup.cpp:9601">
    <![LOG[Updated security on object C:\Windows\ccmsetup\cache\.]LOG]!><time="14:58:05.406+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="3720" file="ccmsetup.cpp:9445">
    <![LOG[Launch from folder C:\Windows\ccmsetup\]LOG]!><time="14:58:05.406+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="3720" file="ccmsetup.cpp:680">
    <![LOG[CcmSetup version: 5.0.8239.1001]LOG]!><time="14:58:05.406+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="3720" file="ccmsetup.cpp:686">
    <![LOG[In ServiceMain]LOG]!><time="14:58:05.422+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="4068" file="ccmsetup.cpp:3492">
    <![LOG[Successfully started the ccmsetup service]LOG]!><time="14:58:05.422+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:3396">
    <![LOG[Deleted file C:\Windows\ccmsetup\ccmsetup.exe.download]LOG]!><time="14:58:05.422+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:9657">
    <![LOG[Task 'Configuration Manager Client Upgrade Task' does not exist]LOG]!><time="14:58:05.422+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="644" file="wintask.cpp:652">
    <![LOG[CcmSetup is exiting with return code 0]LOG]!><time="14:58:05.422+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="644" file="ccmsetup.cpp:10798">
    <![LOG[Running on 'Microsoft Windows 7 Professional ' (6.1.7601). Service Pack (1.0). SuiteMask = 272. Product Type = 18]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="util.cpp:2000">
    <![LOG[Ccmsetup command line: "C:\Windows\ccmsetup\ccmsetup.exe" /runservice "SMSSITECODE=WKS" "SMSSLP=ServerName.domainxyz.CORP" "SMSMP=ServerName.domainxyz.CORP" "FSP=ServerName.domainxyz.CORP"]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:3719">
    <![LOG[Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:3924">
    <![LOG[Command line: "C:\Windows\ccmsetup\ccmsetup.exe" /runservice "SMSSITECODE=WKS" "SMSSLP=ServerName.domainxyz.CORP" "SMSMP=ServerName.domainxyz.CORP" "FSP=ServerName.domainxyz.CORP"]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:3925">
    <![LOG[SslState value: 224]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="4068" file="ccmsetup.cpp:4572">
    <![LOG[CCMHTTPPORT:    80]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8781">
    <![LOG[CCMHTTPSPORT:    443]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8796">
    <![LOG[CCMHTTPSSTATE:    224]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8814">
    <![LOG[CCMHTTPSCERTNAME:    ]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8832">
    <![LOG[SMSSLP:    ServerName.domainxyz.CORP]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8844">
    <![LOG[FSP:    ServerName.domainxyz.CORP]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8884">
    <![LOG[CCMFIRSTCERT:    1]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:8942">
    <![LOG[No MP or source location has been explicitly specified.  Trying to discover a valid content location...]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:4877">
    <![LOG[Looking for MPs from AD...]LOG]!><time="14:58:05.438+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:4885">
    <![LOG[Unexpected row count (0) retrieved from AD.]LOG]!><time="14:58:05.469+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="lsad.cpp:654">
    <![LOG[GetADInstallParams failed with 0x80004005]LOG]!><time="14:58:05.469+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="ccmsetup.cpp:298">
    <![LOG[Couldn't find an MP source through AD. Error 0x80004005]LOG]!><time="14:58:05.469+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="ccmsetup.cpp:4904">
    <![LOG[No valid source or MP locations]LOG]!><time="14:58:05.469+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="state.h:56">
    <![LOG[Failed to parse '"C:\Windows\ccmsetup\ccmsetup.exe" /runservice "SMSSITECODE=WKS" "SMSSLP=ServerName.domainxyz.CORP" "SMSMP=ServerName.domainxyz.CORP" "FSP=ServerName.domainxyz.CORP"' with error 0x80004005]LOG]!><time="14:58:05.469+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="ccmsetup.cpp:4758">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="14:58:05.484+420" date="04-25-2016" component="ccmsetup" context="" type="2" thread="4068" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1001 Deployment Error: No valid source or MP locations']LOG]!><time="14:58:05.484+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="4068" file="state.cpp:215">
    <![LOG[Sending Fallback Status Point message to 'ServerName.domainxyz.CORP', STATEID='100'.]LOG]!><time="14:58:05.484+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="state.cpp:284">
    <![LOG[<ClientDeploymentMessage ErrorCode="0"><Client Baseline="1" Platform="2"/></ClientDeploymentMessage>]LOG]!><time="14:58:05.484+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="statedetails.cpp:108">
    <![LOG[Request failed: 404 Not Found
    ]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="FSPStateMessage" context="" type="3" thread="4068" file="fsputillib.cpp:1347">
    <![LOG[Failed to send message to FSP. Error 0x80004005]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="state.cpp:327">
    <![LOG[Failed to send status 100. Error (80004005)]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="state.cpp:242">
    <![LOG[Failed to get client version for sending state messages. Error 0x8004100e]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="2" thread="4068" file="state.cpp:178">
    <![LOG[Params to send '5.0.8239.1001 Deployment "C:\Windows\ccmsetup\ccmsetup.exe" /runservice "SMSSITECODE=WKS" "SMSSLP=ServerName.domainxyz.CORP" "SMSMP=ServerName.domainxyz.CORP" "FSP=ServerName.domainxyz.CORP"']LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="0" thread="4068" file="state.cpp:215">
    <![LOG[Sending Fallback Status Point message to 'ServerName.domainxyz.CORP', STATEID='307'.]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="state.cpp:284">
    <![LOG[<ClientDeploymentMessage ErrorCode="-2147467259"><Client Baseline="1" Platform="2"/></ClientDeploymentMessage>]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="4068" file="statedetails.cpp:108">
    <![LOG[Request failed: 404 Not Found
    ]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="FSPStateMessage" context="" type="3" thread="4068" file="fsputillib.cpp:1347">
    <![LOG[Failed to send message to FSP. Error 0x80004005]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="state.cpp:327">
    <![LOG[Failed to send status 307. Error (80004005)]LOG]!><time="14:58:05.516+420" date="04-25-2016" component="ccmsetup" context="" type="3" thread="4068" file="state.cpp:242">
    <![LOG[CcmSetup failed with error code 0x80004005]LOG]!><time="14:58:05.547+420" date="04-25-2016" component="ccmsetup" context="" type="1" thread="3720" file="ccmsetup.cpp:10802">

     
    Monday, April 25, 2016 11:02 PM

Answers

All replies

  • Not sure if this is causing the failure, but I noticed this in the log:

    Failed to parse '"C:\Windows\ccmsetup\ccmsetup.exe" /runservice "SMSSITECODE=WKS" "SMSSLP=ServerName.domainxyz.CORP" "SMSMP=ServerName.domainxyz.CORP" "FSP=ServerName.domainxyz.CORP"' with error 0x80004005

    The SMSSLP parameter is not necessary since the SLP is no longer a separate role and is simply part of the management point itself (https://blogs.technet.microsoft.com/anilm/2012/05/05/managing-workgroup-clients-in-configuration-manager-2012/)


    Try removing that parameter and see if you get a different result.

    Tuesday, April 26, 2016 12:14 AM
  • Concur with Kevin.

    Also, why port 445? That's not used by ConfigMgr at all. 10123 is though and should be allowed.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Tuesday, April 26, 2016 12:45 AM
  • More info:

    About Client Installation Properties in Configuration Manager

    https://technet.microsoft.com/en-us/library/gg699356.aspx?f=255&MSPPError=-2147217396


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 26, 2016 9:29 AM
  • Thank you Kevin!  I removed the SMSSLP callout, but that didn't quite solve the problem.  I also had to add an mp/:ServerName.domainxyz.corp to get it installed and communicating correctly.  I appreciate your help!
    Wednesday, April 27, 2016 10:04 PM