locked
Cannot open documents from SharePoint 2007 Server RRS feed

  • Question

  • Is anyone else having problems opening SharePoint docs with the 2010 Beta? I am unable to open word or excel documents from my SharePoint 2007 site. I don't get any specific error code, just a window that states "Could Not Open 'http://document path/file.doc' Is there a compatibility issue between the beta and older versions of SharePoint?
    • Moved by Alicia CalesMicrosoft employee Wednesday, April 28, 2010 9:33 PM Forums Consolidation (From:Microsoft Office 2010 Application Compatibility)
    Wednesday, January 13, 2010 4:45 PM

Answers

  • Nate, could you please experiment with saving the document locally and then trying to open the document? Please report back your results. Thank you.

    Tuesday, January 19, 2010 10:45 PM

All replies

  • Hello, Nate.

    Can you save the docs from the server locally and then open them with the Office 2010 client? If yes, we need to move this question to the SharePoint forum.
    Thursday, January 14, 2010 5:32 AM
  • Nate, could you please experiment with saving the document locally and then trying to open the document? Please report back your results. Thank you.

    Tuesday, January 19, 2010 10:45 PM
  • I have the same problem as well. I can download an excel 2007 file from a SharePoint document library an open it without a problem. However if I click the document inside of IE8 I get the following dialogs:


    I'm using IE8 on Windows 7 x64, tried this in both compatibility mode and normal mode. When accessing the document library in Chrome, FF and Safari it simply downloads the file with no problems.
    • Edited by Gardiner Allen Friday, January 29, 2010 2:57 PM additional info
    Friday, January 29, 2010 2:42 PM
  • I was having this issue but a simple change in IE8 fixed it.

    Open Tools/Internet Options/Connections/LAN Settings and uncheck "Automatically Detect Settings".

    From there on out I am able to do all my work in SharePoint 2007 just like i did with Office 2007.

    System Setup:
    Dell Lattitude D630
    Windows 7 64bit
    Office 2010 Beta
    • Proposed as answer by AndyBradleyII Friday, February 5, 2010 10:05 PM
    Friday, February 5, 2010 10:04 PM
  • I was having this issue but a simple change in IE8 fixed it.

    Open Tools/Internet Options/Connections/LAN Settings and uncheck "Automatically Detect Settings".

    From there on out I am able to do all my work in SharePoint 2007 just like i did with Office 2007.

    System Setup:
    Dell Lattitude D630
    Windows 7 64bit
    Office 2010 Beta

    Thank you AndyBradleyII. I have been having a very difficult time getting documents to open from Office Live into Excel 2010. I kept receiving an error saying it could not open the file. Once I tried your suggestion, it worked perfectly and was able to successfully save back to my Office Live site. You are a lifesaver! Thanks again.
    Friday, February 12, 2010 7:38 PM
  • also worked for me.

    Wednesday, February 17, 2010 9:28 AM
  • I have the same issue for all documents on our MOSS.
    The same behaviour in Office 2010 32 or 64 bits version.

    I also have the "Automatically detect settings" checked on my IE8 / Win7 (64bit).
    But the problem is still there. The message is "Could not open....(filename)"

    Could it be a server issue based on where MOSS is running and/or the Domain controller is running?




    Friday, February 26, 2010 10:07 AM
  • Found this also http://social.technet.microsoft.com/Forums/en-US/office2010general/thread/33062a5c-6bf7-4e36-b788-9e753514a62f

    and it worked.

    Not a good solution from a security view, but I can continue to test Office 2010.

    Friday, February 26, 2010 10:34 AM
  • Had the same problem with Office 2010 and IE8.
    Unchecking the "Automatically detect settings" solved my problem (after restarting IE).
    Wednesday, March 3, 2010 7:54 AM
  • Had the same problem with Office 2010 and IE8.
    Unchecking the "Automatically detect settings" solved my problem (after restarting IE).

    Thanks.

    I tested both the suggested proxy change and *.* (not so good for safety reasons).
    The unchecking of "Automatically..." worked for me also.

    Wednesday, March 3, 2010 1:27 PM
  • This solved it for me as well. Thanks.
    Tuesday, March 9, 2010 7:17 PM
  • This solution worked for me! Thanks I was getting really frustrated on trying to figure it out.

    Thanks again.
    Jignesh Shah
    Thursday, March 11, 2010 11:22 PM
  • worked for me too
    Friday, April 9, 2010 8:03 PM
  • Hey, sorry for bringing up this thread again, but I've got an Office 2010 RTM installation and I can not open any Office documents from our Sharepoint 2007 site. There is no window displaying any error message. Word / Excel opens as usual, but does not show up any document. Saving the docs locally is possible and then I can open them with Office 2010.

    I also tried the mentioned solution with the proxy configuration. But this does not work for me. "Automatically Detect Settings" was never checked. Nevertheless this can't be a solution for a RTM Version.

    Tuesday, May 11, 2010 10:34 AM
  • Microsoft does great tings but  .. sometimes i hate it.

    I have the same problem as Max here above discribes. I cannot understand that this even can occur. I never had this problem in the Office 2010 beta. but now on RTM ..

    it tried al kind of settings in EI8 but no suloution for me so far.

    regards

    Koen

    Tuesday, May 11, 2010 6:52 PM
  • OK a few steps later.

    I connected to my internal network and now the documents open.

    My sharepoint 2007 sites are behind my ISA2006 server (ok not yet TMG :-) so where is the secret ?

    regards

    Koen

     

    Tuesday, May 11, 2010 6:58 PM
  • I am having the same problem with the proxy settings - had them setup in beta but still have to put them in for some users who are RTM. Any ideas?
    Wednesday, May 12, 2010 6:57 PM
  • still looking for the right answer. posting to my own sharepoint blog does not work neither :-( not in the domain or external from the domain.

     

    ?????

    Koen

    Tuesday, May 18, 2010 6:21 PM
  • I was having the same issue with the retail version. The only way to "fix" it was basically not to install Groove (SharePoint Workspace 2010) at all. If you completely disable it during installation, then everything seems to work well. But please note that I was upgrading from Office 2007, so I had Groove 2007 installed. I am not sure if this would work with a clean install.
    Tuesday, May 18, 2010 7:16 PM
  • Max, you are describing the same problem I have.  I was able to move this one step forward, but haven't found a solution. 

    Our original sharepoint site used Basic Authentication, so that people wouldn't have to give a domain name when logging in.  But this doesn't work for search, so I extended our sharepoint site and used Integrated Windows Authentication on the new site.  

    Still with me?  In IIS there are two sites, both pointed at the same content.  They authenticate differently, one uses Basic the other Windows Integrated.  When the problem you describe came up, I found that the site using Integrated Windows authentication works.  The site using only Basic authentication does not. 

    I've seen a couple of other posts here and there with this exact problem (search on office 2010, basic authentication, and sharepoint) but none of them have an answer.

    -Paul

    Wednesday, May 19, 2010 9:34 PM
  • Hey Paul,

    i think you're right! It seems like this is a common problem. Where is Micheal Kiselman? ;)

    Thursday, May 20, 2010 6:08 PM
  • Hello all. I'm having a similar issue but it's specific to the following combination.

    Moss 2007 Word 2010 in this way--

    If I have a document library there's no issue, i can open, close, save etc. I can add certain sharepoint columns like Single line of text, choice, currency, date time etc. Still there is no issue with Office 2010 word opening the document from the library and dynamically creating the document panel etc.


    THE ISSUE where word crashes is "ONLY" when I use a "Person or Group" column. 100% of the time when I add one of these and then go to open the document it will crash and crash and crash.

    If and when I remove the "Person Or Group" column, I can the open/edit/save the document with word 2010. This is horrible, not nearly acceptable, causing a HUGE problem for us here. The point of having sharepoint libraries was to be able to use the metadata in the libraries of course and one thing we use heavily is that column. I use it for assigning documents to staff, showing whos the lead on a document, used by workflows and much much more.

     

    This is the issue I have and it's 100% repeatable from any system. I've created slick labs using VM's with a slick AD, Slick Moss 2007, slick Windows XP to windows 7 and when i mix Word 2010 with Moss document library 2007 with a people or group column BANG..

     

    Please come up with a hot fix or something because right now my entire organization is halting on upgrading Office because we are a huge user of SharePoint and there is massive investment in Moss 2007 and currently is not working.

    Heeeelp!  :)

     

    I hope there is a fix

    Tuesday, June 8, 2010 1:04 PM
  • Same problem here. Office 2010, WSS 3.0 with FBA. Can't get it to open documents in Office 2010 (works in office 2003). I'm also using IE7 and have tried all above mentioned workarounds to no avail (proxy, disabling automatic settings detection etc). I have also set Intranet zone permissions to low but that didn't make a difference either.

    I'd really appreciate another suggestion.

    Tuesday, June 15, 2010 3:10 AM
  • Same problem and none of the above works for me. Please help us out MS.
    Thursday, June 17, 2010 5:04 AM
  • I have a similar problem. I can open documents in Word 2010 by opening the menu in sharepoint and selecting "edit in microsoft word". However, this only works for docx files. Excel files (even .xlsx) and .doc files give me an error message. I guess this must be an IE problem or a file association problem.

    I tried registering the OWSSUPP.DLL in office12 and office14 folders which returns an error.

    I tried the office 2007 diagnostics

    I uninstalled all 2007 and 2010 software (visio 2007, office 2007, office 2010, sharepoint 2010) and reinstalled only office 2010.

    installed sharepoint designer 2010 and 2007

    I tried unchecking the "automatic detect settings" and the *.* proxy in IE8

    No luck so far.

    Thursday, June 17, 2010 10:54 AM
  • The solution which works for me I found on this blog:

    http://howtosharepoint.blogspot.com/2010/04/word-experienced-error-trying-to-open.html

    "Below are the steps..

    1. Run one of the Office 2010 application (e.g. Word 2010).
    2. Click on File menu, and select Options.
    3. In the “Options” dialog, select Trust Center in the left pane.
    4. Click on Trust Center Settings in the right pane.
    5. Select Protected View in the left pane of “Trust Center” dialog.
    6. Disable any of all of the protected view options as below by unticking the check boxes:
      • Enable Protected View for files that fail validation
      • Enable Protected View for files originating from the Internet
      • Enable Protected View for files located in potentially unsafe locations
      • Enable Protected View for Outlook attachments"
    Thursday, June 17, 2010 11:50 AM
  • The solution which works for me I found on this blog:

    http://howtosharepoint.blogspot.com/2010/04/word-experienced-error-trying-to-open.html

    "Below are the steps..

    1. Run one of the Office 2010 application (e.g. Word 2010).
    2. Click on File menu, and select Options.
    3. In the “Options” dialog, select Trust Center in the left pane.
    4. Click on Trust Center Settings in the right pane.
    5. Select Protected View in the left pane of “Trust Center” dialog.
    6. Disable any of all of the protected view options as below by unticking the check boxes:
      • Enable Protected View for files that fail validation
      • Enable Protected View for files originating from the Internet
      • Enable Protected View for files located in potentially unsafe locations
      • Enable Protected View for Outlook attachments"
    I tried this as well and it doesn't work for me. Just to give you a bit of information. If I use the 'Open in Windows Explorer' feature and then try opening a file from there it doesn't work either so I don't think this issue has anything to do with IE settings.
    Thursday, June 17, 2010 11:26 PM
  • Nope, didn't work for me.
    Friday, June 18, 2010 9:03 PM
  • Hey Paul,

    i think you're right! It seems like this is a common problem. Where is Micheal Kiselman? ;)


    Ever find a solution?  I kind of shelved it for a while.
    Friday, June 18, 2010 9:17 PM
  • I'm ecstatic with joy. I think I finally solved this one. My default browser is of course FIREFOX which has it's own proxy settings (PAC file). No matter what I did to IE proxy setting, nothing helped. As soon as I changed my default browser to IE, it magically started working. So perhaps try doing that.
    Tuesday, June 22, 2010 1:06 AM
  • I resolved mine differently and may be a solution to many of you.

    If you are using the 64-bit version of Office 2010, try opening your SharePoint documents using Internet Explorer 64-bit.

    This worked for me. :)

    • Proposed as answer by phetherweyt Tuesday, June 22, 2010 8:21 AM
    Tuesday, June 22, 2010 8:21 AM
  • Hi,

    I see couple of them resolved the issue and few still have a problem.  Following information will help where there is an issue

    1. Please describe Authentication Scheme for the Web Application (FBA, Basic W/SSL, and Windows Integrated)

    Is Anonymous enabled?

    2. Following support solution may help

    http://support.microsoft.com/kb/928692 

    http://support.microsoft.com/kb/943280

    Thank you

    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, June 23, 2010 2:51 PM
  • I am still having the problem of not being able to open Excel or Word files from SharePoint 2007. I had to problems prior to upgrading to Office 2010. There are no errors when trying to open file directly, the appropriate application loads but the document never loads. Downloading the file and then opening it locally works correctly. I have tried the solutions outlined above and nothing has changed this behavior. SharePoint is using Basic Auth but not anonymous. 

    Any other ideas?

    Thursday, June 24, 2010 7:33 PM
  • Hi,

    Please clarify the Client Operating System including service pack level and try running Repair of Office 2010 see it helps.  Whether the WebClient is recycled after applying the support solution.   Please try moving the site to Trusted location

    Whether the Web Application is enabled with both NTLM and Basic?

    Thank you,

    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, June 28, 2010 1:47 PM
  • Sundar,

    Thank you very much for taking an interest in this.  I'll try to give you what you have asked for:

    KB 943280 - fixed with Windows 7 and I am still seeing this on Windows 7.

    KB 928962 - the registry fix did not work on my Windows Server 2003 sp2.

    I'm not sure this is at the web application level.  In IIS I have two sites.  The first uses Windows Integrated Authentication and anonymous access is not enabled.  That site works.  The second site uses Basic Authentication and anonymous access is enabled.  That site has the problem.  I disabled anonymous access and restarted the site (but not iis) and that did not fix anything so I put it back the way it was.  In IIS there are three applications: DefaultApp Pool, Sharepoint - 80 and Sharepoint Central Admin.  As I mentioned earlier, the site with Basic Authentication was extended to create the site with integrated authentication in order to get search to work.

    Within Sharepoint there under alternate mappings there are two url's.  The first points at the site using Integrated Auth is in the Default Zone and the second url pointing at the site with Basic Auth is in the custom zone.

    Under Application Management > Authentication Providers the two zones are defined exactly the same (which puzzles me a little):  Authentication Type: Windows; Anonymous is enabled; IIS Authentication Settings are Basic for both; and enable client integration is Yes.

    -Paul

    Thursday, July 8, 2010 3:42 PM
  • Hello, I'd like to throw my problem into this mix as well.

    Windows 7 64-bit, IE8, upgraded from Office 2007 to Office 2010.

    We need to open documents from our hosted sharepoint site at sharepointsite.net.

    When you just click on a document or select "Edit in Microsoft Excel" you get the dialog to edit or load read only. Then Excel starts but no document opens (blank). Doing a "send to->download a copy" then opening that after it's downloaded works fine.

    I've tried all the various ideas posted all over the place -- the fake proxy, ticking off the automatic proxy selection, uninstalling Sharepoint 2010, and so forth but nothing changes this behavior.

     

    (PDF's posted on our sharepoint site still open fine -- this is only happening with documents that need to open in Office 2010).

    Everything worked fine in 2007.

    Friday, July 9, 2010 1:45 AM
  • Office 2010 doesn't seem to support basic authentication by default. so if you use it in your sharepoint, word or excel open then does not ask for credential and open blank.

    you need to add a registry key:

     HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet, add a  DWORD called  BasicAuthLevel with a value = 2

    should work now.

    (ref: http://www.howtofixcomputers.com/forums/microsoft-office/office-2010-basic-authentication-iis-fails-open-documents-284877.html)

     

    • Proposed as answer by Corner3 Friday, July 9, 2010 10:46 AM
    Friday, July 9, 2010 7:12 AM
  • Ok with the new registry key the problem is solved but I have to authenticate a second time.

     

    THX

    Friday, July 9, 2010 10:46 AM
  • THANK YOU! Worked like a charm. Appreciate it!
    Friday, July 9, 2010 12:01 PM
  • The new DWORD worked for me too in Server 2003 sp2.  For a giggle I also tried adding the DWORD to HKLM\software\microsoft\office\14.0\common\internet but that did not work for me.

    This is nice to know, but doesn't solve my problem:  25 or so customer portal sites that authenticate using basic auth.  The requirement was that they be able to log in using <username> rather than the form <domain>\<username>.  There is no way I will be able to get my customers to add this key when (if) they upgrade to Office 2010, so I guess I have a brief window to change everything over to forms based authentication.  Unless somebody has a better way of achieving the username requirement.

     

    BTW, this might not work for Vista, see Sundar's link to KB 928692.

    -Paul

    Friday, July 9, 2010 2:34 PM
  • Hi

    Thanks for all the updates.   Office 2010 Client connecting to site enabled with Basic Authentication will require following solution on the client:

    1) Apply Solution http://support.microsoft.com/kb/928692 - Solution for Vista or Windows Client Operating System

    2) Additional changes required in Office 2010 environment - Solution to be implemented for all Client Operating System

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet

    Add a new DWORD Value named BasicAuthLevel ,

    Right-click BasicAuthLevel , and then click Modify.
    In the Value Data box, set the appropriate value for the BasicAuthLevel registry key:
    0 means basic authentication not allowed
    1 means basic authentication is allowed on only SSL connections
    2 means that basic authentication is always allowed

    Restart your computer.

    In some scenarios client side solution is not possible there may be possibility to avoid Authentication Prompt for Office Documents. Please read the http://support.microsoft.com/?kbid=2019105 may provide clue

    Thank you,

    Sundar - MSFT

     


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, July 12, 2010 5:35 PM
  • Hi,

    I didn't have the Internet folder in the registry location mentioned above. So i've created it and then added the key however with no change in the symptoms. I've changed the BasicAuthLevel in the KB928692.

    I click on the link within Sharepoint, the software (e.g. MS Word) launches but no document is opened. I am running Office 2010 Standard, Win7 64bit and IE8.

    Can anyone provide further direction?

    Thanks

    Tuesday, July 13, 2010 10:45 AM
  • Hi Stella74,

    The registry fix for very specific scenario (Example: Site configured with Basic Authentication and Client environment is Office 2010).  

    Please check the following:

    1. WebClient Service is enabled

    2. Contral Panel | Program | Uninstall a Program | Select Microsoft Office Professional 2010 | Change | Add or Remove Feature - Verify Office Tools | Microsoft SharePoint Foundation Support is installed.

    3. Repair Office from Contral Panel | Program | Uninstall a Program | Select Microsoft Office Professional 2010 | Change

    4. Try http://support.microsoft.com/kb/943280 if the SharePoint URL is FQDN

    Thank you,

    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 13, 2010 7:18 PM
  • Hi,

    As mentioned I'm using Office 2010 to access documents from WSS 3.0. Sharepoint is externally hosted and requires a basic auth login with hosting\username and a password.

    1. WebClient service enabled and running

    2. MS SP Foundation Support installed

    3. Office repair run

    4. Tried the KB

    5. All registry refs to BasicAuthLevel changed to 2.

    Still same symptoms - I click on the link within Sharepoint, the software (e.g. MS Word) launches but no document is opened.

    Cheers

    Tuesday, July 13, 2010 11:55 PM
  • Just as an additional point, when I map a network drive to the Sharepoint web location, I have the same experience of not being able to open the documents.
    Wednesday, July 14, 2010 1:56 AM
  • I've found that if I copy the shortcut, paste it in to the address bar and then replace the %20 with a regular space and the document opens.

    Interesting fact, but not a solution as we can't control whether users include spaces in their documents or folders.

    Update: I've just tried the copy and paste with no changes to the shortcut and it still opens the file.

    Wednesday, July 14, 2010 11:20 AM
  • Hi Sundar,

    Can you provide any further guidance as we're unable to proceed with a Office 2010 upgrade until this issue is resolved?

    Many thanks.

    Monday, July 19, 2010 7:19 AM
  • Hi Stella74,

    The issue need closer look since environment will be different my suggestion is to open a Microsoft Support case to assist further.  Please check the site http://support.microsoft.com/ for more details.

    Thank you,

    Sundar - MSFT  


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, July 19, 2010 3:03 PM
  • Hi Everyone,

    We have some further information which has provided somewhat of a resolution.

    We have added the BasicAuthLevel = 2 DWord to the following key.

    HKEY_USERS\S-1-5-21-3173002913-2220990406-1037203124-4101\Software\Microsoft\Office\14.0\Common\Internet

    Unfortunately, this would be different for each user so not a fix we can push through Group Policy.

    Putting the same DWord in to HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet does not work.

    Where can we go from here?

    Cheers

    Wednesday, July 21, 2010 10:44 AM
  • Righto everyone, just want to confirm the fix is as suggested.

    The issue in the previous post was due to UAC limiting access to regedit and as a result I was using "run as administrator". So obviously the CURRENT_USER was the admin account, not my logged in account...

    Tuesday, July 27, 2010 12:00 PM
  • A Microsoft knowledge base article is now available which explains this issue and details the workaround steps.

    http://support.microsoft.com/kb/2123563

    Please note this important point made regarding the workaround documented in the article - Caution: Enabling Basic Authentication without Secure Sockets Layer (SSL) can be a significant security risk. Because user credentials are not encrypted for network transmission, and are sent over the network in plain text, using Basic authentication over an unsecured HTTP connection is not recommended.

    Brian - MSFT

    • Proposed as answer by EthanW Wednesday, August 11, 2010 7:50 PM
    Thursday, August 5, 2010 6:28 PM
  • None of the answers worked for me. However, I was able to open documents in Word 2010 that are stored in MOSS 2007 by browsing the the site using Google Chrome. I know it's not a supported browser, but avoiding a Word 2010 crash makes it a reasonable solution until Microsoft resolves this issue.
    Wednesday, August 11, 2010 7:53 PM
  • Similar issue - now fixed - problem was restricted to a Vista PC with Office upgraded from 2007 to 2010.  Interestingly, my notebook Windows 7 with Office upgraded from 2010 beta to 2010 did not have this problem.  The Vista PC also did not have the problem until I "upgraded" it. 

    The most stubborn site was an https: extranet server with "CookieAuth.dll" front page authentication.  Other servers with plain forms-based authentication were generally OK after a few settings changes.  Anyhow the Windows Security dialog failed to appear on the Vista PC after the upgrade. 

    A trawl through IE8 and Office Trust Center settings didn't reveal a difference.  Editing the registry made no difference - it was a https server in any case.

    Finally having hit enough buttons, I managed to get the user name dialog to appear by File ... Open and pasting the .docx URL into it. The preceding steps included:

    • Clearing all browsing history, cookies, auto-complete
    • Removing the site from Trusted sites
    • Resetting Trusted sites security to "Medium level"
    • Disabled protected mode for trusted sites (IE8 Security)
    • Several reboots
    • Applied the web folder hotfix http://support.microsoft.com/kb/907306
    • Re-adding the site to 'Trusted sites"
    • Turning ON the 'prompt for user name and password' setting in IE8 Trusted Sites security settings (had done this earlier, but it didn't work until this later attempt)
    • Pasting the .docx URL into File ... Open dialog (attempts to open from SharePoint web interface not successful) 
    • Sometimes it works... sometimes takes an age

     

    Friday, September 3, 2010 6:24 PM
  • Similar issues...

    Selecting SharePoint document library ... Actions…Open with Windows Explorer a Vista/O2010/IE8 PC states “Your client does not support opening this list with Windows Explorer” (https site).

    Whereas a Win7/O2010/IE8 notebook pops up the Windows Security dialog and continues right on.

    Resolved with hotfix http://support.microsoft.com/kb/907306 tho' unfortunately not solved Word 2010's failure to prompt for user credentials

    Friday, September 3, 2010 6:51 PM
  • This is not an answer.  See info on BasicAuthLevel below for actual answer. 
    Wednesday, November 3, 2010 3:33 PM
  • We had similar problems after an upgrade to office 2010 when using IE7+ (IE6 doesn't appear to conflict).

    So far our investigations suggest that the IE session is passing off the "open document" process directly to the Office application, but Office doesn't have the credentials for the session and so it fails/blank screens etc.

    We have found that our proxy had the option to <in my words> "Hide the password request pop-up box" disabled. Unsetting this for the Sharepoint site (which was over the HTTPS session) means that the Office program now asks for the Sharepoint site's password, and the document subsequently opens.

    We tried unticking the Auto-detect options above, but this didn't work. Removing the proxy name (in the LAN Settings -> advanced settings) from the Secure connection worked, as did putting an exception for the sharepoint site into the Exceptions field. I don't believe either are good as it means you're passing secure information over an unsecured link (correct me if I'm wrong on this). I suspect one of the reasons why fixes work for some and not others is that the issue develops beyond the user's own settings - whether they use a proxy server, how it is configured, where Sharepoint is hosted etc all play a part.

    We use XP with a combination of browsers (IE6,IE7, IE8, Firefox) and Office versions and the combination of IE7+ and Office 2010 is the consistent combination where this issue develops.

    • Proposed as answer by Streekie Thursday, November 4, 2010 8:58 AM
    Thursday, November 4, 2010 8:58 AM
  •  Umm, is there an update to the info from this link??  (I get a 'page not found' error when I tried it today)  And I'm about Desperate at this point, Sharepoint seems to have NO ability to actually get Office 2010 to open any of the docs (.doc or .xls) from the Shared Documents folder in a Sharepoint Team site collection And/or Sharepoint Document site collection.

    Thanks for whatever current help you can provide

    Sean

    Friday, November 12, 2010 8:50 PM
  • All,

    I had the same problem.  I noticed that the Microsoft Office Upload Center document cache had become corrupt on my workstation. To fix the issue:

    1. Shutdown the MS Office Upload Center
    2. Delete the cache at C:\Users\<username>\AppData\Local\Microsoft\Office\14.0\OfficeFileCache
    3. Restart MS Office Upload Center so it can rebuild the cache
    4. Tested opening a Word document on SharePoint 2007 with Office 2010, success!

    Please let me know if this helps anyone out.

    Best Regards,

    Taylor

     

    *Note - I un-proposed as a answer as I figured others in the community should make the recommendation, I am new to the forums. :)

    • Proposed as answer by Taylor Howard Monday, March 7, 2011 7:36 PM
    • Unproposed as answer by Taylor Howard Tuesday, March 8, 2011 11:34 AM
    • Proposed as answer by ellison8 Tuesday, April 5, 2011 4:24 PM
    Monday, March 7, 2011 7:29 PM
  • This solution fixed the problem for me. We don't use basic auth but were still having the issue.

    Good catch Taylor.

    Tuesday, April 5, 2011 4:26 PM
  • Hi Brunchto,

    I have the same problem but above solution is not working for me. I have two different sharepoint foundation 2010 installed one is intranet(http) and another for customer(https). I prepare new terminal server and installed office 2010. when i open document from https (site for customer) i can view the document but when i open document from http (intranet) i can not view the document but i can download the document and view. while i have office 2010 install on my desktop and i can open document from intranet and external site.

    Could you please help me to find out the solution? And I have also try to uncheck automatic detect setting from IE9 but dis not work. 

    Thanks,

    Regards,

    Navi

    Monday, May 16, 2011 2:53 PM
  • This worked for me, but instead of un-checking it, I checked it. Thank you very much. That was a strange one.
    JJC
    Wednesday, August 10, 2011 9:02 PM
  • Thanks for posting this Taylor. Deleting the officefilecache fixed it for me.
    Tuesday, October 11, 2011 1:18 PM
  • MATT!  You're awesome.  Thanks for telling me how you fix yours.....i tried allll these suggestions and more and noting worked for me UNTIL you mentioned the officefilecache (of which i have no idea what it is) and BAM, I can now open my excel spreadsheets from sharepoint using windows 7 64 bit with office 2010 using IE 9 64bit to interface with sharepoint!!!! finally.

    this worked at first for a few weeks and then suddenly started giving me those annoying show-stopping errors. ( i could still open visio pics but not excel)  thanks again matt, and I looked up how to delete officefilecache.....

    1.Close all Office programs.
    2.Click the Ctrl + Shift + Esc keys to open the Task Manager.
    3.On the Processes tab, select MSOSYNC.EXE, click End Process, and then close the Task Manager.
    4.Navigate to %userprofile% \AppData\Local\Microsoft\Office\14.0\.
    5.Rename or Delete the OfficeFileCache folder.
    Wednesday, July 18, 2012 9:51 PM
  • Hi,

    I am facing the same problem. Some users are not able to open the attachments and their account gets locked who is accessing the application from another continent. Application runs on moss 2007 and upgraded to sp2. It seems problem started after patch upgrade.

    Applied all solutions suggested above but its not working for me. Please suggest the solution for me.

    Thanks for your help.

    Arvind

    Wednesday, March 6, 2013 10:42 AM