none
Desktop Wallpaper GPO not working

    Question

  • Hello,

    I'm in a lab environment using VMware Workstation 11. I 've got 1 Domain Controller running Windows Server 2012 R2 (DC01) and 1 Workstation running Win 7 Pro (WS01).

    I have tried to configure a GPO that would change the wallpaper for my domain users, but it's not working.

    What I've done so far:

    1. DC01 is the Domain Controller

    2. Added WS01 to the domain just fine.

    3. Created the GPO named "Desktop Wallpaper" and added the security group that has a particular user that I'm using for this lab in it.

    4. I then restarted WS01 and log on with that user that's in the security group and nothing happens.

    If I were to right click the desktop and go to change background on the WS01 the name of the jpg is there but no picture.

    Please Help,

      

    Saturday, January 30, 2016 9:28 PM

Answers

All replies

  • If I were to right click the desktop and go to change background on the WS01 the name of the jpg is there but no picture.

      

    It sounds like GP is processing/applying correctly, but the user/computer doesn't have access to the JPG file, or, the JPF file is not in a correct format?

    Did you configure the GP to point to a local file on the computer C: drive, or, configure to a shared location on a server?

    There are quite a few guides on the web for how to do this, here are some for you to review:

    http://www.grouppolicy.biz/2011/03/best-practice-using-group-policy-to-configure-desktop-wallpaper-background/

    https://deployhappiness.com/setting-the-desktop-wallpaper-background-with-group-policy/


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Saturday, January 30, 2016 10:33 PM
  • Thanks but I'm still having issues.

    One thing I didn't do that you pointed out was share the folder that the image was in. Stupid of me not to think of that in the first place. I can now navigate to that shared folder on the Windows Server 2012 (DC01) using a Windows 7 Pro workstation (WS01). Now that I've changed that and it's shared I still can't get the GPO to work. I've tried deleting it and then recreating another one but still nothing. 

    I've tried creating a new registry key in the GPO, but that didn't work either.

    This is so simple and basic I'm thinking there's an issues with VMware itself. I mean all I'm trying to do here is change the domain users desktop wallpaper for crying out loud.....

    I have yet to move on to creating another GPO for folder redirection because I can't even get this to work.

    Help please

    Sunday, January 31, 2016 1:07 PM
  • I got it!!!

    I just used the UNC path to the server instead of using C:\Wallpaper\Win7.jpg because that would just point to a path on the local computer not to the server.

    Holy Moly!

    Thanks guys

     

    Sunday, January 31, 2016 1:34 PM
  • Good to see you are unblocked.
     
    And thank you for sharing your experience here. It will be very beneficial for other community members who have similar questions.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, February 3, 2016 2:17 AM
    Moderator