locked
Problem with sound with Creative SB X-FI. RRS feed

  • Question

  • I'm using the Windows 7 release candidate version now, and I love it! Except one thing, I can't get my speakers to work! :(  
    I have the drivers to my soundcard but it says that no speakers are plugged in. 

    Please help me :)  

    edit: Yes I tried to make all devices as default.. 

    update, when I have speakers as default I just get part of the sound really buzzing and scrapping ^^ 

    Thursday, July 16, 2009 8:51 PM

Answers

  • Thx for the help anyways :) Dont have a built in audio card -.- Have a Dell XPS 710 :P Well think I will have one go with reinstalling the OS, and if that doesnt worj I'll go back to XP :(
    • Proposed as answer by magiicmusic Friday, July 24, 2009 11:06 PM
    • Marked as answer by Robinson Zhang Monday, July 27, 2009 8:16 AM
    Saturday, July 18, 2009 12:17 PM

All replies

  • You should have the speakers for the xfi (top device in your pic) selected as default.   

    The "high definition audio device" appears to be a second sound device running on the computer which could possibly be conflicting with the Xfi. Try going into your bios to disable any sound devices that may be present.  If you can't turn it off that way, try going into the Device Manager in Windows and disabling the device from there. 

    Not saying you would do so, but just to eliminate the possibility, make sure you plugged the speakers into the xfi sound card itself and not the speaker plugs for the motherboard's built-in sound.  Also confirm your speakers are plugged into the correct ports on the Xfi.  It is a surround card and it might be easy to have plugged the speakers into one of the surround channels.

    If none of this works, you might want to try the soundcard and speakers on an XP/Vista machine to confirm the hardware is working.

    Good luck

    • Edited by Oracle99 Friday, July 17, 2009 7:09 PM
    Friday, July 17, 2009 7:05 PM
  • Thx for your suggestions, will try em' all! Desperate to get my Win 7 to work completely! :D
    I got the speakers as default, and then get the snap crackle and pop problem, hear the sounds a bit ^^ 
    The speakers are plugged in the x-fi card and right input's. Good idea with dissable the hidh deff ____! 

    Thx m8!

    edit, they worked perfect on my laptop with windows 7 build 7000, and XP.
    Friday, July 17, 2009 9:02 PM
  • And didn't find any sound things in bios to shut down, disabled the high deff in Device manager and, with no success :( 
    Friday, July 17, 2009 10:25 PM
  • Sorry it didn't work.  My Xfi works without a hitch but there is no telling with a pre-release OS and beta drivers.  Something is conflicting if the audio is spitting out junk.  The only other thing I could think of is to try uninstalling the Creative Drivers, maybe physically moving the sound card to another slot (PCI?) and reinstalling the drivers (all while your other sound device is disabled).  I am really out of ideas.  Maybe someone else will have something better to offer.  If you have no luck at all, maybe try removing the Xfi and switching over to the built in sound.  Its not as fancy as the Xfi but at least it would be something.  If THAT doesn't work, I'd almost consider reinstalling your OS.  But I am a reinstall junky.  Bad habits die hard.

    Good luck bud!
    Saturday, July 18, 2009 11:30 AM
  • Thx for the help anyways :) Dont have a built in audio card -.- Have a Dell XPS 710 :P Well think I will have one go with reinstalling the OS, and if that doesnt worj I'll go back to XP :(
    • Proposed as answer by magiicmusic Friday, July 24, 2009 11:06 PM
    • Marked as answer by Robinson Zhang Monday, July 27, 2009 8:16 AM
    Saturday, July 18, 2009 12:17 PM
  • Youll find on the creative website the drivers and audio centers you need for win 7 ...   they worked fine on mine when it didnt at first

    amd dual core 2.8  64
    4 gig memory
    2tb storage
    1033 FSB
    Friday, July 24, 2009 11:08 PM