locked
Mail.que file size is rapidly increasing RRS feed

  • Question

  • Hi Friends,

    I am experiencing an issue with Exchange 2013 mail.que file, it consumes available free disk space in 2-3 days, like grows up 30-40Gb in 2-3 days, any way we can manage it? How can I check why it is growing so fast?

    Thanks in Advance...


    Best Regards, Ranjit Singh

    Friday, December 19, 2014 6:21 AM

Answers

  • Friday, December 19, 2014 6:26 AM
  • Hi Ranjit,

    Thank you for your question. 

    Based on my research, the causes can be: 

    1.Pipeline tracking log is enabled and it takes some space;

    2.Large MaxDumpsterSizePerStorageGroup limitation. 

    To troubleshoot the issue, we can take the following steps. 

    1. Disable the Pipeline tracking log if you do not need it 

        a. Check if Pipeline Tracing enabled by command:

         Get-TransportServer | FL name,*pipeline* 

        b. If enabled, please use the following command to disable it 

        Set-TransportServer “Server Name” -PipelineTracingEnabled $False    

    2. Reset the MaxDumpsterSizePerStorageGroup limitation 

        a. Run “Get-TransportConfig” and ensure the following 

        MaxDumpsterSizePerStorageGroup is in MB’s and not GB’s     

        MaxDumpsterTime : 7.00:00:00 

        b. If not, we run the following command to modify: 

        Set-TransportConfig -MaxDumpsterSizePerStorageGroup <size> -MaxDumpsterTime    <timespan> 

    3. If it still does not work, we can manually reset the Mail.que and then monitor if it is still increasing: 

        a. Stop Transport service on the server. 

        b. Move the folder C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Queue to other place. 

        c. Start the Transport service on the server. 

        d. If there is no related issue, just delete the previous Queue folder. 

        e. Monitor the new Queue folder size. 

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard, 

    Jim

    Monday, December 22, 2014 2:07 PM

All replies

  • Friday, December 19, 2014 6:26 AM
  • Thanks Hotaka for your Prompt revert ,

    I will get back to you with an update on this...


    Best Regards, Ranjit Singh

    Friday, December 19, 2014 6:34 AM
  • Hi Ranjit,

    Thank you for your question. 

    Based on my research, the causes can be: 

    1.Pipeline tracking log is enabled and it takes some space;

    2.Large MaxDumpsterSizePerStorageGroup limitation. 

    To troubleshoot the issue, we can take the following steps. 

    1. Disable the Pipeline tracking log if you do not need it 

        a. Check if Pipeline Tracing enabled by command:

         Get-TransportServer | FL name,*pipeline* 

        b. If enabled, please use the following command to disable it 

        Set-TransportServer “Server Name” -PipelineTracingEnabled $False    

    2. Reset the MaxDumpsterSizePerStorageGroup limitation 

        a. Run “Get-TransportConfig” and ensure the following 

        MaxDumpsterSizePerStorageGroup is in MB’s and not GB’s     

        MaxDumpsterTime : 7.00:00:00 

        b. If not, we run the following command to modify: 

        Set-TransportConfig -MaxDumpsterSizePerStorageGroup <size> -MaxDumpsterTime    <timespan> 

    3. If it still does not work, we can manually reset the Mail.que and then monitor if it is still increasing: 

        a. Stop Transport service on the server. 

        b. Move the folder C:\Program Files\Microsoft\Exchange Server\V15\TransportRoles\data\Queue to other place. 

        c. Start the Transport service on the server. 

        d. If there is no related issue, just delete the previous Queue folder. 

        e. Monitor the new Queue folder size. 

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard, 

    Jim

    Monday, December 22, 2014 2:07 PM
  • Hi Jim-xu,

    I appreciate your response and support!

    Let me perform Suggested Steps and shall get back to you with an update.


    Best Regards, Ranjit Singh

    Tuesday, December 23, 2014 5:39 AM
  • Hi Hotaka and Jim,

    Thanks for your all support!

    We have ran suggested commands and found the Out Put was default except the Dumpster Size Per DB Size, which was increased from its Default Size to 300MB Per DB and there are 40 DBs created. We have reduced it back to its Default Size and seems now there is no issue. Still we have kept it under observation and shall update back in few days.


    Best Regards, Ranjit Singh

    Friday, December 26, 2014 6:45 AM
  • Hi Friends,

    Still same behaviour of mail.que file.

    Please see below snaps for the command output, as recommended by you.

    Pls suggest if something else can be checked...


    Best Regards, Ranjit Singh

    Friday, January 9, 2015 6:49 AM
  • Pls find third Image file...


    Best Regards, Ranjit Singh

    Friday, January 9, 2015 6:50 AM
  • The same problem!

    Exchange 2016. 

    MaxDumpsterSizePerDatabase                                  : 18 MB (18,874,368 bytes)
    MaxDumpsterTime                                             : 7.00:00:00

    PipelineTracingEnabled       : False

    Mail.que file was about 45Gb. I had to recreate it by resseting, now it is growing up again rapidly. Any help?

    Thursday, September 1, 2016 9:03 AM