locked
Sharepoint NO longer accepts the Screenshot Attachements RRS feed

  • Question

  • Hi! I was using Windows Live Writer and trying to Publish this Blog http://www.agileit.com/Blog/default.aspx  As you can see the Blog is Published but all you can see is a Small Cross over all the Pictures.

    I have published different posts in the past on the same SharePoint Blog using the same Windows Live Writer and they don't seem to have this issue. The only change I remember in the past couple of weeks is latest Roll up for SharePoint i.e June 2011 Update. We are using SharePoint 2010 SP1.

    Is this a bug in SharePoint? Or is it because of the addition of some new security policies? In that case I would appreciate if someone can post a workaround. The end result however is that the attachments simply refuse to upload, and instead give a 404 NOT FOUND ERROR.

    Thanks


    Favad Q
    Tuesday, September 27, 2011 6:23 AM

Answers

All replies

  • I checked the image links in the posts and they result in a 404.

    But the urls of the broken images are insteresting:

    http://www.agileit.com/blog/_attach/IM-an-Expert-Flow-Chart_thumb_7CD58FB6.jpg

    As you can see there is an _attach in the Url.

    Url parts which start with "_" are reserved by sharepoint.

    Can you post a link to a post where the images work, so that we can compare the not working Urls with the working ones?


    Microsoft CSS - This post is provided "AS IS" with no warrenties and confers no rights.
    Tuesday, September 27, 2011 7:03 AM
  • Thanks for your reply.

    May be you can see the image attached in this Post here http://www.agileit.com/Blog/Lists/Posts/Post.aspx?ID=882


    Favad Q
    Tuesday, September 27, 2011 7:13 AM
  • How you attach your images?

    The correct path is like: http://servername/blog/Lists/Posts/Attachments/2/picture.jpg

     

    Tuesday, September 27, 2011 7:16 AM
  • All I did was to Click "Insert" and then "Picture From Your Computer" and Select the Picture. Once I'd completed my Blog Post with Pictures I uploaded it, and this is what happened.

    Do I need to do something differently? Like How to embed it or something?

    Thanks!


    Favad Q
    • Edited by Agile-Favad Tuesday, September 27, 2011 7:28 AM
    Tuesday, September 27, 2011 7:24 AM
  • Open your Blog options in live writter -> Go to Pictures.

    What type is used: Blog service or FTP site?

    Tuesday, September 27, 2011 7:34 AM
  • It says Blog Service


    Favad Q
    Tuesday, September 27, 2011 7:37 AM
  • Create new blog post in live writter. Add title, and add image from your computer. Then open source view in live writter. Please provide here source text.

    (try publish this new post.. check image is here?)

    Tuesday, September 27, 2011 7:46 AM
  • Here's the source code

    <p><a href="$IM an Expert Flow Chart[4].jpg"><img style="background-image: none; border-bottom: 0px; border-left: 0px; padding-left: 0px; padding-right: 0px; display: inline; border-top: 0px; border-right: 0px; padding-top: 0px" title="IM an Expert Flow Chart" border="0" alt="IM an Expert Flow Chart" src="$IM an Expert Flow Chart_thumb[2].jpg" width="579" height="533" /></a></p>

    Thanks!


    Favad Q
    Tuesday, September 27, 2011 7:51 AM
  • After you publish this simple post it work fine?
    Tuesday, September 27, 2011 7:57 AM
  • I'm sorry I cannot really check that at the moment, as my current user is having some permission issues (Error Attached). Is there a way of Publishing a Post on SharePoint without using Live Writer or any other Blog Writing Software that you would recommend works well with SharePoint.

    Thanks


    Favad Q
    Tuesday, September 27, 2011 8:07 AM
  • You can write the directly using a browser rather than using an external client software.
    Microsoft CSS - This post is provided "AS IS" with no warrenties and confers no rights.
    Tuesday, September 27, 2011 8:11 AM
  • Live Writter is good soft for publishing to sharepoint 2010.

    How you create your blog account?

    Try this in live writter:

    1. Click "Add blog accoun..." -> Check SharePoint ->  Enter http://www.agileit.com/Blog -> Click Next.

    2. Try post.

    3. If you can't. Open Manage blog accounts -> Select your account -> Click Edit... -> Click "See blog capabilities" to see your capabilities. -> Or click Update Account information... -> Select Correct user. -> Click Ok. Try post.

     

    Tuesday, September 27, 2011 8:17 AM
  • Here are my Blog's Capabilities. I have taken the Snapshot of first few lines. Guess there aren't any problems with this. Although I can find Post Draft to Server, should there be a separate permission for Publish Blog?

    Thanks!

     


    Favad Q
    Tuesday, September 27, 2011 9:58 AM