none
MIM 2016 setup failing during installation RRS feed

  • Question

  • Using SQL 2014 SP3 for the installation and getting the error shown above. SQL is installed on another server. Errors showing no hints. Can anyone please advise, how to fix this issue? 

    Action ended 19:45:39: CheckDotNetVersion. Return value 1.

    Info 2898. For WixUI_Font_Normal__UL <g class="gr_ gr_67 gr-alert gr_spell gr_inline_cards gr_disable_anim_appear ContextualSpelling ins-del multiReplace" data-gr-id="67" id="67">textstyle</g>, the system created a 'Tahoma' font, in 0 character set, of 13 pixels height.
    Action 19:45:39: SqlCredDlg. Dialog created
    MSI (c) (88:84) [19:45:39:491]: PROPERTY CHANGE: Deleting MsiSelectionTreeSelectedFeature property. Its current value is 'ResetPortal'.
    MSI (c) (88:84) [19:45:39:491]: PROPERTY CHANGE: Deleting MsiSelectionTreeSelectedAction property. Its current value is '2'.
    MSI (c) (88:84) [19:45:39:491]: PROPERTY CHANGE: Deleting MsiSelectionTreeSelectedCost property. Its current value is '0'.
    MSI (c) (88:84) [19:45:45:180]: PROPERTY CHANGE: Modifying SQLSERVER_SERVER property. Its current value is 'DGAMIM01'. Its new value: 'dbMIM'.
    MSI (c) (88:84) [19:45:45:242]: Doing action: CheckDatabaseNameFormat
    Action 19:45:45: CheckDatabaseNameFormat. 
    Action start 19:45:45: CheckDatabaseNameFormat.
    MSI (c) (88:90) [19:45:45:242]: Invoking remote custom action. DLL: C:\Users\SA_PSH~1\AppData\Local\Temp\MSI8E65.tmp, Entrypoint: CheckDatabaseNameFormat
    MSI (c) (88!44) [19:45:45:258]: PROPERTY CHANGE: Adding IS_VALID_DATABASE_NAME property. Its value is '1'.
    Action ended 19:45:45: CheckDatabaseNameFormat. Return value 1.
    MSI (c) (88:84) [19:45:45:258]: Doing action: CheckSQLConnectionAndVersion
    Action 19:45:45: CheckSQLConnectionAndVersion. 
    Action start 19:45:45: CheckSQLConnectionAndVersion.
    MSI (c) (88:64) [19:45:45:258]: Invoking remote custom action. DLL: C:\Users\SA_PSH~1\AppData\Local\Temp\MSI8E75.tmp, Entrypoint: CheckSQLConnectionAndVersion
    MSI (c) (



    • Edited by rndmaster Friday, January 4, 2019 1:35 AM
    Friday, January 4, 2019 12:54 AM

Answers

  • With "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." enabled, I started getting the error below when creating the new PAM Group.

    To fix this, I had to disable "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." 

    But it broke my SQL connectivity and I again started receiving SChannel errors

    I had to enable TLS 1.0 and SSL 3 using IISCrypto tool on both MIM 2016 SP1 and SQL 2014 SP3 server (Win 2016) to fix this. 

    After rebooting the SQL and MIM server, everything started working.  


    • Edited by rndmaster Monday, January 7, 2019 8:27 PM
    • Marked as answer by rndmaster Friday, February 1, 2019 6:09 AM
    Monday, January 7, 2019 8:26 PM

All replies

  • Resolved

    Tried testing SQL connectivity using UDL file and got the error. 

    https://dougrathbone.com/blog/2013/11/18/testing-connectivity-to-microsoft-sql-server-without-any-tools-installed 

    Checked the event logs and found SCHANNEL errors. Event ID 36871 (the internal error state is 10013)

    Applied the steps mentioned below on both MIM server and SQL Server and rebooted the machines which resolved the issue. 

    1.        Open the Control Panel
    2.        Click on Administrative Tools
    3.        Open the Local Security Policy
    4.        Open the Local Policies tree view to see the options there
    5.        Select Security Options
    6. Within the Security Options, you should see the following policy: System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing.
    7.        Open the Properties of this policy by right clicking on it and selecting Properties.
    8.        Choose Enable to activate the policy
    9.        Click Apply and then OK to close out the window
    10.    Close the Local Security Settings window
    11.    Restart Server 
    Friday, January 4, 2019 2:10 AM
  • With "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." enabled, I started getting the error below when creating the new PAM Group.

    To fix this, I had to disable "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." 

    But it broke my SQL connectivity and I again started receiving SChannel errors

    I had to enable TLS 1.0 and SSL 3 using IISCrypto tool on both MIM 2016 SP1 and SQL 2014 SP3 server (Win 2016) to fix this. 

    After rebooting the SQL and MIM server, everything started working.  


    • Edited by rndmaster Monday, January 7, 2019 8:27 PM
    • Marked as answer by rndmaster Friday, February 1, 2019 6:09 AM
    Monday, January 7, 2019 8:26 PM