No Audio Output Device is Installed... RRS feed

  • Question

  • I just bought a new vista home premium acer computer, the audio was working fine until i came home and see that the sound wasnt working, so i looked at the bottum right of my computer screen and it says `no audio output device is installed`` is there anyway to fix this
    Monday, June 4, 2007 9:57 PM

All replies

  • Someone please help.
    Monday, June 4, 2007 10:43 PM
  • Anyone, please!
    Tuesday, June 5, 2007 1:21 AM
  • I have the same exact problem, also with an Acer computer.  It can be resolved with a reboot, but who wants to reboot all the time.  It seems to be okay for a couple of days and then the drivers just magically disappear!  I tried downloading the audio codec drivers for Windows Vista from the Realtek site, but no difference.  I am hoping that may with more people experiencing the same problem, Microsoft or Realtek will address it.
    Wednesday, June 6, 2007 3:26 PM
  • I am also having the same problem. I also have a new Acer.
    Wednesday, June 6, 2007 11:34 PM
  • my new acer does the same thing i cant fix it
    Saturday, June 9, 2007 2:17 AM
  • I sent an email to Acer via their online support system for registered users. This is the response I received:


    Thank you for contacting Acer America. It may help to refresh the sound driver. To do this click on Start > right click on My Computer > click on Manage. In the window that

    comes up click on Device Manager and locate the Sound, Video and Game Controllers heading. Click on the + next to the heading and then right-click on the device and go

    to Uninstall.  After uninstalling, reboot and Windows should detect the sound card and reinstall.  If this does not resolve the issue or you need further assistance with this

    please contact Acer Technical Support at 1-800-816-2237 M-F 7am-9pm CST and Sat-Sun 8am-5pm CST excluding holidays.


    I have not tried it yet but intend to do so when it happens again. It will happen again unfortunately.


    If it replaces the sound driver with the same driver, it won't fix it. If it replaces it with a new driver, it just might work.



    Sunday, June 10, 2007 12:50 PM
  • Ok. I did it. That didn't fix it.


    I ended up uninstalling the Realtek audio driver alltogether.

    Realtek has a driver dated May 2007 that I installed.


    It works fine now.


    Bad advice from Acer. They should have figured this out themselves and made the driver available.

    Saturday, June 16, 2007 3:29 PM
  • Well, it's over six months after this thread was started and my new Acer t690 is doing the same thing. Aftre receiving the same message Scott did, I contacted Acer and was told to reinstall windows from their recovery program. This isn't going to happen,   because when this happens again I will be out of service and  because reinstalling everything would take forever.

    Support claims this is the first incident ever. Obviously not. It is the second Acer T690 with the problem, by the way. Take it in, said the tech support person, who didn't know what I was talking abut when I said audio services were running, there was no report of an issue in the event log and that perhaps we should uninstall recent updates before doing something drastic.

    I have followed through with the suggested fixes here and find nothing. I have put in an updated driver, and nothing. The sound "meter" on the interface shows sound being received and the Realtek interface recognizes the speakers when plugged in. Incorrectly setting environment to surround sound gets a positive response from the two rear side speakers, but there is no audio.

    I wonder if anyone else  had this issue. I suspect that the thousand plus people who viewed this did. May make another post. In the meantime I am venting my fury on Acer review sites. Feels good.

    Note that when I suggested that two supposedly defective boards in a row were if not a sign of a software conflict one of a buggy product, they of course adamently denied it. Bad, bad choice, this one.
    Thursday, January 31, 2008 11:43 PM
  • this is the first and last time i will buy ACER again. this is bullSH*t Angry. i am very disappointed with this company. i have the same problem Sad did anyone had the same problem and got it fixed ? this is stupid. and i wondered why they sold these pc's for less.
    • Proposed as answer by kenchiu Tuesday, July 5, 2011 10:50 PM
    • Unproposed as answer by kenchiu Tuesday, July 5, 2011 10:51 PM
    Thursday, May 1, 2008 2:52 AM
  • Support claims this is the first incident ever
    I would say Acer was lying outright, if I had not come to the conclusion that they are hiring from the bottom of the smart tree. I don't think the support techs have much information.

    If you do a search on Vista/realtek/no sound, you will see that the majority of problems seem to be acer, but there are others involved, and Realtek seems to be the culprit. Almost all of them are Vista related, some after an automatic update. There was a class action suit against Nvdia and another company for claiming their video cards were Vista ready, when they weren't, and this is possibly the same thing..a Vista conflict of some sort.

    Some peole have managed to fix it by upgrading the drive, but make sure you have the old one in place, since some of the upgrades don't work.

    Dell (same problem) offers the same wingnut solution, which worked for me until I rebooted: Unplug everything. Unplug compter. Turn computer off. Wait. Reconnect. Turn on. Go figure.

    Acer told me it was a hardware problem and offered to fix it, but I couldn't go without, so I bought a new, non Realtek sound card, pluged it in and everything is fine. I think the oem card cost $20. It won't work with a laptop, and they seem to be having a lot of problems with sound.

    I will agree, however, that this is the last Acer I buy. My office desktop blew a board and I picked up a cheap board, PSU and some memory plus XP instead of Vista, plugged it in and was running in about a day without the annoyances of Vista or of Acer.

    Thursday, May 1, 2008 4:46 AM
  • i got it fixed.. maybe it will help someone else with the same problem.... here it goes...  start, control panel, device manager. click the + next to sound, video, and game controllers, then uninstall Realtek High Definition Audio. ( the operator on the phone told me to uninstall High Definition Audio Device that didnt work Big Smile.) ones its uninstalled restart, thne once you have restarted it will ask you to install the driver install and play a song...   that it might work. the operators on the phone dont know anything. they just repeat the same thing everytime.

    i hope i was helpfull.
    Thursday, May 1, 2008 3:57 PM
  • This assumes just the driver is wrong. That pulls a driver from internet update. You can also go to realtek and download a driver. Unfortunately it doesn't always work.
    Friday, May 2, 2008 5:33 AM
  • I am also having this problem with my Toshiba. I have had it for two years now and the "No Audio Output Device is Installed" problem just started a week and a half ago. I have rebooted twice today to fix it with no luck! I feel your pain, but at least you know it is not just Acer.
    Thursday, December 24, 2009 3:06 PM
  • me too. I'm out of ideas

    Tuesday, August 8, 2017 11:42 AM