locked
Application launches & shutdown immediately in app-v 4.6 RRS feed

  • Question

  • Hi All,

    I have sequenced an application successfully, when the application is deployed to client machine then the Application launches & shutdown immediately. i tried all possible things can you help on this.

    i have tried this link http://social.technet.microsoft.com/Forums/en-US/appvclients/thread/4035f789-4557-41a5-a5d3-205bed16f5c6 but it did not work.

    Thanks in advance.

     

    Ragards

    Raghu

    Thursday, April 14, 2011 7:07 AM

Answers

  • Hi,

     

    I got the application to work

    When i launch the application in the client it was looking in C:\Program Files\.......\ & it was not able to find the related files of the application, so it was launching & shutdown.

    Resolution:

    While sequencing i have changed the location of the shortcut i.e OSD from C:\Program Files\.......\ to Q:\.......\ then the application works fine.

     

    Regards

    Raghu


    Raghavendra Rao V
    • Proposed as answer by znack Monday, April 18, 2011 12:54 PM
    • Marked as answer by VRaghu Wednesday, April 27, 2011 8:11 AM
    Monday, April 18, 2011 12:54 PM

All replies

  • Hello,

    What does the program do while it starts? Does it start at all? What registry keys does it access? What files does it access? 
    /Znack
    Thursday, April 14, 2011 7:54 AM
  • Hi

     

    The shortcut it will open with batch file(C:\Program File\....\xyz.bat) & it uses HKLM registry.

    Thanks in advance.

     

    Ragards

    Raghu


    Raghavendra Rao V
    Thursday, April 14, 2011 10:47 AM
  • Hello,

    That doesn't really explain what the program does, what happens, what registry keys it access or what files it uses.

    Can you be a lot more detailed? What does the bat-file do? What happens when that executes? 
    /Znack
    Thursday, April 14, 2011 11:24 AM
  • Does your OSD have the TERMINATECHILDREN parameter set to TRUE.  If it does you may want to turn it off.  If your batch file launches an application then closes once it has launched, then the App-V client will take that as a signal to kill off any child process launched by your batch file.

    Otherwise it looks like an application issue and you will need to run monitoring tools such as procmon from Sysinternals to determine why your application is shutting down prematurely.


    Blog: http://Softwaredeployment.wordpress.com
    Monday, April 18, 2011 11:49 AM
  • Hi,

     

    I got the application to work

    When i launch the application in the client it was looking in C:\Program Files\.......\ & it was not able to find the related files of the application, so it was launching & shutdown.

    Resolution:

    While sequencing i have changed the location of the shortcut i.e OSD from C:\Program Files\.......\ to Q:\.......\ then the application works fine.

     

    Regards

    Raghu


    Raghavendra Rao V
    • Proposed as answer by znack Monday, April 18, 2011 12:54 PM
    • Marked as answer by VRaghu Wednesday, April 27, 2011 8:11 AM
    Monday, April 18, 2011 12:54 PM
  • Hi All,

    I have sequenced an application successfully, when the application is deployed to client machine then the Application launches & shutdown immediately. i tried all possible things can you help on this.

    i have tried this link http://social.technet.microsoft.com/Forums/en-US/appvclients/thread/4035f789-4557-41a5-a5d3-205bed16f5c6 but it did not work.

    Thanks in advance.

    Ragards

    Raghu


    Hi my guy, i have this problem too, but i find a solotion for this problem, i sequenced a application, i install app-v sequencer in virtual machine from Hyper-V but when i want to launch application from local client it goes force to shutdown, when i install app-v sequencer in a local client and sequnced again the application it runs very well.
    Friday, March 16, 2012 4:24 PM