locked
Changing the default option on context menue for drives and folders from explore to open. RRS feed

  • Question

  • The explore option on the right context menu no longer works, but open does.  Can I change the default option from explore to open?  I really do not want to reinstall Win 7.
    Thursday, March 10, 2011 7:27 PM

Answers

  • I'm posting the REG here, Bill.

     

    Windows Registry Editor Version 5.00
    
    [-HKEY_CLASSES_ROOT\Folder\shell\open]
    
    [-HKEY_CLASSES_ROOT\Folder\shell\explore]
    
    [HKEY_CLASSES_ROOT\Folder\shell\explore]
    "MultiSelectModel"="Document"
    "ProgrammaticAccessOnly"=""
    "LaunchExplorerFlags"=dword:00000018
    
    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    
    [HKEY_CLASSES_ROOT\Folder\shell\open]
    "MultiSelectModel"="Document"
    
    [HKEY_CLASSES_ROOT\Folder\shell\open\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
     00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
     65,00,00,00
    

     

    That'll restore the default settings for "explore" and "open"

     

     

     


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Arthur Xie Wednesday, April 20, 2011 6:45 AM
    Sunday, April 10, 2011 4:50 AM
    Answerer
  • I just merged the Explore command.  The open command was OK as is (on the menu and it worked).  After the merge, the Open command was still on the list, but not the Explore command.
    WCK
    I'd say that absolutely normal. "Explore" doesn't show up although the "explore" verb exists under the "Folder\shell" registry key.
    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by WCKeyser Monday, April 25, 2011 8:51 PM
    Monday, April 25, 2011 3:23 PM
    Answerer
  • I just merged the Explore command.  The open command was OK as is (on the menu and it worked).  After the merge, the Open command was still on the list, but not the Explore command.
    WCK

    That's normal and by design. The "explore" verb is only intended to be invoked programmatically (there is a "ProgrammaticAccessOnly" string value under the subkey).

    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    • Marked as answer by WCKeyser Monday, April 25, 2011 8:49 PM
    Monday, April 25, 2011 3:31 PM
    Answerer

All replies

  • I don't know what you've installed or done - possibly something designed for an older version of Windows - but my right-click context menu doesn't have an Explore in it.  Open IS the default.

    You should try to get to the bottom of what was changed to add an Explore option to that menu and undo that.

    You can list all your shell extensions via the freeware tool ShellExView:  http://www.nirsoft.net/utils/shexview.html

    -Noel

    Friday, March 11, 2011 5:23 AM
  • If ShellExView does not work, you may try to restore the system.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, March 14, 2011 8:17 AM
  • Thank you for your response.  A friend of mine has seen the Explore option on a Win 7 context menu, so I am not the only one.  I tried Shellexview, but it does not show any context menu items under the type column. It also does not show Explore as a menu name.  I "think" I saw the explore option on the context menu when I first got the Gateway computer, but I am not sure now.  I did remove any programs that affect disk drives but no change.  I can reinstall Win 7 but would rather not.  Can you tell me how to change the default option?  I did find what I was looking for, but it does not work in Win 7 -

    http://www.annoyances.org/exec/show/article02-026


    WCK
    Monday, March 14, 2011 3:13 PM
  • I can restore the system, but the problem was triggered by a Windows update, so I will have to screen all future updates.  Microsoft suggested that I reinstall Win 7, but I would rather not.  Can you tell me how to change the default option?

    WCK
    Monday, March 14, 2011 3:16 PM
  • I have examined the registry to see if I can find the source of my problem.  I found the following key under folder:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Folder\shell\explore]

    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    @="%SystemRoot%\\Explorer.exe"

    This is the command that fails if I click on a drive or folder icon.

     

    The adjacent command is Open:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Folder\shell\open]
    "MultiSelectModel"="Document"

    [HKEY_CLASSES_ROOT\Folder\shell\open\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
      65,00,00,00

    Since open works but explore dosen't I tried to replace the explore keys with an edited copy of the open command.  This failed.

    I the exported the Explore keys and then deleted the Explore key set.

     

    The Open command became the default.

     

    This solved my problem, since when I click on a drive or folder icon, I get the desired results.  The old (bad) Explore command is still in the list as ExploreA.

     

    Does anyone know what the explore key set should look like?

     

    Is there any reason I should try to fix it?

     

    Bill


    WCK
    Saturday, April 9, 2011 8:34 PM
  • I'm posting the REG here, Bill.

     

    Windows Registry Editor Version 5.00
    
    [-HKEY_CLASSES_ROOT\Folder\shell\open]
    
    [-HKEY_CLASSES_ROOT\Folder\shell\explore]
    
    [HKEY_CLASSES_ROOT\Folder\shell\explore]
    "MultiSelectModel"="Document"
    "ProgrammaticAccessOnly"=""
    "LaunchExplorerFlags"=dword:00000018
    
    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    
    [HKEY_CLASSES_ROOT\Folder\shell\open]
    "MultiSelectModel"="Document"
    
    [HKEY_CLASSES_ROOT\Folder\shell\open\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
     00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
     65,00,00,00
    

     

    That'll restore the default settings for "explore" and "open"

     

     

     


    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by Arthur Xie Wednesday, April 20, 2011 6:45 AM
    Sunday, April 10, 2011 4:50 AM
    Answerer
  • the problem was triggered by a Windows update

    I suspect not.

    My systems are all up to date with Windows Update and the default is still Open.

    -Noel

    Sunday, April 10, 2011 8:03 PM
  • I Merged your Explore command and it showed up in the list as shown below:

     

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Folder\shell]

    [HKEY_CLASSES_ROOT\Folder\shell\explore]
    "MultiSelectModel"="Document"
    "ProgrammaticAccessOnly"=""
    "LaunchExplorerFlags"=dword:00000018

    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

    [HKEY_CLASSES_ROOT\Folder\shell\open]
    "MultiSelectModel"="Document"

    [HKEY_CLASSES_ROOT\Folder\shell\open\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\
      65,00,00,00

     

    It did not show up in the right context menu.  What did I  do wrong?

     

    Bill


    WCK
    Sunday, April 24, 2011 10:12 PM
  • I Merged your Explore command and it showed up in the list as shown below:

    It did not show up in the right context menu.  What did I  do wrong?

    Bill


    WCK
    After merging the REG file, you're supposed to see the "Open" command in the context menu for folders. What do you get?
    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    Monday, April 25, 2011 6:04 AM
    Answerer
  • I just merged the Explore command.  The open command was OK as is (on the menu and it worked).  After the merge, the Open command was still on the list, but not the Explore command.
    WCK
    Monday, April 25, 2011 2:37 PM
  • I just merged the Explore command.  The open command was OK as is (on the menu and it worked).  After the merge, the Open command was still on the list, but not the Explore command.
    WCK
    I'd say that absolutely normal. "Explore" doesn't show up although the "explore" verb exists under the "Folder\shell" registry key.
    Ramesh Srinivasan | The Winhelponline Blog
    Microsoft MVP, Windows Desktop Experience
    • Marked as answer by WCKeyser Monday, April 25, 2011 8:51 PM
    Monday, April 25, 2011 3:23 PM
    Answerer
  • I just merged the Explore command.  The open command was OK as is (on the menu and it worked).  After the merge, the Open command was still on the list, but not the Explore command.
    WCK

    That's normal and by design. The "explore" verb is only intended to be invoked programmatically (there is a "ProgrammaticAccessOnly" string value under the subkey).

    Microsoft MVP Windows Expert Consumer | http://www.wintecnico.com

    • Marked as answer by WCKeyser Monday, April 25, 2011 8:49 PM
    Monday, April 25, 2011 3:31 PM
    Answerer
  • Thank everyone for your help.  My original question was "How do I changer the default option on the context menu?".  The answer is to delete , move or add a program only key to the option.

     

    As a bonus, I got to correct the Explore option to the way it was designed to work.

     

    The fact that the command showed up on my menu was probably the root cause of my problem that became noticeable after the Windows Update.

     

    Thanks again.

     

    Bill 


    WCK
    Monday, April 25, 2011 8:59 PM
  • Windows Update simply does not break systems in this way.

    You should try to figure out the ACTUAL root cause - i.e., what you did that caused the change in the first place.  Most likely you installed something that changed that registry entry - a shell extension of some sort.  Also, registry "cleaners" can change things you don't want changed.  You may not even know what you did to cause the problem...  Just visiting web sites can cause the installation of software.  At the very least, read up on Internet security and consider how your computing and browsing habits could lead to such a change.

    -Noel

    Tuesday, April 26, 2011 12:19 AM
  • You are correct that either I did something to change the Explore registry entry or is came from Gateway that way.  Since I did not notice the problem until it bit me, I will probably never know which it was.

     

    However, the thing that brought the issue to my attention was a specific Windows update.  After I installed the update, the problem surfaced.  When I removed the update, the problem went away.  However, I don't know if the Explore command was in the context menu before the update was installed, but I suspect it was.  As I said before, you don't look at the details until something brings it to your attention.

     

    You were right when you said that the default command should be Open.  Since I never particularly noticed the Explore command on the menu until it became an issue, I don't know if it was there when I got the computer, or it appeared later.

     

    Anyway, thanks for your help.

     

    Bill


    WCK
    Tuesday, April 26, 2011 7:10 PM
  • It just occurred to me:  How do I know the Explore command works?  Since it doesnot appear on the list, I can't test it.

     

    Any ideas?

     

    Bill


    WCK
    Sunday, May 1, 2011 7:58 PM
  • I honestly don't know what the "Explore" key is for.  Maybe compatibility with older applications or something.

    If Explorer seems to do all the things Explorer is supposed to do, you're probably good.

    -Noel

    Monday, May 2, 2011 3:28 PM