none
Windows 7 / IE8 - Disable Do you want to open or save this file. RRS feed

  • Question

  • We have a web application that has thousands of links to TIF files and PDF files.   When a user clicks on the link to open the file they are presented with the File Download dialog box " Do you want to open or save this file?"   the selections are to open save and cancel.

    We are looking for a way to disable this prompt every time the user clicks on the link to the file.   The web application is a hosted solution, we do have the site set as a trusted site. We have tried the Setting the HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}

    Wednesday, January 9, 2013 4:15 PM

All replies

  • Do you want to open or save this file?"   the selections are to open save and cancel.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute\{0002DF01-0000-0000-C000-000000000046}


    Unless you get someone who has already been through this (e.g. to understand the symptom) I suspect you will need to use ProcMon to trace this to find out what is going on, possibly supplemented by the hints in this document:

    http://msdn.microsoft.com/en-us/library/bb250462(VS.85).aspx 

    and then somehow related to this one

    http://blogs.msdn.com/b/ieinternals/archive/2009/12/01/understanding-internet-explorer-security-protected-mode-elevation-dialog.aspx

    (MSDN search for
        browserflags open save
    )

    Note in particular the discussion in the comments.

    Also, where did you get that AttachmentExecute key to experiment with?  FWIW in my registry it indicates it has something to do with shdocvw which I doubt would be a promising tack to try.

     
    I imagine that you may find that this is all WAD and there is no designed workaround but perhaps you can find a registry hack this way.

     
    Good luck

     
    Robert Aldwinckle
    ---

    Wednesday, January 9, 2013 7:15 PM
    Answerer
  • Hi,

    What programs do you have associated with tif and pdf file extensions?

    for PDF documents commonly users will have Adobe Reader (X) installed which is an ActiveX control AND a broker process BHO - Adobe PDF link helper BHO....

    both of these Addons need to be enabled to open pdf documents directly in the Adobe PDF Active X control (tools>Manage Addons>Show All Addons).... ActiveX filtering will disable the ActiveX part, but leave the link helper part enabled.... Running in noaddons mode will disable both.

    if either one or both are disabled then typically you will see the file open/save dialog as there is no longer an opener for the pdf file extension... (see you HKCR\.pdf hive)

    I would recommend that you configure Adobe Reader to not use a web browser to open PDF documents and to use the Native Support of the Adobe Reader instead...(web search for PDF exploits/virus)...

    Start>Adobe Reader>Edit>Preferences>Internet>uncheck "use web browser to open PDF".

    (you can also download adm files from the Adobe site so that you can configure this globally with GPO).

    the default .tif opener on my win7 system is PhotoGallery, but I imagine on yours you will find that you are using a third-party Addon ActiveX control.


    Rob^_^


    Thursday, January 10, 2013 1:45 AM
  • We currently have PDF's openning in Reader, I did check and the BHO is the only Adobe Add/On in the browers and it is enabled.   For .TIF's we are using Microsoft Office Document Imaging (MSPVIEW.EXE).    Both .PDF and .TIF are configured to open in the application I just mentioned.
    Thursday, January 10, 2013 3:27 PM
  • Hi Turn360! Did you ever find a solution for this? I now have this issue with IE11, and using MSPVIEW.exe to view tiff files. The site in question is in the trusted sites.  The prompt is a nuisance.  Can you offer any advice?

    Thursday, July 2, 2015 12:29 PM