none
AEM not working for Clients Vista and newer

    Question

  • Hi 

    With SCE 2010 RC I am seeing the same problem as described here for SCE 2007: http://social.technet.microsoft.com/Forums/en-US/systemcenter/thread/fbd87777-2236-4894-8843-d02b3a029aee 

     

    Clients connecting are reporting over information and data correctly, and getting updates, but AEM is not functioning correctly.  Some Windows XP based machines which are part of our test setup have reported correctly.  

     

    The Health of the Crash Listener view appears ok. Even trying to send reports from the SCE server (SCE1) using Action Center|Problem Reports results in a dialog "Problem connecting to the Windows Error Reporting Service.  Some of the reports could not be uploaded to the Windows Error Reporting Service.  Please try again later.

    Group Policy has been checked and is applying correctly, and firewalls have been disabled.  Any ideas???

    Thanks

    Janson

    Thursday, April 15, 2010 5:32 PM

Answers

  • FYI.  Microsoft closed my support case and said that it was a bug that would be fixed in a future service pack.  I don't know of any workaround.  :(
    Wednesday, April 20, 2011 12:44 PM
  • Thanks for posting that information, Jeff.

    I am also having the problem of no clients able to report errors to SCE 2010. I disabled error collection as a workaround:

      * Administration > select the top-node "Administration" item on the left-hand pane
         * in the Administration Overview pane, under Configuration, click the "Enabled" link beside "Agentless Exception Monitoring" -- this will start the Product Configuration Wizard
            * under Error Monitoring, select "No, do not collect application errors" and complete the wizard. All the Error Reporting-related group policy settings in the policy "SCE Managed Computers Group Policy (hostname_MG)" will be removed.

    After a group policy update, clients will report errors (successfully now) directly to Microsoft.

    Regards,

    Tim Miller Dyck

     


    Tim Miller Dyck PeaceWorks Computer Consulting Waterloo, ON, Canada
    Saturday, May 07, 2011 8:59 PM

All replies

  • did you check the registry on a client pc that's having problems reporting?

    This was posted by Eric Zhang, NOT me:

    HKLM\Software\Policies\Microsoft\PCHealth\ErrorReporting\DW\DWReporteeName: It should be \\<SCEServerFQDN>\<Share>

    HKLM\Software\Policies\Microsoft\PCHealth\ErrorReporting\DW\DWReporteeName: Replace instances of the word “Microsoft” with:<Management Group Name>

     

    Also I'd make sure that the firewall on both client and server is open for port 51906.  post back with your findings.

     

    Tom


    It's a...jump...to conclusions...mat.
    Tuesday, April 20, 2010 1:37 PM
  • Hi Tom

    Thanks for coming back to me.  I beleive these settings are for Windows XP/2003 clients and newer.  The settings for Vista and above are held here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Error Reporting

    The settings in there: CorporateWERPortNumber are set correctly for mysetup.  I've actually setup AEM again with a custom port number of 60000, but this also does not work. 

    On the server SCE1 using nbtstat -a from a command prompt I can see that there is a port (60000) listeneing correclty.  Likewise I have turned off the firewalls on both client (Windows 7 Enterprise x64) and Server.

    Further, even attempting reporting from the Server fails with the same issue.  I'm using the AEMTestApplication.exe to force an error report to be generated.

    I'm wondering if there is a log file somwhere on SCE 2010 that monitors the AEM service, or one that can be turned on to enable logging. 

    Cheers

    Janson

    Tuesday, April 20, 2010 1:47 PM
  • if you can view/edit your group policies, you should be able to see the gp that SCE created for your domain.  Look at the details in the GP and see if your custom ports are included or not, it SHOULD add a firewall exception for them.  Also, FWIW even if the firewall is "off", it may not really be off until a reboot (maybe you've already done that).  As far as a log file goes, i can't really help you out there since I don't have error reporting turned on for my clients to go to my management server.
    It's a...jump...to conclusions...mat.
    Tuesday, April 20, 2010 1:54 PM
  • Hi Tom

    I've checked that out with the Group Policy Management Console, and also by running a Gpresult /h gpresult200410.txt

    All seems good and the ports are shown correclty.  The firewall rule is set to allow any communication form the IP address of SCE1, whcih again is set correctly :o(

    It just seems for some reason that communciation is not happening correclty.  Using Fiddler I can even see that communication does happen, but as its encrypted you don't really get to see much that is going on.

    Perhaps its an issue that is fixed in RTM... looking forward to getting that and trying as apparenlty upgrade from RC to RTM is supported.

    Cheers

    Janson

    Tuesday, April 20, 2010 3:02 PM
  • I'm sorry to report that after the upgrade to RTM (which went smooth, with no errors reported), the Issue with AEM still not working is present.  I will try to reconfigure AEM again, first by removing, and then reconfiguring to see if this resolves the issue.

    I will post back with my results!  In the mean time if anyone from MS can chirp in with some ideas that would be much appreciated.

     

    Cheers

     

    Janson

    Thursday, April 22, 2010 4:10 PM
  • Janson

    You can decrypt the message; I saw this message in one of my messages:

    To view the encrypted sessions inside this tunnel, ensure that the Tools | Fiddler Options | Decrypt HTTPS traffic option is checked.

    You probably have to restart Fiddler.  I didn't see much that would help, maybe you will. 

    I have similar issue from client side.  See http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/7dd569d0-e4fa-4ae1-ba7b-99ecfdfd3ee1/?prof=required

    No solution yet . . .

    Saturday, April 24, 2010 6:45 AM
  • Hi Janson,

    On the Essentials server, are you seeing anything logged in the event log (particularly the System/Application/Operations Manager logs)?

    As you've seen the XP clients use a different method for uploading crash data (they directly copy to the file share), while Vista and above use the HTTPS connection, so it is possible for XP clients to be able to return data but Vista and later to fail.

    Thanks

    Richard


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, April 29, 2010 6:58 PM
  • One more thing, hopefully you can confirm this from the fiddler logs:

    If you use proxy for accessing internet in your corporate environment make sure proxy resolution is turned off for local addresses. You can access this setting from Control panel -> Internet options -> connections -> LAN settings and then check the checkbox to “Bypass proxy server for local addresses”.

    Based on your posting it looks like you've already covered the process described in this blog, so I'm providing more as a reference for others who may not have seen it. 

    Thanks

    Richard 


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, April 30, 2010 9:03 PM
  • Hi Richard

    Thanks for coming back to me.  There are no errors reported in eihter the applications log or the Operations Manager log unfortunatley.

    Using fiddler I can see a connection is made, but no data recieved back.  Also even if I use the AEMTestApplication to generate an error on the SCE1 Server, the same error is received when checking for solutions to problems, so in essence SCE1 cannot communicate to the service running on itself.

     

    I've also checked the proxy settings and these are not set.

    Thank you for the reference to the blog post I have tried this but unfortunately this also drew a blank! :(

    Is there a way to run the AEM service in a diagnostic mode to assist with troubleshooting?

    Cheers

    Janson

    Thursday, May 06, 2010 1:09 PM
  • I am having the same issue.  Fiddler detects traffic going to the SCE server using the HTTP Protocl with result 200.  However, the body column says "0".  I ran "netstat -a" on the server and it is listening on port 51906.  I tried disabling the firewall on the client PC but that didn't help.  I'm running SCE 2007 SP1.

    Did you ever get this resolved?  If so, what did you do to resolve it?

    Monday, October 04, 2010 4:38 PM
  • I upgraded to SCE 2010 but it still isn't working.  The "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Error Reporting" key seems to be empty.  I'm running Windows 7 Pro x64.
    Thursday, December 30, 2010 4:39 AM
  • I opened a tech support case with Microsoft and they confirmed that it is a bug in SCE.  They said AEM only works with http but SCE tries to configure AEM with https by default.  They haven't given me a solution yet.
    Thursday, February 24, 2011 6:31 PM
  • FYI.  Microsoft closed my support case and said that it was a bug that would be fixed in a future service pack.  I don't know of any workaround.  :(
    Wednesday, April 20, 2011 12:44 PM
  • Thanks for posting that information, Jeff.

    I am also having the problem of no clients able to report errors to SCE 2010. I disabled error collection as a workaround:

      * Administration > select the top-node "Administration" item on the left-hand pane
         * in the Administration Overview pane, under Configuration, click the "Enabled" link beside "Agentless Exception Monitoring" -- this will start the Product Configuration Wizard
            * under Error Monitoring, select "No, do not collect application errors" and complete the wizard. All the Error Reporting-related group policy settings in the policy "SCE Managed Computers Group Policy (hostname_MG)" will be removed.

    After a group policy update, clients will report errors (successfully now) directly to Microsoft.

    Regards,

    Tim Miller Dyck

     


    Tim Miller Dyck PeaceWorks Computer Consulting Waterloo, ON, Canada
    Saturday, May 07, 2011 8:59 PM
  • I've been seeing errors on clients that they weren't able to upload the error reports.  It's actually been going on for some time, but I just finally started looking into it and came across this thread.  

    So has this ever been fixed, or is it a feature that will never work in SCE 2010? 

    And if the issue is that it's trying to use SSL, can I just I edit the manged computers policy to disable the "Connect using SSL" setting to make it work?

    • Edited by NeighborGeek Thursday, February 23, 2012 6:32 PM
    Thursday, February 23, 2012 5:28 PM
  • if i follow the string above i get no windows error reporting folder,however if use  find under edit and write windows error reporting i do get to that folder,problem is i do not know what to do with the entries listed on the right hand side.could you be of help,because i have the same problem
    Saturday, May 06, 2017 10:56 PM