locked
Win 7/Outlook 2007 Clients Prompt for Password for Incorrect Exchange Server RRS feed

  • Question

  • Hi,

    Bit of an odd problem. Current environment has 2 Exchange 2010 servers (ex01 and ex02 for this scenario). Prior to Exchange 2010 being installed, it was an Exchange 2007 environment also with 2 servers (ex03 and 04).

    EX01 - CAS and Hub transport
    EX02 - Mailbox Stores

    Majority of our desktops are running Windows XP, Office 2003 with Outlook 2007 (bit of a mess I know). We are currently preparing a Win 7 deployment. On our test Win 7 machines we have Office 2007. For some reason, when using Win 7/Outlook 2007, the client continuesly prompts for the password for one of the old exchange servers, EX03. If we click cancel, it goes away and the client connects to exchange fine. But then the prompt comes up again at random intervals (2 minutes to hours)

    If either outlook 2003 or 2010 are used instead if 2007, the problem goes away. We have 3 test machines that are all behaving in this same manner.

    Now I know the easiest way to deal with this is to just use Office 2010, but I've been told that is not an option for some unknown reason.

    Any assistance would be greatly appreciated.

    Thanks,
    Gary 

     

     

     

    Friday, August 12, 2011 7:48 AM

Answers

  • Try putting outlook in online mode instead of cache. As online with talk to the CAS/MBX directly.
    • Marked as answer by Gary_Chan Friday, September 23, 2011 6:24 AM
    Monday, August 15, 2011 5:10 AM

All replies

  • Is the old server in some way configured as OWA server?

    Check Outlook 2007 setting (Tools - Account settings - Change - More Settings - Connection - Checkbox "Connect over HTTP"). Sorry if the path shown is not exactly correct, I have no english Outlook version. Could it be that Outlook is trying to connect using RPC over HTTP?  

    Friday, August 12, 2011 8:14 AM
  • I am wondering if this is autodiscover.
    Start by running the test autodiscover tool. Hold down ctrl while right clicking on the Outlook icon in the system tray. Choose test email autoconfiguration. Run the process. See what results are being returned.

    I would also check the autodiscoverserviceinternalURI value on get-clientaccessserver |fl and ensure that it resolves to where you are expecting it to.

    Is the EX03 server still around? Is it/was it a domain controller?

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Friday, August 12, 2011 3:24 PM
  •  

     

    Thank you both for your replies.

    Sorry, I should have made it clear before that EX03 and EX04 no longer exist.

    @eduard - The old server EX03 was configured for OWA, but as noted above no longer exists. I have had the problematic Win7/Outlook 2007 clients using Outlook Anywhere also for testing proposes and the problem still exists whether I use it or not.

    @Sembee - When using the test AutoDiscover tool, it resolved to EX02 as expected.

    Running the get-clientaccessserver | fl, autodiscoverserviceinternalURI returned the value I would expect it to. If it was an autodiscovery issue, wouldn't all versions of the outlook client be experiencing issues?

    EX03 was only ever an Exchange server, and was never a DC.

    Thanks,

    Gary.

     

     


    Monday, August 15, 2011 4:41 AM
  • Try putting outlook in online mode instead of cache. As online with talk to the CAS/MBX directly.
    • Marked as answer by Gary_Chan Friday, September 23, 2011 6:24 AM
    Monday, August 15, 2011 5:10 AM
  • From limited testing, not using cache mode appears to be working. I'll give it a day to two and report back.

    Thank you greatly for your suggestion. Although it still leaves many questions unanswered.

    Cheers,
    Gary 


    Monday, August 15, 2011 7:48 AM
  • Hello,

     

    The credential issue may be occur due to various causes. Would you please help to collect the following informaiton for further troubleshooting:

     

    1. [The screenshot of the credential pop up window]

     

    2. [Collect AutoConfiguration Status in Outlook]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Test Email Autoconfiguration”.

    b. Confirm that your email address is in the address field, uncheckUse Guessmart” and “secure Guessmart authentication” boxes. Then click the “Test” button.

    c. Once it runs, please send me a screen shot of the Log tab and Results tab.

     

    3. [Capture a screenshot of the Outlook connectivity]

    ===================================

    a. While Outlook is running, click the CTRL key and then right-click the Outlook icon in the system tray and then select “Connection Status”.

    b. Send me a screenshot of the result.

      

    1. [CAS server configuration information]

    =============================

    On CAS server, open “Exchange Management Shell” and type the cmdlet:

     

    Get-autodiscovervirtualdirectory | fl >c:\auto.txt

    Get-clientaccessserver | fl >c:\cas.txt

     

    You can reach me at: v-simwu@microsoft.com

     

    Thanks,

    Simon

    Monday, August 15, 2011 7:51 AM
    Moderator
  • Hi Gareth,

     

    Thank you for taking time to collect the information.

     

    From the screenshots, all the Outlook web services are set to “access owa.xxx.xx.xx”. So, the credential issue is not related to the web services.

     

    The issue may occur if the Outlook still tries to access the public folder database on EX03 or EX04 server.

     

    Run the following command to see the default public folder database for all the mailbox store:

     

    Get-MailboxDatabase |FL

     

    Please see the “public folder database” value and check if it still resides on EX03 or EX04 server.

     

    Thanks,

    Simon

    Tuesday, August 16, 2011 3:40 AM
    Moderator
  • Hello,

     

    The “xxx Public Folders” is on Exchange 2010 MBX server, isn’t it?

     

    If so, we have to first know why Outlook tried to connect the Exchange 2007 server. You can take a RPC trace from the problematic Outlook client, reproduce the issue to see the details:

     

    [RPC trace]

    ===========

    1. Please unzip the package in the attachment(rpctrace_2007) to c:\rpctrace

    2. Locate C:\Program Files\Microsoft Office\Office12, rename emsmdb32.dll to emsmdb32.bak, olmapi32.dll to olmapi32.bak.

    3. Then copy trace-enabled version of these two files (in the attachment) to this folder.

     

    For example, if the Outlook client version is Outlook 2007, please copy the emsmdb32.dll to emsmdb32.bak in the Outlook 2007 folder in my attachment to C:\Program Files\Microsoft Office\Office12.

    4. Run the registry file attached “Tracetofile.reg”, then click “OK”.

    5. Please try the reproduce this issue.

    6. After complete the test, The RPCTrace log file will be generated as

     

    C:\tmp\rpctrace.log. please send this file to me.

     

    7. Restore the 4 dll files in step 3#.

     

    Thanks,

    Simon

    Wednesday, August 17, 2011 8:51 AM
    Moderator
  • I can confirm that running Outlook in online mode stops the message. Currently working through what the actual cause of the problem is with Simon. Will update thread as soon as it is resolved.
    Friday, August 19, 2011 6:37 AM
  • Gary_Chan, any update please

    Thank you!

    Wednesday, February 8, 2012 7:40 PM
  • We are also facing the same password prompt issue

    Current environment has 14 Exchange 2010 servers

    10 mailbox server

    4 CAS/HUB server

    We have Public folder database PA-PF01, CR-PF01 and it resides in mailbox server PA-MBX01 and CR-MBX01  respectively.

    5 database  point to PA-PF01 (default public folder database)

    5 database point to CR-PF01 (default public folder database)

    For some reason, few user outlook continuously prompts for the password, If we click cancel, it goes away and the client connects to exchange fine. But then the prompt comes up again at random intervals (2 minutes to 15 minute). When I check their connection status, it is trying to connect PF via http and never accept password

    Database which I resides  default PF is set to PA-PF01 and When i opens Outlook while in the LAN the initial public folder connection attempts to form an HTTPS connection (therefore forcing a password request) to the PA-PF01 public folder replica then fails over to the CR-PF01 replica (via TCP/IP) after the successful credential (it never connect to PA-PF01).

    I don’t understand why it is connecting CR-PF01 instead of PA-PF01

    Any assistance would be greatly appreciated

    Wednesday, February 8, 2012 7:48 PM