none
service unavailable http error 503 Application pool Stopped for the Web Appliaction

    Question

  • i am getting service unavailable http error 503 while opening a site in Sharepoint

    When i checked IIS, i found out that Application pool Stopped for the Web Application.

    So, i started it and then again launched the site...yet it still shows the same error and the pool is automatically stopped.

    Please help..

    Saturday, July 27, 2013 11:00 AM

Answers

  • Hi NabX,

    Based on your description, I can suggest as follow:

    1. Check the web site properties in IIS. Under home directory tab, check the application pool value and then open that application pool from the application pools (separate node in the IIS tree). Click the identity tab and see who is the pool assigned to. For the sake of testing, you can select "Predefined" and select local service from the drop down. Restart IIS and see if things work out for you. Http 503 error is generated by the IIS and it happens when web server sends data stream back to the web site.
    2. Verify that all SharePoint services are started, this error might occur because of changing the service account password. You may need to change the new password to application pool or SharePoint timer service. Click the stopped application pool -> click advanced settings ->Identity ->click the user to retype the user ->Application Pool Identity dialog ->click set -> manually type the user name and password. Then restart the server.

     

    Thanks,


    Qiao Wei
    TechNet Community Support

    Monday, July 29, 2013 5:53 AM
    Moderator

All replies

  • Hi NabX,

    Based on your description, I can suggest as follow:

    1. Check the web site properties in IIS. Under home directory tab, check the application pool value and then open that application pool from the application pools (separate node in the IIS tree). Click the identity tab and see who is the pool assigned to. For the sake of testing, you can select "Predefined" and select local service from the drop down. Restart IIS and see if things work out for you. Http 503 error is generated by the IIS and it happens when web server sends data stream back to the web site.
    2. Verify that all SharePoint services are started, this error might occur because of changing the service account password. You may need to change the new password to application pool or SharePoint timer service. Click the stopped application pool -> click advanced settings ->Identity ->click the user to retype the user ->Application Pool Identity dialog ->click set -> manually type the user name and password. Then restart the server.

     

    Thanks,


    Qiao Wei
    TechNet Community Support

    Monday, July 29, 2013 5:53 AM
    Moderator
  • Thanks alot, i had same error but now its resolved..........once again thanks..
    Wednesday, March 05, 2014 6:20 AM
  • i tried this one...working..thanks


    abbijohn

    • Proposed as answer by abbijohn Wednesday, June 18, 2014 10:10 AM
    • Unproposed as answer by abbijohn Wednesday, June 18, 2014 10:10 AM
    Wednesday, March 05, 2014 12:54 PM
  • Excellent, Thanks for the solution.
    Monday, May 12, 2014 11:59 AM
  • Thank you very much, i had the same error and i have resolved it by following yours suggestions.

    Best Regards,

    Waseem Khan

    Friday, June 27, 2014 6:04 AM
  • This was very helpful, we installed Metalogix for SP2013 and the installation disabled all the SP Application pools.   Thanks for the heads up, starting them after the install did the trick!
    Thursday, July 31, 2014 8:33 PM
  • Many thanks. It solved my problem.

    keep up the good work. cheers.

    Thursday, October 09, 2014 9:14 AM
  • Hello,

    This issue may causes because of the password expiry of user account attached to the application pool and adding the User and password again will solve the issue. To reset the password for user follow the steps:

    1. Start the IIS and go to Application pool
    2. Select the application pool which is showing the error and click on the Advanced Settings
    3. Go to Process Model -> Identity and click the Application Pool Identity
    4. Select the Custom Account and click on the set button
    5. Enter the user name, password and confirm password and click OK
    6. Restart the IIS server

    Hope this will answer the people who facing the same issue

    Thanks,

    Umesh

    Tuesday, December 30, 2014 11:46 AM
  • Another thing you need to check in Event Viewer>Windows Logs>System is if there is a 5021 warning event. This event states that user name or password is incorect or the user may not have batch logon rights.

    To grant a user the batch logon rights, open the Group Policy (or Local Security Policy if domain is not used) and under Computer Configuration>Policies>Windows Settings>Security Settings>Local Policies>User Rights Assignment find "Log on as a batch job" and add the app pool account. 

    When you start the App pool again it should now run without stopping automatically.

    Wednesday, March 11, 2015 12:53 PM