locked
Files in Windows 7 64 not associated with Application in Windows XP Mode RRS feed

  • Question

  • I have autocad files located on an office server that we would like to associate with our autocad 2000 application installed on Windows XP Mode.  When Autocad was installed on the xp mode, the program was auto published to the Windows 7 start menu.
    I have tried copying the target string from the Windows 7 shortcut into the "open with" association dialog, but gives me an error message.  It says the filename is not valid.
    %SystemRoot%\system32\rundll32.exe %SystemRoot%\system32\VMCPropertyHandler.dll,LaunchVMSal "Windows XP Mode" "||f78bc45e" "Autodesk Architectural Desktop 3"
    After reviewing the help file, I understand that files should be automatically associated with xpmode apps, but in this case, they are not.

    The goal is to double click on the autocad file in windows 7, and then the autocad application will launch from the xpmode.

    I am unable to choose the correct target under "open with" because the executable for autocad (acad.exe) is installed within the virtual hard drive (.vhd).  Is there a command line that allows me to access the VHD from windows 7?

    Specs:
    Windows 7 64 Pro
    running Windows XP Mode
    Intel i7 920 2.66

    thanks,
    James
    Wednesday, December 9, 2009 7:23 PM

Answers

  • I use Virtual PC every day. I use them for a range of purposes. I have one with Office 2010 beta and Visual Studio 2010 betas. Others are for backwards compatibility reasons. Finally a few is for testing in various legacy versions of Windows.

    If you have installed AutoCAD in the VM you should be able to open a drawing fine and work on it. Keep in mind the host OS and guest OS are isolated form each other. So you will have to install it in the VM again if you want to use it there.

    I have a file server so I keep a lot of files there as its easier to share them with a server than with the host OS's offerings.

    As for Shan's comments that old programs perform poorly, give the VM plenty of memory and it will run just fine.

    At the end of the day it might be an idea of scrape up the price of a new version of AutoCAD. The new versions now are 64-bit and can handle even super complex 3D drawings easily.

    I upgraded to AutoCAD 2009 x64 and I also have 3D studio 2009 x64 as well. Together I can work with the largest models easily.



    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe

    Server: ASRock P4-2GHz, 1.5 GB RAM, Linux Server, need IDE/SATA disks for my chess site

    Workstation: Asus M2NBP-VM CSM, Athlon64 X2 4200+ 65W CPU, 2GB RAM, NVIDIA 8600GT, 320GB + 160G backup, Windows 7 Ultimate x64.
    Tuesday, December 15, 2009 3:24 AM
  • Update:

    How to get AutoCAD 2000 to install on a Windows 7 64 bit operating system.  The problem we were having was with the forced installation of Netmeeting from the AutoCAD installation disc.  Our solution at the time was to install AutoCAD on the Windows Virtual XP.  The XP mode created more problems than we were able to ignore because the XP mode is very watered down and does support proper graphics for the drafting software.  We decided to try another approach.  Take the AutoCAD 2000 installation disc (Architectural Desktop release 3 in our case, which is based on AutoCAD 2000) and create an ISO image of the disc.  I used MagicISO because it allowed me to make the image, and delete the folder for Netmeeting from the ISO image.  I believe it is under Support\NM in the ISO image.  Once the NM folder is deleted from your ISO image, burn the image onto a new disc.  It will fit onto a 700mb disc.  Then proceed with the installation of AutoCAD onto your Windows 7 machine.  It worked great for me, but my colleague is still having problems.  We suspect it is because he is still using the Beta version of Windows 7 64.  I am using the full Windows 7 64 Professional version.  We will be getting the full version for my colleague and trying the installation again.  I will start a new thread for this discussion.

    Cheers,
    James
    Monday, December 21, 2009 3:11 PM

All replies

  • Hi James,

    As AutoCAD 2000 is published to Windows 7 desktop, can you start it without starting XP Mode?

    If so, can you use it to manually load a file in Windows 7 system?

    I tried to install a different program in XP Mode named WINRAR. It can help open zip files. It is published to Windows 7. when I tried to choose Open with on a ZIP file, WINRAR (on XP Mode) will be an option automatically.

    Specific to AutoCAD, I cannot confirm if it will be the same as WINRAR. But I need to say that although we published the program shortcut to Windows 7, actually it is still started in virtual machine. So you should enable Integration feature and integrate hard drives to XP Mode so that it can help load files easier.  
    Friday, December 11, 2009 9:19 AM
  • Shaon Shan,

    Yes, I can start Autocad 2000 from Windows 7 without starting a full run of XP mode.  The program is in my start menu under XP mode applications in my Windows 7 start menu.

    I tried to use the Open With command for Autocad 2000, but the program was not on the list.  There is a problem if it is not on the list because I can't go searching for the acad.exe due to the fact it resides within the virtual drive.

    I do have my Integration Feature turned on, and was on during installation.  I have also loaded Adobe Acrobat 6.0 within XP mode, and I am able to choose this program from the list within the Open With option.  I have a colleague who also has the same operating setup, and he too does not have Autocad 2000 listed in the Open With command....

    I am starting to think it is an Autocad 2000 problem....

    Is there a way to manually associate files with an XP mode application?

    Best,
    James
    Monday, December 14, 2009 2:53 PM
  • Hi James,

    It seems that we cannot manually choose a program in virtual PC. Programs will be added to the Open With list after publish to desktop. I tried Notepad and IE6, both are added to Open with list automatically. So it may be a AutoCAD issue.

    Do you have AutoCAD program installed on Windows 7? Maybe you can try to 1. Install AutoCAD 2000 in Windows 7 with compatibility Mode. 2. Try reinstall AutoCAD 2000 in XP Mode with enable Integration Feature and Auto Publish to see if it will add itself to the Open with list. 3. Upgarde AutoCAD to get it installed in Windows 7 as I've heard its performance is not so fine in virtual system as physical system.
    Tuesday, December 15, 2009 3:10 AM
  • Update:

    How to get AutoCAD 2000 to install on a Windows 7 64 bit operating system.  The problem we were having was with the forced installation of Netmeeting from the AutoCAD installation disc.  Our solution at the time was to install AutoCAD on the Windows Virtual XP.  The XP mode created more problems than we were able to ignore because the XP mode is very watered down and does support proper graphics for the drafting software.  We decided to try another approach.  Take the AutoCAD 2000 installation disc (Architectural Desktop release 3 in our case, which is based on AutoCAD 2000) and create an ISO image of the disc.  I used MagicISO because it allowed me to make the image, and delete the folder for Netmeeting from the ISO image.  I believe it is under Support\NM in the ISO image.  Once the NM folder is deleted from your ISO image, burn the image onto a new disc.  It will fit onto a 700mb disc.  Then proceed with the installation of AutoCAD onto your Windows 7 machine.  It worked great for me, but my colleague is still having problems.  We suspect it is because he is still using the Beta version of Windows 7 64.  I am using the full Windows 7 64 Professional version.  We will be getting the full version for my colleague and trying the installation again.  I will start a new thread for this discussion.

    Cheers,
    James
    Monday, December 21, 2009 3:11 PM
  • hi james i tried your idea with autocad 2000 mechanical desktop,

    but i cannot find the support/nm view can you help please thks

    progmaster

    Thursday, July 1, 2010 9:40 PM