locked
new-mailboxexportrequest MapiException errors RRS feed

  • Question

  • When I run the new-mailboxexportrequest cmdlet I get one of two errors, depending on how I put the mailbox in.  If I just use the alias, I get MapiExceptionUnknownUser.  If I put in the full user@domain.com I get either MapiExceptionUnknownUser or MapiExceptionCallFailed: unable to make a connection to the server.  I am running this command directly on the server.  If I use the get-mailbox command with either the alias or email address, I do not get an error.  If I pipe that into the export request, I get the same errors again.

    Some things I have tried:

    set-casmailbox -identity user.name -mapblockoutlooknoncachedmode:$false (then back to true) and tried to export again - no luck.

    Stopping and starting the Mailbox Replication Service

    running the get-mailboxexportrequest before running the new-mailboxexportrequest

    and just running the command over and over - I have it scripted and running the scrip repeatedly did eventually get me 18 mailboxes exported in small chunks.  I'd get 5 or 6 and the rest would fail.  so I would start over, just removing those that succeeded from my list.  I have 11 left to export.  I am trying just one at a time so that I can try something, run the command, and if it fails try something else.

    There is only the one exchange server, so there is no load-balancing or SNAT'ing to work with. I have asked that the server be rebooted tonight. It currently has Exchange 2010 SP2 rollup 4. Any help would be greatly appreciated!

    Monday, September 17, 2012 3:18 PM

All replies

  • Is user@domain.com the UPN or just an e-mail address?  That form is supported for the UPN.

    I can't fathom why you're seeing the other issues you're seeing.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."


    • Edited by Ed CrowleyMVP Tuesday, September 18, 2012 6:09 AM Error fixed
    Tuesday, September 18, 2012 6:06 AM