locked
"No windows media player detected" using Firefox 2.0.0.1 RRS feed

  • Question

  • I do not know if this is a mozilla issue or a vista issue, but anyhow it is anoying! :-)

    Anyone out there that knows of a workaround to get the media player plugin to work for firefox?..all the faq's and howtoos out there are for older WMP versions and XP..

    borkrist
    Wednesday, January 3, 2007 7:58 AM

Answers

  • The fix described here worked for me:
    http://kb.mozillazine.org/Windows_Media_Player#Missing_plugin
    Basically I simply downloaded three .dll files and put them in the Windows Media Player folder, as described, and magically it started working.
    Friday, February 2, 2007 12:25 PM

All replies

  • I also have the same issue with Firefox 2.0.0.1  I'm not sure if the "No windows media player detected" occurred after upgrading to FireFox 2 or when I "upgraded" to Windows Media Player 11.

    Installing Windows Media Player 11 has no effect.

    Embedded Windows Media players in webpages also do not work.

    Windows Media Player 11 does seem to work in I.E. Version 6

    If I save the files to my PC first and open them, they do play.
    - - - - -

    Separate issue.  With pre version 11 Windows Media Player, we were able to click on the top right corner of the screen and save the file.  Where is this capability in version 11.  Also, where is the help / about to check or version number?

    Thanks.
    Friday, January 26, 2007 3:31 PM
  • I also have this problem. When you find out could you please let me know? I was looking at cnn video yesterday on firefox but that was before i downloaded media player 11. No can do now.
    Monday, January 29, 2007 5:13 AM
  • Same problem here.  I just did a fresh install of Vista Home Premium which has WMP 11 included and CNN videos won't play in Firefox 2.0.0.1.  Videos work in IE.  Looking for a fix, I'll report back here when I find it.
    Thursday, February 1, 2007 3:56 PM
  • The fix described here worked for me:
    http://kb.mozillazine.org/Windows_Media_Player#Missing_plugin
    Basically I simply downloaded three .dll files and put them in the Windows Media Player folder, as described, and magically it started working.
    Friday, February 2, 2007 12:25 PM
  • I saw that info in a search yesterday but decided not to try it and risk my new Vista install by mucking with DLLs.  However, after seeing your post, I tried it and it worked.  Thanks! 

    I just copied those three DLLs to the plugins directory under the Firefox install, then told it to "continue anyway" when playing a CNN video the first time.
    Friday, February 2, 2007 1:33 PM
  • You are the MAN. I downloaded the 3 DLL's in the media player file and it works like a champ. Case close. And thank you very much!!!
    Friday, February 2, 2007 4:19 PM
  • Awesome!  Same problem on a new machine with XP Media Center Edition.  Adding the dll’s fixed it.

    Saturday, February 3, 2007 3:14 PM
  • had the same problem with a brand new computer that had media center edition 
    , adding the dlls worked! thanks a bunch!
    Sunday, February 4, 2007 2:20 AM
  • I had the same issue with Firefox 2.0.0.3 running on Windows XP x64. I tried installing  both the  Windows Media Player app from microsoft and also the plugin from: http://port25.technet.com/pages/windows-media-player-firefox-plugin-download.aspx, neither worked.

    I downloaded the above DLL's to the Firefox plugin directory and everything works fine (I didn't even have to restart!).
    Tuesday, May 8, 2007 8:03 PM
  • thanks a lot!! it worked for me! Smile
    Sunday, November 16, 2008 1:27 AM