Application stops listening on port 2121 when the RDP session is logged out


  • I have a 3rd party application installed on a VM running windows server 2008r2 with SP1.

    The application runs as a service.

    The application is configured to listen in on port 2121 and this works fine if the application is launched at a console session via an RDP connection, the issue though starts when the RDP session is logged off.

    The knock on effect is that this seems to permanently close the application which means it stops listening in on port 2121 which in turn affects client connections.

    There are no errors in event viewer or the application that I can tell.

    I have installed the application in a lab environment and it works 100% with no issues , even after logging out of a RDP session.

    Any ideas what could be causing such an issue ?

    Thanks in advance.

    Wednesday, July 17, 2013 12:38 PM

All replies

  • Which process? When in console session, look in Task Manager, User Name column, which user owns this process? If this user initiated the console session, then this process will end when the user logs off the console session.

    It’s best to consult the vendor of this 3-party software for a solution.


    TechNet Subscriber Support |If you have any feedback on Technet forum, please contact

    Thursday, July 18, 2013 5:47 AM
  • Hi,

    Any update on this post?

    TechNet Subscriber Support |If you have any feedback on Technet forum, please contact

    Tuesday, July 23, 2013 7:52 AM
  • Hi Zhang,

       Sorry for the time lapsed...I tried setting the service as local system account instead but the same issue occurs.

    I even rebuilt a server in my lab using different media and one that is custom built for the business that worked ok, but I'm not sure if it's the same version used to build the server on which I'm having the issue.

    It's almost like the OS doesn't like the application service.

    Unfortunately the program vendor is not able to provide much support cause they only really know about the app and not how it might interact with different OS.

    Are there any group policy's that can cause such an issue ?

    I'm thinking of moving the server into a different OU to see what effects that has.


    Tuesday, July 23, 2013 10:20 AM
  • I've being able to fix the issue (finally)...

    It ended up being a tick box in the logon tab of the service which is "Allow service to interact with the desktop".

    It's a legacy app.

    So i had to stop the service,tick the check-box,start the service and now it's working fine...and best thing is that the application does not need to be launched interactively as it's now running as  as "Local System Account" service.

    So just thought I'd write this up in case anyone else finds themselves in a similar situation.

    Cheers and regards,

    • Edited by Darsenator Thursday, August 01, 2013 4:42 AM
    Thursday, August 01, 2013 4:40 AM