none
Actuals not "in-synch" in "Tasks" page and in Timesheet RRS feed

  • Question

  • Hi all,

    In our Project Server Online environment, I’ve found a strange behavior when using the “Single Entry Mode” for the actual work. In fact, it can be easy to “desynchronize” the actuals from the “Tasks” page and the Timesheet. Moreover, the Project Manager can approve actuals that are not in synch with the timesheet.

    I know that when the “Single Entry Mode” is enabled, we should always use the timesheets to enter actuals and hide “Tasks” from the quick menu. But even if the Tasks option is hidden from the quick menu, as I explain at the end of the post, it still possible to access the “Tasks” page

    So, here are the steps to “desynch” the actuals

    First, I enter some actuals (35 hours) in the “Tasks” page


    If I click on « Current timesheet », all the actuals are there and in-synch (35 hours in the Tasks page and 35 hours in the timesheet). But since we have clicked on « Current Timesheet », the timesheet has not been created yet, as we can see in the “Manage timesheets” page :


    Ok, so I click « Click here to create . But oops, all actuals are gone !!!


    Then I re-enter some actuals (with a total of 25 hours, to see if actuals are pushed to the “Task” page”) and save the timesheet


    I go back to “Tasks” page. The total (25 hours) is the same as expected (yesss !!). Again, I change the actuals (this time 40 hours) in the “Tasks” page and save. If I return in the timesheet, the actuals have not been updated, it still 25 hours (Oh Nooo !!!)


    It looks like the synchronization is one way when the « timesheet » is created, and two ways when the time sheet is not created.

    But worst !! In the Timesheet page, I click submit and the Project Manager receives the update. The actuals are the ones in the Tasks page (40 hours), not the ones submitted (25 hours)…


    To push the tests a little farther, I recall the timesheet and delete it. Then I click on the « Current Timesheet » (on the left). The actuals are the same (40 hours) as in the “Tasks” page. So far so good. Since the actuals are the same, I submit !!! Oops !! No more actuals…..


    But the Project Manager has the good actuals ….


    I don’t think it’s a feature…. But there is a solution, since we are in the «Single Entry Mode », we just have to hide the « Tasks » link on the left. The problem is, even if the option is hidden in the quick menu, when we add a team task, the « Tasks » button is available in the ribbon…


    And believe me, if it’s available, it will be used….

    Finally, my question is : Is this a bug or feature and if it's a normal behavior, how can I get rid of the "Tasks" page definitively...

    Thanks !


    Hugues Perron

    Tuesday, October 27, 2015 12:46 PM

Answers

  • Hi,

    SEM is just a one way direction, if a timesheet is already created. So your approach to hide the link to tasks ist fine as described for 2010 here.

    To completely hide Tasks for users, you could remove webpart from /tasks.aspx - Settings - Edit page - Delete webpart.

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Monday, November 2, 2015 6:23 PM
    Moderator