ActiveSync Clients Cannot Open Attachments Over 10MB RRS feed

  • Question

  • Good day,

    I was alerted to an issue today where ActiveSync clients cannot download e-mail attachments that are over 10MB.  I was able to successfully recreate the problem with my Lumia 920 (WinPhone 8) and my old iPhone 4 (iOS 6).  The iPhone had a nice work-around though where if you scroll to the bottom of the message there is a section stating "This message was downloaded as plain text" with a button beneath it labeled "Download full message".  Clicking that button downloads the full HTML-formatted message, attachments included. 

    As it relates to the Exchange-side of things I do not have a "Maximum attachment size" set in the EAS Mailbox Policy (attachments are allowed to be downloaded by the device though).  My receive connectors are set with a "MaxMessageSize" of 21MB and my TransportConfig is set with a 21MB MaxReceiveSize and MaxSendSize.  Mailboxes and Send Connectors are set as "unlimited". 

    I did a little more digging and found the following lines in the ActiveSync web.config file (located at C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Sync):
                Sets the maximum data size that we will fetch (range or othewise)
        <add key="MaxDocumentDataSize" value="10240000"></add>


        <!-- Allow maximum 10 megs of content -->
        <httpRuntime maxRequestLength="10240" />
        <authentication mode="Windows" />

    Doing some searching around these forums (and on the web in general) have revealed that people have altered one but not the other and achieved what they needed.  This is a little confusing, as why would I be able to increase the DocumentDataSize value and have it work, where someone else would increase the RequestLength and achieve the same result? 

    Can anyone shed some light on this for me? 

    Additionally, I am in a 2003-to-2010 transition period but the 2010 CASes (behind a Kemp HLB) are handling all of the EAS work at the moment.  The Exchange servers are 2010 SP2 Rollup 3.  This issue was reported with a 2003 mailbox, but I replicated it on my mailbox, which is in a 2010 database. 

    Thanks in advance!  

    Wednesday, November 28, 2012 10:50 PM


All replies

  • Thanks for your reply!  I was getting a little concerned that no one was going to chime in! 

    Scenario 1 doesn't appear to apply, as I mentioned in the original message, I already checked the TransportConfig and ReceiveConnectors, which are set at 21MB, and the SendConnectors and mailboxes aren't set with a limit. 

    Scenario 2 seems quite plausible, but I'm curious as to what the difference is between "MaxDocumentDataSize" and "maxRequestLength", as I've seen some documentation state that they only set the one but not the other, and some had set both.  Do you have any insight on the differences of these two files? 

    I don't think scenario 3 applies, as I cannot find urlscan.ini on my 2003 back-end servers (when the CASes would be proxying to) and the OMA\Sync folder is indeed empty, while OMA\browse does contain the web.config. 

    Thanks again!

    Thursday, December 6, 2012 3:28 PM
  • Thanks for the reply, but those links don't help me too much.  Again, my transport-related settings are at 21MB and this is only affecting opening attachments via ActiveSync (not adding attachments via OWA or sending mail). 

    That said, I have seen where some people have fixed it by adjusting the "MaxDocumentDataSize" (like in this thread and in this thread) but have seen others, like the ones you shared, recommending adjusting the "maxRequestLength". I'd simply like to know what the difference is between these two fields as it relates to Exchange 2010. 

    Also, now that I think about it, I have the Default EAS Mailbox Policy set to allow attachments and "MaxAttachmentSize"is set to "Unlimited".  I'm wondering if changing that to 20MB would work, too. 

    Friday, December 7, 2012 4:42 PM
  • Paul, have you ever managed to solve this problem (10 MB download limit) and if answer is yes, how exactly? ... have you managed to shed some light on difference between MaxDocumentDataSize and maxRequestLength?

    Thanks, MS

    Thursday, May 30, 2013 4:46 AM
  • No, I actually haven't needed to.  The people who complained stopped having the issue when I moved them to 2010 (iOS users who can click the "download full message" button), so I haven't had to do anything to it.  Plus I still need to implement a few new CASes and want to do them all at once. 

    That said, my company had an Exchange Premier Field Engineer come out to do an Exchange Risk and Health Assessment in March and he said that the proper field is "MaxDocumentDataSize" (and that the "maxRequestLength" is actually meta-data related).  Interestingly, as noted above, I've read articles where people say that they set one and it worked, but other articles claim they set the other and it worked, so I dunno. 

    If you end up pulling the trigger let me know how it works out for you.  If you do, you'd have my undying gratitude.  ;) 

    Thursday, May 30, 2013 10:15 PM
  • Thanks for answering Paul. I ended up "pulling the trigger" and it seems everything end well. We can now send and receive attachments larger than 10 MB from our iPads. You can read entire thread I started at http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/a55a5769-8fb0-44dd-a92e-28de178493c2 . I summarized everything in the last post.

    Friday, May 31, 2013 6:58 PM
  • Awesome!  So from what you're saying, and based on the 2013 article you posted on your thread, MaxDocumentDataSize = downloading via ActiveSync and MaxRequestLength = sending via ActiveSync.  Is that correct? 
    Friday, May 31, 2013 8:00 PM
  • Based on TechNet documentation, on my observation from Windows Application log and IIS logs on Exchange Server 2010, and on my real life testing, that is the correct answer.
    Saturday, June 1, 2013 11:17 AM
  • hi MiToZ

    i know this is an old topic and great to see you were able to resolve the issue you had with the limits

    we are experiencing a similar situation and we have applied higher limits using the same steps you have undertaken and that allowed us to send/receive/open attachments over 10MB. we have set our limit to 50MB but we are still unable to send anything over 20MB from the mobile devices.  I was wondering if you have any additional info you can share on how to address that issue



    Friday, April 21, 2017 12:52 AM