none
.msg files open in new tab or window, not with the default program RRS feed

  • Question

  • Hello,

    I am having an issue with .msg files not opening with the default program, Outlook. They are opening in a new tab and it is just a bunch of gibberish from the email header. Does anyone know how to force IE to open the .msg files in Outlook? They open fine in Chrome and Firefox.

    Thanks for your help!

    Thursday, March 27, 2014 4:41 PM

Answers

  • Hi,

    First I suggest we take a try in IE with no-addons.

    Follow the steps below:

    1. Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons)

    2. Press Shift, then right click Internet Explorer icon on taskbar, select run as administrator;

    Please also take a verify that if the outlook is set to the default open program of .msg files:

    Control Panel\All Control Panel Items\Default Programs\Set Default Programs, find the .msg file and take a look.

    Then we may try to use process monitor to track the root cause of this issue:

    The download link here:

    Process monitor

    And here is a blog talking about how to use it:

    Process Monitor - Hands-On Labs and Examples

    Hope this may help

    Best regards


    Michael Shao
    TechNet Community Support

    Friday, March 28, 2014 8:25 AM
    Moderator

All replies

  • Hi,

    First I suggest we take a try in IE with no-addons.

    Follow the steps below:

    1. Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons)

    2. Press Shift, then right click Internet Explorer icon on taskbar, select run as administrator;

    Please also take a verify that if the outlook is set to the default open program of .msg files:

    Control Panel\All Control Panel Items\Default Programs\Set Default Programs, find the .msg file and take a look.

    Then we may try to use process monitor to track the root cause of this issue:

    The download link here:

    Process monitor

    And here is a blog talking about how to use it:

    Process Monitor - Hands-On Labs and Examples

    Hope this may help

    Best regards


    Michael Shao
    TechNet Community Support

    Friday, March 28, 2014 8:25 AM
    Moderator
  • I am having an issue with .msg files not opening with the default program, Outlook.

    From where?  The web?  Then you should look at the Content-type header which is coming with them.  Use the Developer Tools, Network Capture tool to find out what is going on.  In IE11:  F12, Ctrl-4, F5.  If you are using IE8 you can use Fiddler2 to do the tracing.  Otherwise a guess would be that the Content-type header is incorrect so then you could use a Security option in the Miscellaneous section which, depending on your version of IE, variously says, pay attention to file extension or avoid MIME sniffing.  Otherwise, just use right-click, Save Target as... and then open the .msg file using Windows File Explorer.  Assuming you have the correct filetype association for that extension it should then open in the program you have associated with that extension.

     

    FYI



    Robert Aldwinckle
    ---

    Sunday, March 30, 2014 5:23 AM
    Answerer
  • Hi, I have the same problem when downloading a stored file with the .msg file extension.

    The browser (IE11) opens a new tab and display the .msg file as it was html.

    Then I select "save target as" the file extension is changed from .msg to .htm

    If I rename the extension back to .msg and save it, I can open the file with outlook without a problem.

    Any idea why IE11 thinks it's a .htm file? 

    EDGE in win 10 also has the same bad behavior...

    Firefox or Safari just downloads the file or present a dialog to open it.

    Even if Firefox works, IE11 is the company preinstalled app and we have 90 users, I would not like to ask them all to use a new browser.

    Best regards,

    /Richard

    Tuesday, March 15, 2016 1:19 PM
  • I also have the same issue as Richard, IE11 is used by default for everyone in the company, and it is really annoy when viewing/saving .msg file.

    I tried to configure the web server to tell the browser that .msg is a binary file but still doesn't work for IE11. When moving the cursor over the URL, the hint shows it's a .msg but when saving IE proposes to save as .htm and when viewing, the link was opened in IE which shows meaningless things.

    Please let me know you if you have any solution so far, other than recommending people to change their browser to FF or Chrome.

    Wednesday, February 7, 2018 1:25 PM