none
Error while using KPI Indicator with SQL Server 2005 Analysis Services RRS feed

  • Question

  • Within a KPI List I'm attempting to create a new item using SQL Server 2005 Analysis Services. After a lot of head-banging and eventually turning on Single Sign-On, I was able to create a Data Connection that would allow me to connect to a data cube within the Adventure Works database.

    The problem happens with I try to select a KPI from those available within the combo box. Whenever I click a KPI the following error message is displayed:

    There is an error retrieving the KPI data.  Please make sure the KPI is setup properly in Analysis Service.

    If I ignore the error message and save the selected KPI, back on the KPI List page, the following error message is shown:

    Query (1, 23) Parser: The syntax for 'Value' is incorrect.

    Is there something I am doing wrong? All of the mentions of Analysis Services within SharePoint 2007 refere to the 2005 edition, but my database server is SQL Server 2008 R2. Is this the root of the problem?

    Any help would be much appreciated. 

    • Edited by Mike Walsh FIN Thursday, January 6, 2011 6:55 PM . Help?! removed from Title
    • Moved by Mike Walsh FIN Thursday, January 6, 2011 6:55 PM KPI so BI (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Wednesday, August 11, 2010 4:01 PM

All replies

  • I'm with you; I get the same error. I have SharePoint 2007, and SQL 2008 R2 (Standard). I can see the KPI Value, Goal, and Status in Excel if I browse the cube. What kills me is that I even set the Value Expression in BIDS to 0 (as in EVERYBODY is 0, regardless) and the KPI page STILL says, "The syntax for Value is incorrect."

    I'm of the mind that SharePoint 2007 does not read KPIs from SSAS 2008. Wouldn't be the first time one Microsoft product didn't play well with another. (Yes, I have MSOLAP.4 listed as a Data Provider in Central Admin).

    Have you gotten anywhere with this?

    • Edited by Mike Walsh FIN Friday, January 7, 2011 3:26 AM sig removed
    Thursday, January 6, 2011 6:40 PM
  • I´m also having the exact same problem. Have you managed to get it to work?

    This is what I tried so far:

     

    1) tried altering the mdx expressions in Analysis Services (on the data cube´s KPI tab) to consider something like KpiValue("Reseller Revenue")/KpiGoal("Reseller Revenue")>=.95, instead of syntax like [Measures].[Sales] (something i saw here: http://technet.microsoft.com/en-us/library/ms166869.aspx)

     

    2) installed 2 files from the SQL Server 2008 R2 Feature Pack: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=CEB4346F-657F-4D28-83F5-AAE0C5C83D52&displaylang=en#amo

     

    • Microsoft® Analysis Services OLE DB Provider for Microsoft® SQL Server® 2008 R2    Microsoft® SQL Server® 2008 R2 Analysis Management Objects


      3) Tried, on SSAS, put the number 0 on the Trend Expression, in case it was somehow necessary to have a value there.


    Note: i am new to SSAS, never used SSAS 05.

     

    Sunday, January 9, 2011 10:50 PM
  • Finally I found the solution. If you are interested I can tell you.

    Monday, January 24, 2011 11:15 AM
  • Did you ever solve this issue?
    Sunday, February 13, 2011 8:27 PM
  • OK, Can you please tell...

    I have tried everything I can think of with SSO and odc files etc to no avail.

    Wednesday, February 16, 2011 2:50 AM