locked
Issue with SfB remembering passwords after restart... RRS feed

  • Question

  • Hi Everyone,

    I've been having a lot of problems with SfB credentials over the past few months. It all started with the release of kb3114351 which was the cause of the "Exchange needs your credentials." issue. This issue is well documented on various forums and there are many solutions available online. The one that worked for me was disabling the "save password" box in the SfB login page (I achieved this by setting the SavePassword and AllowSavePassword values to 0 in the registry). Sure, users would have to enter their password every time they wanted to sign in but at least they could retrieve their call history from Exchange. 

    Which brings me to my current problem... I've noticed that if a user restarts/shuts down their computer while they're signed into SfB, somehow their password is retained when their computer turns back on and they are signed in to SfB automatically - even though there is no 'save password' option available in the client... Now this causes a different error:

    "The Exchange server won't let us connect.  We're working on fixing the connection.  Your history, voice mail and Outlook features might be unavailable or out-of-date until things are fixed."

    Again, call history and other features are unavailable due to this error. 

    Anyone have any suggestions to resolve any of the two issues? Your help would be much appreciated.


    • Edited by sainim Wednesday, February 15, 2017 12:50 PM
    Wednesday, February 15, 2017 12:47 PM

All replies

  • Hi sainim,

    Regarding the issue about SFB auto logon, please try to delete SFB cache file and test again.( %userprofile%\AppData\Local\Microsoft\Office\15.0\Lync\sip_UserName@Domain.com). On your computer, please try to do a clean boot as the following link:
    https://support.microsoft.com/en-us/kb/929135

    With the error “The Exchange server won't let us connect.  We're working on fixing the connection.  Your history, voice mail and Outlook features might be unavailable or out-of-date until things are fixed”, what issue did you encounter except for call history?

    Please press Ctrl and right click SFB icon in the taskbar, open configuration information. On the open page check if EWS status and MAPI status are OK.

    Moreover, make sure your SFB server and Exchange server with the latest update then test again.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Liinus Friday, February 17, 2017 6:00 AM
    • Unproposed as answer by sainim Monday, February 27, 2017 2:59 AM
    Thursday, February 16, 2017 7:36 AM
  • I have faced this issue.This always a head ache when integrating with exchange.Refer the below blog which will help you to solve your issue

    http://lyncforum.blogspot.in/2015/08/lync-2013-issue-with-ews-integration.html


    Jayakumar K

    • Proposed as answer by Liinus Friday, February 17, 2017 6:00 AM
    • Unproposed as answer by sainim Monday, February 27, 2017 2:59 AM
    Thursday, February 16, 2017 9:11 AM
  • Thanks for your suggestion, I tried the solution in your article but it didn't resolve the issue.

    The default providers for EWS and Autodiscover in my environment were Nego and NTLM. I did notice however, replacing those providers with Kerberos for EWS caused a different error: "Exchange needs your credentials."

    Any other thoughts? Again, this error never occurs when a user enters their password during login. It only occurs if their password had been saved.

    Sunday, February 26, 2017 2:02 PM
  • Thanks Alice, I'm sure deleting the cache file will stop the autologin, however, it won't permanently solve my problem. As I mentioned in my initial post, passwords are retained after every shutdown/restart - even though there is no 'save password' option. 

    The main issue is the call history. Although it seems like calendar info isn't coming through either.

    EWS is not available in the SfB configuration information: "EWS unavailable. Retrying"

    SfB server and Exchange server are updated.


    Sunday, February 26, 2017 2:09 PM
  • Also, this error does not occur in SfB 2016 (office 16.0) clients. It only seems to be occurring on SfB 2015 (office 15.0)...
    Sunday, February 26, 2017 2:11 PM
  • Hi sainim,

    Because there is no problem with SFB 2016 client, just appeared on the SFB 2015 clients, so based on my understanding, it may be a client side issue , please try to reinstall SFB 2015 client with the latest update and then test if there is the same issue, why we recommend you install with the latest update is that the latest update will fix some strange issue sometimes.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 1, 2017 8:38 AM
  • Hi sainim,

    Because there is no problem with SFB 2016 client, just appeared on the SFB 2015 clients, so based on my understanding, it may be a client side issue , please try to reinstall SFB 2015 client with the latest update and then test if there is the same issue, why we recommend you install with the latest update is that the latest update will fix some strange issue sometimes.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thanks Alice, but I have done this on multiple computers and it hasn't made a difference. Any other suggestions?
    Thursday, March 2, 2017 2:27 AM
  • So I logged on to one of my computers that was having this issue with a different account, applied the same GPOs that affect SfB, and noticed that the issue was no longer happening... 

    I should note that we use the same domain account to log into every computer in the office. I know it's unusual but we have our reasons.

    I've already tried the following (on the shared domain account):

    • Removing all user profiles under %userprofile%\AppData\Local\Microsoft\Office\15.0\Lync\sip_UserName@Domain.com
    • Deleting certs for those users in certmgr.msc

    Furthermore, this issue was occurring even when the shared domain account was used for the first time.

    Tuesday, March 7, 2017 3:34 AM