none
Hyper-V Server 2019 - RDP not working RRS feed

  • Question

  • Hi,

    So I am testing with Hyper-V Server 2019, which I deployed to three brand new HP Proliant gen10 machines. I'll test on them for a while before putting them in production. Installation was a breeze, as with Hyper-V 2016. However, I can't seem to enable RDP on Hyper-V Server 2019. When I enable through the menu, it says it's done so, but alas, netstat -a reveals there isn't even a process listenening on port 3389.

    I checked the registry, HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server is correct. The required services are running. Firewall is completely disabled through netsh for testing. Remote administration is working fine, RDP is not listening at all.

    Anyone else ran into this?


    Thursday, October 4, 2018 2:10 PM

Answers

All replies

  • I'm experiencing the same problem on a Dell R420. I tried to enable RDP via sconfig, but still said disabled. I changed the registry value for "fdenytsconnections" from 1 to 0, which at least showed "Enabled" for Remote Desktop in sconfig, but RDP still wouldn't work.... 
    Thursday, October 4, 2018 8:30 PM
  • Hi,

    Thanks for your question.

    Please try the following check steps,

    1 First, please use netstat -an |find /i "established" command to see what ports are in computer actually communicates with. Please do netstat -an |find /i "3389" command, to find if the port 3389 is open or not.

    2 Make sure listening port is set to default port 3389 or change to another value you prefer:
    Start Registry Editor.
    Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
    On the Edit menu, click Modify, and then click Decimal.
    Type the new port number, and then click OK.
    Quit Registry Editor.
    source: http://support.microsoft.com/kb/306759

    3. Enable Remote Desktop Connection:
    Right click on My computer
    Click on Properties
    Click on the Remote Desktop Tab
    Under Remote Desktop section click the check box: “Allow users to connect remotely to this computer
    Click OK

    4. Make sure your firewall (if you have one) allows for traffic on port 3389 or the port you chose for the listening port

    5. Please also check if any intermediary network devices such as switch or router to configure any security policy or rule to block this specific RDP traffic.

    If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 5, 2018 8:17 AM
    Moderator
  • Have you actually read my post? I stated EXACTLY that I have already the firewall disabled, the reg-keys / values are in place, RDP is actually enabled and there is NO pocess listening on 3389.

    @Rockstar: thanks for testing, that's what I thought already.

    5 minutes into the product and I run into bugs. This is what to expect from MS these days. Just lost 50GB of document with the 1809 update as well. Thank god I do multiple backups a day.



    Friday, October 5, 2018 8:33 AM
  • Yes, I am also looking for a way to set this up. It's very annoying. On the Server Core 2019 it works on this it does not. It works also on Hyper-V 2016.
    Friday, October 5, 2018 6:44 PM
  • Hi Robert,

    I missed your previous update, it's a terrible mistake, I'm very sorry!

    Please run the command "winver" on the RUN.exe and tell me the subversion as below. Meanwhile, I'll make the test with your similar environment to see if it could reproduce the same issue. I'll post you update as soon as possible.

    Highly appreciate your effort and time. If you have any question or concern, please feel free to let me know.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, October 9, 2018 10:08 AM
    Moderator
  • erm... there is no winver in Hyper-V Server, nor is there in Core servers. regular 'ver' though reveals version 10.0.17763.1.

    Note that I used the official media, 17763.1.180914-1434.rs5_release_SERVERHYPERCORE_OEM_x64FRE_en-us.iso, SHA1: 04B40E7E2FD14C964086C214D6409795908F6887, so that's the already infamous Windows 10 and Windows Server 2019 versions that both got pulled back. Not sure about Hyper-V 2019.

    Tuesday, October 9, 2018 11:18 AM
  • Hi,

    OK. I'll use the image to construct a similar environment for testing. See you. 

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, October 9, 2018 11:40 AM
    Moderator
  • I have installed two Windows Hyper-v 2019 server instances and both of them are problematic.  

    (Windows_InsiderPreview_ServerHypercore_17744.iso)

    I have enabled remote management in Sconfig.  I also set it to respond to pings.  

    I then enabled Remote desktop (from any client).  

    Result:

    ====

    I cannot ping or rdp to either of them.  I can't use RSAT tools to manage them. 

    \\192.168.9.211\c$ does not work either

    I have domain-joined the machines and they do this OK.  Outgoing connections are fine.  

    Aside from regedit, most of the tools I'd normally use to diagnose are not present.  

    I ran an netstat -ano and got this:

      Proto  Local Address          Foreign Address        State           PID
      TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       1144
      TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
      TCP    0.0.0.0:2179           0.0.0.0:0              LISTENING       2740
      TCP    0.0.0.0:5985           0.0.0.0:0              LISTENING       4
      TCP    0.0.0.0:47001          0.0.0.0:0              LISTENING       4
      TCP    0.0.0.0:49664          0.0.0.0:0              LISTENING       860
      TCP    0.0.0.0:49665          0.0.0.0:0              LISTENING       1428
      TCP    0.0.0.0:49666          0.0.0.0:0              LISTENING       1852
      TCP    0.0.0.0:49667          0.0.0.0:0              LISTENING       948
      TCP    0.0.0.0:49668          0.0.0.0:0              LISTENING       2244
      TCP    0.0.0.0:49701          0.0.0.0:0              LISTENING       908
      TCP    0.0.0.0:65124          0.0.0.0:0              LISTENING       948
      TCP    192.168.9.18:139       0.0.0.0:0              LISTENING       4
      TCP    192.168.9.211:139      0.0.0.0:0              LISTENING       4
      TCP    [::]:135               [::]:0                 LISTENING       1144
      TCP    [::]:445               [::]:0                 LISTENING       4
      TCP    [::]:2179              [::]:0                 LISTENING       2740
      TCP    [::]:5985              [::]:0                 LISTENING       4
      TCP    [::]:47001             [::]:0                 LISTENING       4
      TCP    [::]:49664             [::]:0                 LISTENING       860
      TCP    [::]:49665             [::]:0                 LISTENING       1428
      TCP    [::]:49666             [::]:0                 LISTENING       1852
      TCP    [::]:49667             [::]:0                 LISTENING       948
      TCP    [::]:49668             [::]:0                 LISTENING       2244
      TCP    [::]:49701             [::]:0                 LISTENING       908
      TCP    [::]:65124             [::]:0                 LISTENING       948
      UDP    0.0.0.0:123            *:*                                    1404
      UDP    0.0.0.0:5353           *:*                                    1612
      UDP    0.0.0.0:5355           *:*                                    1612
      UDP    127.0.0.1:54432        *:*                                    948
      UDP    127.0.0.1:54959        *:*                                    1396
      UDP    127.0.0.1:55926        *:*                                    1560
      UDP    127.0.0.1:63784        *:*                                    2740
      UDP    127.0.0.1:64944        *:*                                    2364
      UDP    192.168.9.18:137       *:*                                    4
      UDP    192.168.9.18:138       *:*                                    4
      UDP    192.168.9.211:137      *:*                                    4
      UDP    192.168.9.211:138      *:*                                    4
      UDP    [::]:123               *:*                                    1404
      UDP    [::]:5353              *:*                                    1612
      UDP    [::]:5355              *:*                                    1612

    They are not listening on TCP:3389

    I looked at the services with 

    sc queryex type= service state= all >services.txt

    and found this in the text file:

    SERVICE_NAME: TermService
    DISPLAY_NAME: Remote Desktop Services
            TYPE               : 30  WIN32  
            STATE              : 4  RUNNING 
                                    (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
            WIN32_EXIT_CODE    : 0  (0x0)
            SERVICE_EXIT_CODE  : 0  (0x0)
            CHECKPOINT         : 0x0
            WAIT_HINT          : 0x0
            PID                : 1376
            FLAGS              : 

    So tyhe service is running.  Then to my surprise, regedit worked (So I didn't need any more commandline wizardry and typos putting in long registry keys).  

    In short, it seems that the port is set for 3389 and it is enabled

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp]

    "AudioEnumeratorDll"="rdpendp.dll"
    "Callback"=dword:00000000
    "CallbackNumber"=""
    "CdClass"=dword:00000000
    "CdDLL"=""
    "CdFlag"=dword:00000000
    "CdName"=""
    "CfgDll"="RDPCFGEX.DLL"
    "ColorDepth"=dword:00000003
    "Comment"=""
    "Domain"=""
    "DrawGdiplusSupportLevel"=dword:00000001
    "fAllowSecProtocolNegotiation"=dword:00000001
    "fAutoClientDrives"=dword:00000001
    "fAutoClientLpts"=dword:00000001
    "fDisableAudioCapture"=dword:00000000
    "fDisableCam"=dword:00000000
    "fDisableCcm"=dword:00000000
    "fDisableCdm"=dword:00000000
    "fDisableClip"=dword:00000000
    "fDisableCpm"=dword:00000000
    "fDisableEncryption"=dword:00000001
    "fDisableExe"=dword:00000000
    "fDisableLPT"=dword:00000000
    "fEnableWinStation"=dword:00000001
    "fForceClientLptDef"=dword:00000001
    "fHomeDirectoryMapRoot"=dword:00000000
    "fInheritAutoClient"=dword:00000001
    "fInheritAutoLogon"=dword:00000001
    "fInheritCallback"=dword:00000000
    "fInheritCallbackNumber"=dword:00000001
    "fInheritColorDepth"=dword:00000000
    "fInheritInitialProgram"=dword:00000001
    "fInheritMaxDisconnectionTime"=dword:00000001
    "fInheritMaxIdleTime"=dword:00000001
    "fInheritMaxSessionTime"=dword:00000001
    "fInheritReconnectSame"=dword:00000001
    "fInheritResetBroken"=dword:00000001
    "fInheritSecurity"=dword:00000000
    "fInheritShadow"=dword:00000001
    "fLogonDisabled"=dword:00000000
    "fPromptForPassword"=dword:00000000
    "fReconnectSame"=dword:00000000
    "fResetBroken"=dword:00000000
    "fUseDefaultGina"=dword:00000000
    "InitialProgram"=""
    "InputBufferLength"=dword:00000800
    "InteractiveDelay"=dword:00000032
    "KeepAliveTimeout"=dword:00000000
    "KeyboardLayout"=dword:00000000
    "LanAdapter"=dword:00000000
    "LoadableProtocol_Object"="{5828227c-20cf-4408-b73f-73ab70b8849f}"
    "MaxConnectionTime"=dword:00000000
    "MaxDisconnectionTime"=dword:00000000
    "MaxIdleTime"=dword:00000000
    "MaxInstanceCount"=dword:ffffffff
    "MinEncryptionLevel"=dword:00000002
    "NWLogonServer"=""
    "OutBufCount"=dword:00000006
    "OutBufDelay"=dword:00000064
    "OutBufLength"=dword:00000212
    "Password"=""
    "PdClass"=dword:00000002
    "PdClass1"=dword:0000000b
    "PdDLL"="tdtcp"
    "PdDLL1"="tssecsrv"
    "PdFlag"=dword:0000004e
    "PdFlag1"=dword:00000000
    "PdName"="tcp"
    "PdName1"="tssecsrv"
    "PortNumber"=dword:00000d3d
    "SecurityLayer"=dword:00000002
    "SelectNetworkDetect"=dword:00000001
    "SelectTransport"=dword:00000002
    "Shadow"=dword:00000001
    "UserAuthentication"=dword:00000000
    "Username"=""
    "WdFlag"=dword:00000036
    "WdName"="Microsoft RDP 8.0"
    "WdPrefix"="RDP"
    "WebSocketListenerPort"=dword:00000d3b
    "WebSocketTlsListenerPort"=dword:00000d40
    "WFProfilePath"=""
    "WorkDirectory"=""

    I am at a loss, what do I do now?  I have some VMs to install and I wanted to use 2019 so I could try out the new admin centre, but I am going to have to reinstall at least one with 2016! (I'll leave the other running in case anyone has any tips)

    Any help would be greatly appreciated.  I know that MS had previously left out the RDSH.  Perhaps in putting that back in, some other related component has been broken and they'll issue a fix?



    I Code therefore I am John



    Wednesday, October 10, 2018 11:24 AM
  • Hey - same here - Hyper-V 2019 DE

    I'm also surprised that there is no update for the Hyper-V 2019 available on October patch day.

    For the management I'm using the "Windows Admin Center" - it's not only a workaround… it's a cool new tool for the administration.

    Did anybody noticed MS about this bug?

    Wednesday, October 10, 2018 11:28 AM
  • Ahhh… just forgot to mention. You could install Admin Center on any of your Windows 10 > 1709 Clients instead of RSAT for the management.
    Wednesday, October 10, 2018 11:34 AM
  • Hi,

    I can also confirm that it does not work, I've tried in many different scenarios with different settings but it won't help.

    This should definitely be logged as a bug here: https://windowsserver.uservoice.com/forums/295047-general-feedback so that they can fix it.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 10, 2018 11:50 AM
  • Logged it at that page

    I Code therefore I am John

    Wednesday, October 10, 2018 1:39 PM
  • Something else, is anyone able to add a Hyper-V 2019 server to VMM? I've just updated to VMM 1807 (https://support.microsoft.com/en-us/help/4135364/system-center-virtual-machine-manager-version-1807) but when I try to add a Hyper-V 2019 host, it's

    Error (20594)
    The Windows feature NetworkVirtualization could not be enabled on the computer <my hostnames> because of the following error: Unknown error (0x800f080c)

    I guess it's really to early to run on Hyper-V 2019, and even Server 2019 as that's been pulled as well. Shame, shame, shame. Not sure how MS' QA works nowadays, but for us, especially since those dreadful cumulative updates, it just doesn't work at all.

    [edit]

    Of course you have the same results as Leon, I already stated even netstat didn't show a listening port 3389, and the services were all running. Mind, really thanks for testing and spending your time!

    So it's clearly a bug, which is why I unproposed the answer. Reporting to uservoice has made literally 0 solutons for us the last 6 years, so that's a no go. Remember the Windows 10 1809 update deleting files? It was reported there tens of times. No cigar though.

    As soon as a fix is out, there is an answer.


    Thursday, October 11, 2018 8:51 AM
  • Hi Robert, 

    I agree with Leon, after testing in my lab, same result as Leon. So we could click the above user voice link to log and feedback this known issue, and I've already also reported to our products team with the situation as a hot issue. I trust it will be fixed soon. You kind patience and effort are very appreciated. 

    Regarding VMM issue, I suggest you refer to experts from System Center forum to get professional support:

    https://social.technet.microsoft.com/Forums/windows/en-US/home?category=virtualmachinemanager

    If you have any question or concern, please feel free to let me know. We'd love to hear any voice and feedback from our users.

    Best regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, October 11, 2018 2:36 PM
    Moderator
  • ive got the same thing going on....

    Thursday, October 11, 2018 6:31 PM
  • For your info, the recently released KB4464330 and KB4465477 do not fix this on our machines.
    Friday, October 12, 2018 6:51 AM
  • I've got this issue as well. Checked everything but couldn't get RDP to work on a Hyper-V 2019 core server.

    An other professional at a different technical forum reported the same problem. So I hope it will be fixed soon.

    Saturday, October 13, 2018 6:07 AM
  • I also cannot get RDP to work on a Hyper-V 2019 Server install. Have RDP enabled, firewall disabled, still nothing. 
    Thursday, October 18, 2018 4:02 AM
  • I hit this too.

    It was my very first attempt ever at installing Hyper-V (or any Windows-based virtualization), so I just assumed the problem was with me.

    Glad to see that I am not as stupid as my ex claims.

    mlavie58


    • Edited by mlavie58 Saturday, October 20, 2018 6:58 PM
    Saturday, October 20, 2018 8:18 AM
  • Dear All,

    Sorry for my delay.

    For now, MS is investigating this issue. I will update here once there's any update on this issue.

    Thanks again for your support and understanding.

    Best regards,

    Michael 


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, October 29, 2018 2:44 PM
    Moderator
  • Still not fixed in November 13, 2018 update, KB4467708 (OS Build 17763.134).
    Tuesday, November 20, 2018 11:32 AM
  • Still nothing. Not even with the build 17763.167 released yesterday in the Insider Preview branch.
    Unbelievable
    Wednesday, November 28, 2018 10:14 AM
  • all version have this problem w10 1809 w2019 server 1809 standard and datacenter all the connections freeze in RDP Mode. core or desktop.
    Thursday, November 29, 2018 7:12 PM
  • Same thing happens with the latest November update to the 2012 R2 RDP Gateway.  Solution there is to uninstall the November 13 cumulative.  In the 2012 R2 case, it appears to me like the issue has something related to TLS 1.0 being disabled.
    Saturday, December 1, 2018 6:31 AM
  • it is now 4 Dec and my hyper-v 2019 server core still has all the latest patches (ver says 10.0.17763.1 ) and RDP is still not possible. 

    Urs Rau

    Tuesday, December 4, 2018 9:38 PM
  • December patch round. KB4470788 and KB4471332. Still it's not working. What a joke.
    Friday, December 14, 2018 1:17 PM
  • Hi Michael,

    I should build a new Hyper-V based infrastructure. I can not wait any longer, I still use Hyper-V 2016?

    Thank you

    Alberto Grasso

    Wednesday, December 19, 2018 8:26 AM
  • Hi Michael,

    I should build a new Hyper-V based infrastructure. I can not wait any longer, I still use Hyper-V 2016?

    Thank you

    Alberto Grasso

    Same here. Tried to get it working but so i'll switch to 2016 and Windows 1803 for my VDI, thanks MS!
    Wednesday, December 19, 2018 4:16 PM
  • December 19th - KB4483235 - Still not working.
    Friday, December 21, 2018 9:18 AM
  • December 24. Still not working.

    BUT. I found temprary non-official solution: RDP Wrapper (google). Somehow it allow to connect to server via RDP.

    I guess that it's a problem with authentification type, 'cause when I start wrapper on win10 there is network level auth selected. But when I start it at server - nothing was selected.

    Mb someone identify where is a problem.

    Monday, December 24, 2018 7:43 PM
  • Same problem here! Fresh install with all updates available using dism /add-packages Before install on bare-metal.

    Dont work with RDP

    netstat show it is NOT listening to port 3389

    Changed port to 68 and restarted service without any luck.

    Changed network profiles on both lan to private without any luck

    Got out of ideas :-(  Downloaded "rdp wrapper" msi file and just installed it as is. No configuration whatsoever. Then it just worked at once.

    Netstat -ano shows 3389 port open too.

    Will run like this until MS has solved it. Lucky us there are third party Tools to help out from time to time. :-)

    • Edited by Magnus_KGA Friday, December 28, 2018 2:19 PM
    Friday, December 28, 2018 1:48 PM
  • RDP Wrapper gives me so much warnings, that I don't dare to install it. First Chrome refuses to download it and you find your way around that, all AV that I tried seriously warns against starting it.

    But I agree that it is VERY weird and even more annoying that MS's own tools don't work.

    Jan Z

    Monday, December 31, 2018 9:43 AM
  • This has had me stumped for hours, at least it is not just me.

    This is a very large oversight as you need RDP to manage Hyper-V Core.

    Hope this is not a sign that Microsoft is quietly dropping the free version of Hyper-V.


    • Edited by webwizuk Tuesday, January 8, 2019 11:15 AM
    Tuesday, January 8, 2019 11:15 AM
  • It would be ridiculous if this was a sign to phase out Hyper-V Server. Especially because there is an option built in to configure RDP. But never say never, it is Microsoft.
    They started "One Windows" and dropped support for Windows10 on mobile too...
    Tuesday, January 8, 2019 3:09 PM
  • *sigh*

    KB4480116 - January 8th - STILL not working.

    Monday, January 14, 2019 11:43 AM
  • It's so strange!

    Why doesn't Microsoft tell something about this problem?

    So many time has passed.

    Saturday, January 19, 2019 12:16 PM
  • Turn on ONLY TCP mode on client or server and all will work
    Monday, January 21, 2019 10:38 PM
  • Turn on ONLY TCP mode on client or server and all will work

    how?

    Friday, January 25, 2019 9:33 AM
  • Has anyone else tried the Remote Desktop App in the Windows Store. The RDP Client would not connect so I used this and connected ok.

    Friday, January 25, 2019 9:37 AM
  • January 22, 2019—KB4476976 (OS Build 17763.292) - still not working. Idiots.
    Tuesday, January 29, 2019 6:16 PM
  • Please all vote here:

    https://remotedesktop.uservoice.com/forums/266795-remote-desktop-services/suggestions/36669943-fix-hyper-v-server-2019-rdp-not-working

    Tuesday, January 29, 2019 10:29 PM
  • Anyone was able to get it running yet?

    Thx,
    V

    Friday, February 15, 2019 9:40 AM
  • Still not available, see this post:

    https://serverfault.com/questions/933761/windows-remote-desktop-service-running-but-not-listening-on-port-3389

    Friday, February 15, 2019 9:43 AM
  • run gpedit.msc from console

    and set GPO in Comp config > admin templates > Win components > Remote Desktop Services > Remote Desktop Session Host > Connections > to

    Close Editor and reboot your server

    Thursday, February 21, 2019 10:18 PM
  • Problem finally (and officially) fixed with the build 17763.348 (KB4482887) realeased today :-)

    Friday, March 1, 2019 10:56 PM
  • Problem finally (and officially) fixed with the build 17763.348 (KB4482887) realeased today :-)


    Do you have a link for the Hyper-V 2019 download? It's not on the Evaluation Center, nor in MSDN (I have an active subscription).

    Thanks.


    Davide Elessar Envinyatar Dúnadan


    • Edited by davide_c Saturday, March 2, 2019 3:16 PM
    Saturday, March 2, 2019 3:13 PM
  • Thanks @Monostatos  ; confirmed fixed with KB4482887  !! This was drivign me crazy :-)

    @davide_c: no need to re-install it from the ISO; just download the KB from http://www.catalog.update.microsoft.com/Search.aspx?q=KB4482887 

    then store it on a USB key and mount it on your Core Server, then from a command prompt install it using:

    Wusa KB.msu

    reboot when prompted and RDP will now work !!


    • Proposed as answer by charlston Tuesday, March 12, 2019 6:17 PM
    Sunday, March 3, 2019 8:29 PM
  • Link for HyperV2019 server: https://software-download.microsoft.com/download/pr/17763.1.180914-1434.rs5_release_SERVERHYPERCORE_OEM_X64FRE_EN-US.ISO
    Thursday, March 7, 2019 9:49 AM
  • I confirm that the KB above resolves the problem for HyperV Server 2019. I had to download it manually as it didn't show up in the updates of the server.
    Thursday, March 7, 2019 10:03 AM
  • Huzzah,

    Thanks for reporting back that it contained the fix. If anyone wants to create their own working ISO, I've written up the steps to do it here:

    http://www.c-amie.co.uk/technical/create-a-slipstreamed-hyper-v-server-2019-installation-image-with-working-remote-desktop/

    Thursday, March 7, 2019 8:01 PM
  • Yesssssssssss!!!!!!!! It worked. Thank you so much.

    Sunday, March 17, 2019 3:50 PM
  • This actually fixed mine too! Just wondering why Windows Update is not showing this patch :(

    Thanks @Monostatos !

    Saturday, August 3, 2019 2:54 PM