locked
"BDC Metadata Store is Currently Unavailable" when navigating to the External Content Types object in SPD 2010 RRS feed

  • Question

  • After installing SharePoint 2010 Beta and Sharepoint Designer 2010, opening Designer and navigating to the External Content Types object results in the following error:

    "The Business Data Connectivity Metadata Store is currently unavailable."

    Anyone else having this experience?

    Thanks
    Mark

    • Edited by Mike Walsh FIN Thursday, November 19, 2009 2:58 PM Title expanded
    Thursday, November 19, 2009 1:17 PM

Answers

All replies

  • After installing SharePoint 2010 Beta and Sharepoint Designer 2010, opening Designer and navigating to the External Content Types object results in the following error:

    "The Business Data Connectivity Metadata Store is currently unavailable."


    Did you do a single click install or a farm based install? The single click installs should setup a BDC Service for you, while farm installs will not.

    First thing to check is to go to the Central Admin page, then click "Manage Service Applicaitons". You should see a "Business Data Connectivity Service" entry (well, 2 really - one for the service application, one for the service application proxy). If you don't have one, create one via the ribbon.
    • Edited by Mike Walsh FIN Sunday, November 29, 2009 11:20 AM No need to use full quote. In this case - as the first reply in a thread - there was also no need for any quote as it is clear what you are replying to,
    Friday, November 20, 2009 6:41 PM
  • I believe I had the same problem when I had installed on Server 2008 R2 without the WCF fix (see the Installation notice:  http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx)

    What does your install look like?

    • Marked as answer by markm247 Friday, November 20, 2009 9:28 PM
    Friday, November 20, 2009 7:14 PM
  • Thanks Raymond - This was the issue. Thanks to Jie Lie for his post pointing out the same.
    Friday, November 20, 2009 9:30 PM
  • I'm having this issue on Windows 7 x64 and looks like that article applies to Server 2008 only?  Is that right?
    Saturday, November 28, 2009 1:03 AM
  • That WCF fix is needed for both Windows 7 x64 and for Server 2008 R2.
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Saturday, November 28, 2009 7:14 AM
  • I've got the same problem, but the WCF fix didn't fix my problem. I've got the BDC service running and have setup a Service Application for it. Both seem to work fine, no errors. But when trying to create a new external content type from SPD, the above error is displayed when I click "External Content Types".
    MCTS in Web Application Development in .NET 2.0
    Sunday, March 14, 2010 2:47 PM
  • I found that A: sequence of what i installed (VMWare workstation 7 x64 -> server 2008 R2 -> SQL 2008 R2 CTP-> Office 2010 Web Apps-> WCF fixes -> Sp 2010 ) seemed to resolve the issue I had.  Had to run a couple of power shell scripts to allow me to install in a single VM without using a domain account and had to apply the fixes about and also there was a ps script for SQL 2008 R2, I think.
    Sunday, March 14, 2010 5:48 PM
  • Hmmm but no definite/conclusive fix though. Perhaps someone @ MS is willing to look into this? Don't think they want this ending up in the RTM version :)


    MCTS in Web Application Development in .NET 2.0
    Monday, March 15, 2010 7:20 AM
  • I get this also.  The WCF hotfix is installed on the sharepoint box, and I still get the error.  Any more thoughts?
    Friday, March 19, 2010 1:40 AM
  • I'm also experiencing the same issue while having the hot-fix installed.  I've tried uninstalling/resinstalling the hotfix, creating new BDC service applications, etc. but nothing seems to work.
    Friday, March 19, 2010 11:00 PM
  • I'm still stuggling with it too. Unfortunately the option Raymond gave was marked as an answer which it clearly isn't in all cases. I hope people who do have the answer don't overlook this thread because it's marked as answered...
    MCTS in Web Application Development in .NET 2.0
    Saturday, March 20, 2010 2:38 PM
  • I had this problem and think it is related to the interface between SP2010 ans SQL.

    Reinstalled my VM from scratch (VMWare 7 x64)

    Patched it

    Installed SQL 2008 R2 CTP

    Patched it, ran the power shell script that realtes to security issues

    Installed Office Web Apps 2010 Beta

    Installed SP 2010 Beta 2

    Installed eveything in a single VM

    Now works

    Saturday, March 20, 2010 4:45 PM
  • For those of you still experiencing the issue, I'd be curious to see if there is anything keeping SPD from talking with the BDC Admin Service.  Can you try:

    1) Install fiddler if you don't already have it (http://www.fiddler2.com)
    2) Open SharePoint designer and open your site
    3) Open fiddler and make sure it is capturing
    4) Click on the External Content Types object
    5) Check fiddler

    There are two things I'd look for:

    1) What is the host and URL it is trying to connect to?
    2) Are there a large number of 500 or other errors?  <-- (my build works but I do still get a few 500 "errors")

    Saturday, March 20, 2010 5:26 PM
  • You're on to something there! But instead of 500's, it's 401's (unauthorized) followed by a lot of 302 redirects untill SPD comes with the unavailable error. It seems SharePoint is redirecting SPD to the windows login page (_windows/default.aspx) and then goes back and forth to /_vti_bin/BDCAdminService.svc/BDCAdmin. If I browse to the same location with IE, nothings wrong. Other calls to the services in _vti_bin work fine, so I'm curious why this one wouldn't. Any ideas?

    Update: when I try to access the actual WSDL, I get an error in IE too: http://localhost/_layouts/error.aspx?ErrorText=The%20Audience%20URI%20could%20not%20be%20validated%2E with the text "An unexpected error has occurred."

    Update 2: fixed the authentication error by mapping the complete network name (host.network.local) as an alternate access mapping. Now I can access the WSDL in IE just fine, but SPD still gets 302's.

    Update 3: tried enabling anonymous access on the site, didn't change anything.


    MCTS in Web Application Development in .NET 2.0

    Sunday, March 21, 2010 8:04 PM
  • Can you tell us how your security is configured?  Are you using classic mode or Claims-based authentication?  Forms Authentication by any chance?  NTLM/Kerberos?

    Monday, March 22, 2010 2:58 AM
  • I eventually got it fixed.  I was not running the same version of SPD as SharePoint 2010.  They have to be exactly the same build.  I really hope this is not going to be the case come RTM, as it will cripple doing SharePoint patches if you have to roll an Office patch at the same time.
    • Proposed as answer by Mario_SPSGuy Tuesday, March 23, 2010 12:43 PM
    Monday, March 22, 2010 3:01 AM
  • @ Raymond: It's a default site running claims based authentication with NTLM / Kerberos. I have another site setup for forms authentication, but that's not the one I try to connect to (the other one is showing the same behaviour though).

    @ donal.colon: how did you check the versions and where is a new one / patch obtainable?


    MCTS in Web Application Development in .NET 2.0
    Monday, March 22, 2010 7:40 AM
  • Is there any chance you could try setting up another site with classic mode authentication and see if that works?  I'm not sure why the claims-based wouldn't work but it is worth a try! :-)
    Monday, March 22, 2010 1:01 PM
  • @siegmund If you go to Programs and Features, you will see the versions listed there.  My customer is on the TAP program so we have access to later builds.

    Another thing to confrm is that the BCS service is associated with the web application you are hitting.  Go to Manage Web Apps, select the web application, and click Service Connections.

    • Proposed as answer by stewpot22 Thursday, November 4, 2010 12:20 PM
    Monday, March 22, 2010 1:21 PM
  • The service connection is okay. I don't have access to the later builds, so I'm guess I'm outta luck on that one.

    I'll try setting up a classic mode site. I do have one, but that mixed mode authentication and it doesn't work either. Havent tried fiddler on it though, so I'll post some test results on that later on.


    MCTS in Web Application Development in .NET 2.0
    • Proposed as answer by Mario_SPSGuy Tuesday, March 23, 2010 12:42 PM
    Monday, March 22, 2010 1:52 PM
  • donal.conlon is right. I have verified the issue. I was using SPS2010RC but with SPD2010Beta. You must use a new version of SPD with the same build number as SPS has. That worked for me.

    Tuesday, March 23, 2010 12:46 PM
  • Any of you guys willing to help me out in getting that newer build?
    MCTS in Web Application Development in .NET 2.0
    Tuesday, March 23, 2010 2:30 PM
  • Sorry J.Siegmund.  We are bound by an NDA under the TAP.  Can't even talk about it!! :(.  If I could, I would.
    Tuesday, March 23, 2010 3:07 PM
  • @JSiegmund: Should be the same location where you have got the SPS2010RC from ;-)

    Sorry

    Tuesday, March 23, 2010 4:48 PM
  • I'm not following. I've downloaded the SP2010RC from Microsoft public download site since it's publicly available. That's the same location as where I found SPD, but apparantly those versions don't match 100%? So there's a newer build available for partners under the TAP, I'll check if we have access to that (we're an official partner, but I'm not sure if that's enough).
    MCTS in Web Application Development in .NET 2.0
    Wednesday, March 24, 2010 8:41 AM
  • Success!

    It seems the authentication mode does have an effect on this. I've setup a second site with classic mode authentication and voila; it works fine there. I haven't been able to fix it with the claims based site, but that might be already a bug fix in SPD as noted above.


    MCTS in Web Application Development in .NET 2.0
    Wednesday, March 24, 2010 2:06 PM
  • For anyone else that comes across this post, I resolved this issue (with the RC of SharePoint 2010 and SPD) with the following hotfix:

    http://support.microsoft.com/default.aspx/kb/976462?p=1

    That's it, good luck!

    Monday, March 29, 2010 7:45 PM
  • I already had this one, didn't make any difference in my case.
    MCTS in Web Application Development in .NET 2.0
    Tuesday, March 30, 2010 6:38 AM
  • I had the similar problem before. I was using SP2010 beta 2 And I figured out that the cause for this is either the BDC service on your farm is stopped or You might need to create new BDC service for your web application. PS : I have used Farm admin account to do this and I had all hot-fix installed.

    Please look into this for detailed workaround : BDC Unavailable

    Hope this will help.

    MCPD (PRO: Designing and Developing Web-based Applications by Using the Microsoft® .NET Framework 2.0) MCTS (MOSS 2007 - Application Development)
    Wednesday, March 31, 2010 12:48 PM
  • I am having this problem and have all RTM.  I gave a demo to client that worked great.  Afterwards I did run the Windows Security Wizard which configured the firewall but I don't think that was the problem as the I turned the firewall after experiencing this problem.  BDC was not installed so if that is required, I don't know how this all worked when I gave them demo, unless the Windows Security Wizard uninstalls that.  Anyone notice this problem in the RTM?

    Saturday, July 31, 2010 5:21 AM
  • So I created a BDC and added to my application.  But when I click on BDC in the Manage Service Applications, I get:

     

     

    Error

    There are no addresses available for this application.

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: a5378494-340b-4b5c-95ef-e95b86d406ac

    Date and Time: 7/31/2010 1:33:03 AM

    Saturday, July 31, 2010 5:34 AM
  • I rolled back the Windows Security Wizard profiles/changes and it all works now.
    Saturday, July 31, 2010 6:13 AM
  • If you did not run the farm configuration wizard (good that you're not loading your server with un-necessary services). you need to start the BDC service application from services on server page. Windows Application Event indicates this. Hope this helps.

     

    Monday, September 27, 2010 3:29 PM
  • In SP Designer I had to specifically connect to my application server running the bcs service to get this working. When I referenced the web server it wouldn't work.
    So:
    Connecting to SPWEB1 gave me the error.
    Connection to SPAPP1 works fine.

    Cheers,
    Xopher

    Friday, October 22, 2010 8:51 PM
  • Many thanks, was trying everything suggested and this one did the trick for me!

    "Another thing to confrm is that the BCS service is associated with the web application you are hitting.  Go to Manage Web Apps, select the web application, and click Service Connections."

    Thursday, November 4, 2010 12:21 PM
  • Hi may I know the settings for creating the BDC. I deleted the one that was already there because I was unable to create External Content Types on SPD 2010. A guide told me that I should try deleting it and create a new one. I tried that but it's still not working. Please help. TIA :)
    Wednesday, March 23, 2011 3:07 AM
  • dears, I found the solution in this blog.
    Now it's working with me. :)
    http://blog.armgasys.com/?p=133
    Monday, January 2, 2012 7:27 AM
  •  It seems that there are a few issues that cause this problem. After seeing the "The Business Data Connectivity Metadata Store is currently unavailable" message, when I tried  to create a new external content type I got the message "The remote server returned a '(407) Proxy Authentication Required".

    I have resolved this issue by going to IE settings: Tools> Internet options > Connections > LAN Settings and unticking the "Auto Detect Settings" option.


    Tuesday, September 11, 2012 1:01 PM