locked
Cannot sign in with mobile app RRS feed

  • Question

  • Hi,

    I have an issue with an on premises Skype for Business Server. Since installation I haven't been able to get the mobile client (both iOS and Android) to work. The PC client is working fine both internally and externally fine though.

    Client always says 'You've been signed out. We need your account info to sign back in' no matter what when using anything address with the sign in domain. This is even if using the wrong credentials

    A quick overview of what I've checked;

    • lyncdiscover is NAT'd to 8080/4443 and resolving correctly
    • XML is being responded
    • Can see in Fiddler the XML being returned but nothing after that
    • Server is updated to latest CU
    • External access and mobility policies are ok

    Not sure where to go from here?

    Saturday, October 6, 2018 11:54 PM

All replies

  • Hi,

    External Web Services needs to be published externally, mobile clients won't work without it.

    You've said that you are using NAT, its highly advisable to deploy a Reverse Proxy.  Also, I'm assuming that you've set the External Web Services to use a third party trusted SSL certificate, otherwise the mobile devices won't trust it?

    Sunday, October 7, 2018 1:32 PM
  • Hi Raphael,

    Which network environment did you use? Wifi or cellular traffic. Please confirm connection the without any break.

    If you set your account in another computer, does the issue persist?

    Do other users in your organization have the same problem?

    If all users have this issue in same time, you could check the connect of reverse proxy. You could check the event ID of reverse proxy.

    If some user have this issue, you could export the SFB mobile client log, filter the log by timeline.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, October 8, 2018 7:27 AM
  • Hi,

    I have an issue with an on premises Skype for Business Server. Since installation I haven't been able to get the mobile client (both iOS and Android) to work. The PC client is working fine both internally and externally fine though.

    Client always says 'You've been signed out. We need your account info to sign back in' no matter what when using anything address with the sign in domain. This is even if using the wrong credentials

    A quick overview of what I've checked;

    • lyncdiscover is NAT'd to 8080/4443 and resolving correctly
    • XML is being responded
    • Can see in Fiddler the XML being returned but nothing after that
    • Server is updated to latest CU
    • External access and mobility policies are ok

    Not sure where to go from here?

    Hi Raphael,

    it might be a certificate issue. just simply test by browsing to your external web service url from a third party computer or use SSL Labs. com

    if you get a certficate error, you need to install the root and intermediate certificate on the mobile devices.

    regards

    Monday, October 8, 2018 2:45 PM
  • Hi,

     

    Are there any updates for this issue, if the reply is helpful, please try to mark it as an answer,  it will help others who have similar issue.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, October 15, 2018 9:30 AM