Printing an SSRS Report on a Windows 7 Client Prompts for Elevation RRS feed

  • Question

  • Environment:

    • Servers: Windows Server 2008, SQL Server 2008 R2
    • Desktops: Windows 7 Pro 64-bit with UAC enabled
    • Users: All users are standard users.

    We have a financial reporting application(browser based) which uses SSRS to create custom reports on client portfolios.  This works great up until a user clicks the print button on the page.  At this point UAC pops up requiring admin credentials.  If the user restarts their browser, they will once again be prompted for credentials when they go to print SSRS reports again.

    Is there any workaround for this, or a client side install I can push out to my desktops to resolve this issue?




    • Edited by Zak Lyles Thursday, December 1, 2011 9:40 PM
    Thursday, December 1, 2011 9:38 PM


All replies

  • Hi Zak,

    I believe your question is related to Windows 7 issues so I recommend you to post your question here http://social.technet.microsoft.com/Forums/en-US/category/w7itpro


    Sunday, December 4, 2011 8:22 PM
  • Hi Zak Lyles,

    Before posting the question to the thread Shahfaisal posted, could you verify it as following:

    • Disable UAC and then try again
    • Grand the user logging the Report Manager or Report Server with Admin permission and then try again


    Please remember to mark the replies as answers if they help.
    • Marked as answer by Lola Wang Tuesday, December 13, 2011 9:54 AM
    • Unmarked as answer by Zak Lyles Tuesday, December 13, 2011 3:54 PM
    Wednesday, December 7, 2011 8:42 AM
  • We have already tested with UAC disabled, which still throws an error but if you continue past the error it will print correctly.  This however is not the solution I am looking for, as disabling UAC increases the difficulty of managing Windows 7 workstations when users are logged in as standard users.

    The users don't login to report manager or the report server.

    As stated above, we use a browser-based financial portfolio management system.  One section of the many available reports is for SSRS reports.  The reports pull up and displays in the users web browser with no issues.  It is not until the user attempts to print the report that they are prompted for admin credentials.

    This works perfectly fine on Windows XP as a standard user, but not Windows 7 with UAC.




    • Edited by Zak Lyles Tuesday, December 13, 2011 4:24 PM
    Tuesday, December 13, 2011 4:18 PM
  • Hi Zak,

    Did you resolve this issue?

    We are having the same issue, on a Citrix server running Server 2008 R2.

    We also do not want to turn off UAC.



    Friday, February 10, 2012 2:34 PM
  • I am having the exact same problem.

    The users are not local administrator on their laptops, nor is disabling UAC an option.

    I found this workaround on the Microsoft Connect site but it has no effect.

    It would be nice if someone from Microsoft would PLEASE respond to this issue. We have just deployed a Reporting Services solution, and without the ability to print reports, our solution is quite frankly useless.

    • Open Internet Explorer 8, click Tools, click Internet Options, and then click Security tab.
    • Click the Local Intranet zone, and then click to clear the Enable Protected Mode check box.
    • Click the Trusted sites zone, and then click to clear the Enable Protected Mode check box.
    • Restart Internet Explorer 8.

    A. M. Robinson

    Thursday, April 19, 2012 9:44 PM
  • I recently took another crack at this with one of our developers and we finally found a solution.

    The following link will provide more details on the issue as well as how to create an MSI installer to deploy the fix to your organization via Group Policy.


    After following the instructions in the post, I installed the MSI on a test workstation and printing SSRS reports worked like a charm.


    • Edited by Zak Lyles Wednesday, June 6, 2012 5:42 PM
    • Marked as answer by Zak Lyles Wednesday, June 6, 2012 5:42 PM
    Wednesday, June 6, 2012 5:41 PM